はじめに

はじめに-BkASPilの概略

BkASPil（ビーケーアスピル）はWindows用メールソフト「Becky!InternetMail」（ベッキーインターネットメール）向けに作られたスパム対策用プラグインです。（用語解説：スパム、プラグイン）

  その機能は大きく二つに分かれています。

  1. spamフィルタリング（振り分け）機能
  2. spam処置依頼メール作成支援機能（SpamCop宛メール作成支援機能を含む）

■Ａ：spamフィルタリング機能

  メールを受信する際、spamメールだけを指定のフォルダやごみ箱フォルダに振り分ける機能です。
  当プラグインでのフィルタリングは「ユーザ同士でspamメール情報を共有化する方式」と「spamメールの内容を分析・解析して『spamらしさ』を判定する方式」の二つの方式から行っています。

  「ユーザ同士でspamメール情報を共有化する方式」とは、spamを受け取ったユーザからの情報などを用いて共有データーベースとしてのspamブラックリストを作成し、そのリストを用いて同類のspamメールを他のユーザがspamと判定できるようにするものです（この方式を「ブラックリスト参照方式」と呼んでいます）。

  「spamメールの内容を分析・解析して『spamらしさ』を判定する方式」とは、以前に受け取ったメールの内容をベイズ理論というもので分析・学習し、そのデータベースを用いて新しく受け取るメールがspamであるかを判定する方式であり、一般に「ベイジアンフィルタ」と呼ばれています（当プラグインでも「ベイジアンフィルタ方式」と呼びます）。
  この方式のフィルタリングは2003年以降の各種spamフィルタリングで多く採用されるようになっています。

（用語解説：フィルタリング、ブラックリスト、ベイジアンフィルタ）

■Ｂ．spam処置依頼メール作成支援機能（SpamCop宛メール作成支援機能を含む）

  spamを受信した時のアドバイスとして日本では「無視と削除」を勧められることが多いようです。
  その一方で、海外を中心として
「spam送信に利用されたネット業者に通報し、spam発信者とその行為に対処をするよう依頼しましょう」
というアドバイスも行われてきました。ネットワーク管理者（ネット業者）はspam受信者からの通報を元にspam発信者に各種の対処を行い、spam抑止に向けて日々取り組んでいます。（用語解説：ネットワーク管理者、ネット業者、spam処置依頼）

  spamメールはその性質上、受信した本人でなければ真っ当な大量配信メールと区別することがなかなか困難です。加えてメールの検閲は行われるべきでないという認識が一般的であるため、spamが発信されたかどうかはspam被害者(受信者)から提供される連絡・報告が重要な情報源となります。
（→参考：参考資料「spam処置依頼メール送信の正当性」）

  しかし残念なことに、スパム受信者が「受け取ったspamそれぞれの適切な処置依頼先」を見つけることは、必ずしも簡単ではありません。なぜなら電子メールでは差出人メールアドレスを詐称することが可能であり、メールを一見しただけでは発信者がどこのサーバを使ったかが分からないからです。

  当プラグインのＢの機能は個々のspamに関する正しい処置依頼先を見つけ、そこに処置依頼メールを送ることを支援し、容易にする機能です。

目次へ
このページの最新版をオンラインで見る（画像付き）
→次の頁へ


特徴・機能と動作環境、著作権

●特徴・機能

［フィルタリング部］

  • ごみ箱フォルダや特定フォルダへspamメールを自動振り分け(フィルタリング)
  • spam判定では「ユーザ間で情報共有するブラックリスト参照方式」と「ユーザ個別に学習が行われるベイジアンフィルタ方式」とを併用（日本語対応済）
  • 「ブラックリスト参照方式」ではspamの発信、中継サーバのIPアドレスをユーザ間で共有化
  • 「ベイジアンフィルタ方式」の導入により定常フィルタリング率を平均60％から90％以上にまで向上（当チーム比、2004年前半現在）
  • 「ベイジアンフィルタ方式」用の学習データベースは「ブラックリスト参照方式」でspamと判断されたメールから「自動学習」することにより行い、手動学習での労力を軽減化（「スパムフィルタの概要」を参照のこと）
  • spamとして振り分けされたくないメールは特定の差出人メールアドレス、IPアドレスなどをホワイトリストとしてローカルに登録することが可能

［処置依頼支援部］

  • spam処置依頼メールを送るための様々な支援機能
  • 対スパムツール集との連動により、メールヘッダを解析し、spam発信に利用されたサーバに関する情報を速やかに調査可能
  • spam処置依頼には必須の「ヘッダ＋spam本文」を引用したメールがすぐに作成可能
  • Becky!標準のテンプレートと組み合わせたメール作成機能により、柔軟なspam処置依頼メール作成が容易

［共通部］

  • マウスジェスチャーの導入による各種作業の効率化
  • ホットキーによる各種作業の効率化

●動作環境

対応OS
  ・Windows98、98SE、NT、Me、2000、XP
  ・InternetExplorer Ver.4以降が必要
  ・「地域と言語のオプション」の「標準と形式」を「日本語」にしていることが必要（これに関しては質問回答「プラグインが文字化けします」を御参照下さい）

メール環境
  POP3対応（IMAPは対応していません）

推奨スペック
  CPU：Intel 300MHz以上
  メモリ：160MB以上

インターネット接続環境
  常時接続を推奨

その他
  「Becky!InternetMail」Ver.2.08（日本語版）以上を導入済みであること。
  （それ以前のバージョンのBecky!では動作しません）

●著作権

  BkASPilプラグイン本体の著作権は「高柳良充」（ハンドルネーム・BNR32）が所有しています。転載、及び配布は自由に行なって頂いて結構ですが、パックされた内容の変更のないようにお願いします。(転載後は事後でも連絡頂けると幸いです)

  フィルタリング絡みのサーバシステム関係の著作権は「松永香澄」が所有しています。

  ヘッダ解析等に関する対spamツール集の著作権および本解説書の著作権は「高崎真哉」が代表して管理しております。

  システム全体における著作権は「BkASPil開発チーム」（高柳、松永、高崎）が所有しています。

目次へ
このページの最新版をオンラインで見る（画像付き）
←前の頁へ


重要告知と新機能・修正点

●重要告知

2005/07/30
  プラグイン自体のバージョンアップは頻繁なのにヘルプの改訂は一年ぶりで恐縮至極。（担当がＴだから。おいおい）

●新機能・修正点

～2005/07/30 大きな変更点

  • ベイジアンフィルタの対象に日本語のメールも含むようにした。
  • ベイジアンのspamデータをバックアップ、インポート、エクスポートなどが出来るようにした。
  • ホワイトリストへのメールアドレス登録で「アドレス帳からの一括登録」が出来るようになった。
  • その他、高度な設定を中心に変更点いろいろ
  • その他いろいろバグ修正


この解説書(ヘルプ)についての情報

●注意点

  この解説書はプラグイン自体の仕様変更・バージョンアップに遅れて改訂されますので御了承下さい。最新の改訂はオンライン版にもっとも早く反映されます。

●解説書の種類

正式版(フルバージョン)
  取り込み画像を豊富に使って解説しています。容量が大きく、4MB弱あります。（参考：4MBのデータのダウンロード時間→アナログモデムで約16分、ISDNで約9分、ADSLで約１分以内）
  「ダウンロードのページ」から入手できます。

軽量版（シンプルバージョン）
  配布に便利なように正式版から画像のほとんどを省いたものです。大きさは700KB（正式版の5分の１）ほどにおさえています。プラグインに添付しており、設定の「ヘルプボタン」から呼び出すことが出来ます。

オンライン版
  ネット上で公開しているもので基本的には正式版と同じですが、内容がもっとも迅速に改訂されます。正式版、軽量版の各頁からリンクが張られており、インターネットに接続していれば正式版、軽量版から速やかに参照することが可能です。
  オンライン版であることが分かりやすいよう、他の二つと異なり緑を基調とした色調にしております。

●当解説書の更新記録

2005/07/30　第2.5.1版（正式版、簡略版改訂）
  ベイジアンフィルタに関する設定等を中心に改訂。
2004/08/06　第2.4版（正式版、簡略版改訂）
  ベイジアンフィルタ導入に伴い全面的に改訂を実施。
2004/01/22　第２版（正式版、簡略版改訂）
  全面的に校正、改訂を実施。オンライン版の色調を緑にする。
2004/01/20　第1.1版
  インストールツールの変更、「高度な設定」タブの複数化に反映。FAQを大幅増補。
2004/01/15　第1.0.1版
  アンインストール方法の変更を反映。
2003/08/29　初版作成(正式版、簡略版改訂)

●当解説書（ヘルプ）での用語と参考画面について

  当解説書（ヘルプ）で使用している用語、紹介しているコンピュータ画面は後述のシステム条件下で得られたものですが、ユーザ各々方の環境により画面や名称、雰囲気が異なる場合が多々発生しますので、適宜御自分の環境に合わせて御理解して頂きますよう御願いいたします。
  また、当プラグインのバージョンアップに伴って設定画面等が少しずつ変化しておりますが、その都度当解説書内の全ての画像を入れ替えているわけではありませんので、当解説書内の画面は皆様の御覧になる画面と異なる場合があること、全体的に統一が取れていないことを御了解願います。
  なお、各種の用語に関しては用語集で解説しているものがありますので、御参照下さい。

［当ヘルプの作成された環境］

  • オペレーションシステム：Windows XP Professional (Microsoft Corporation)
  • 画面配色(LUNAスキン)カスタマイズ指南サイト
    「StyleXP （TGT Soft）」　http://www.tgtsoft.com/
    「スキンぐらい好きんにさせてくれよ！」　http://kuraba-web.hp.infoseek.co.jp/xp/
    「XpSkinNet」　http://www.xpskin.net/
    「ThemeXP」　http://www.themexp.org/

●当解説書の作成で利用したソフト

この解説書(HELP)を作るにあたっては以下のソフトなどを利用させて頂きました。厚く厚く感謝いたします。

  • 「ヘルプましん」（うな<藤山祐一>氏作成)
    http://homepage3.nifty.com/KaeruMachine/
  • 画面取り込みソフト「キャプラ」
    クリップボード監視ソフト「クリップアウト2000」
    （チャッピーのパパ 氏作成）
    http://homepage1.nifty.com/chappy/
  • 画像表示・効果ソフト「IrfanView」
    http://www.irfanview.com/
  • FrontPage 2000 (Microsoft Corporation)

●各種商標など

Microsoft、Windows、WindowsXPなど は、米国Microsoft Corporationの米国およびその他の国における登録商標です。

Becky! Internet MailはRimArts の登録商標または商標です。

その他、このヘルプ記載の社名、商品名は各社の登録商標、商標です。


免責

［振り分けの誤判定に伴う損失］

  このプラグインはspamと想定されるメールを別フォルダに振り分けますが、振り分けの際の判定は100%確実なものではありません。「スパムメールをspamと判定できない」「spamではないメールをスパムメールと判定する」などの誤判定がしばしば発生します。
  プラグイン利用者の大切なメールが誤って振り分けられ、読み損ねる危険性が常に発生します。その危険性を十分に了承し、利用者各人の自己責任により当プラグインを使用してください。

  誤った振り分けに起因する損失を含め，当プラグインを使用したことによるいかなる損害（逸失利益、機密情報若しくはその他の情報の流出、プライバシーの漏洩、金銭的損害など、これらに限らない諸々の被害) に対してBkASPilプラグイン開発チームは一切責任を負いません。

  上記の類の損害は、プラグイン利用者のみならず、利用者にメールを出した発信者も被る可能性がありますが、そのあらゆる損害に関しても開発チームは責任を負いません。当プラグインで振り分けされるメールの発信者側が被る利益に関しては、メール受信者であるプラグイン利用者の方々が負うものとさせて頂き、発信者と受信者（プラグイン使用者）との間で解決して下さい。

［当プラグインを利用したメール発信に伴うトラブル、損害］

  当プラグインは各種の解析機能との連携により、spam処置依頼を目的としたメール作成を容易化する機能を備えています。しかしながら本機能は、大量にメールを配信する機能や悪意あるメール（ウイルス付きメールなど）を作る特殊な機能を持っているわけではなく、あくまで通常のメールの作成を支援する機能にとどまっております。
  ですから、プラグイン利用者がこれを利用して発信したメールに関して起こるトラブルや損害に関し、開発チームは一切責任を負うことは出来ません。

［当プラグインのサービス停止］

  当プラグインとそれに付随する各種サービスはボランティアによる有志によって提供・運営されています。サーバメンテナンス等のため告知無しにサービスが中断する場合もありますし、提供メンバーの各種事情により突然サービス自体が提供できなくなる恐れもあります。それらの可能性も含め、当サービスに関する苦情は受け付けかねますので御理解下さい。

  以上の条件に同意されない場合、本プラグインの使用はできません。なお、当プラグインにより開発チームが得る各種情報の取扱については、当プラグイン開発チームの「個人情報取扱指針・当プラグインの目的と方針」も参考にして下さい。


プラグインのインストール

1．「Becky!InternetMail」は既に導入されていることを前提とします。Becky!のバージョンに御注意下さい。（参考→「動作環境」）
  まず、Becky!を終了します。

2．プラグインBkASPilのダウンロードをします。以下の場所からダウンロードを行って下さい。

BkASPil総合案内頁のダウンロード頁

  ダウンロードの際、「ファイルによってはコンピュータに問題を起こす可能性があります云々」と出てくることがありますが（下図参照）、了解した上で「保存」を選んで下さい。
  無論、当プラグインには悪意的なプログラムは入れていませんが皆様のあらゆる場合の環境で問題を発生しないとは保証できません。（参考→「免責」）

3．保存する場所を適宜選択します（下図参照）。

4．ダウンロードが終わるとそのファイルの処置の方法を尋ねるダイアログが出てきます（下図参照）。「ファイルを開く」を選択します。もし「フォルダを開く」や「閉じる」を選択してしまった場合には、保存したファイルを「マイコンピュータ」や「エクスプローラ」から見つけだし、ダブルクリックして下さい。

5．インストールの開始とインストールする場所に関して尋ねてきます（下図参照）。
  「Becky!InternetMail」のプラグインは一般的に、「Becky!InternetMail」のプログラムが入っている所の「Plugin」というフォルダか、メールボックスの所の「PlugIn」というフォルダのどちらかにインストールされます。（参考→参考資料「プラグインフォルダの位置」）
  どちらか適当な方を選んで「次へ」を押して下さい。

6．インストールが開始されます。場合によっては何も反応がなくなりますが、しばらく待って下さい（10秒以上）。セットアップが無事終了した旨のダイアログが出てきます（下図参照）。完了を押します。必要であればチェックボックスにチェックをして下さい。

7.注意書きである「BkASPil.txt」が表示されます。御確認下さい（下図参照）。

8．その後、初めてBecky!を起動する際、プラグイン「BkASPil」を導入して良いか確認するダイアログが出てきます。確認した上で「ＯＫ」を押します（下図参照）。

9．以上でインストールは完了ですが、当プラグインはフィルタリングシステム維持のため、導入後、インターネットを通じて関係サーバへの自動アクセスを行います。十分にその性質を御理解の上でお使い下さい。

  当プラグインを導入したことによるメール亡失などの危険性を避けたいならば、速やかに手順解説「フィルタリング機能の基本設定」「フィルタリング機能の停止」にて適切な設定を行って下さい。


プラグインの削除

プラグインの削除(アンインストール)

１．最近の版の場合(Ver.1.003以降)

  アンインストールをしたい場合にはBecky!インストールフォルダ内の「bkpiinst.exe」を実行してください（下図参照）。それ以降はそのソフトの指示に従って下さい。

  なお、上記のアンインストールを行っても当プラグインが作成したデータなどが残ることがあります。それらのデータも消したい場合、あるいは不具合発生の際のトラブル解決としてアンインストールを行いたい場合には、次ページ以降の「不具合が発生したら（２）　当プラグインの完全削除」に書いてある完全に削除の措置を取ることをお勧めします。

  アンインストールをするとホワイトリスト、スパム集計、spam学習データベースなどが消去されますので御注意下さい。ちなみに当プラグインはレジストリには情報を書き込んでいません。

２．古い版の場合（Ver.1.002以前）

オペレーションシステムの
「プログラムの削除と追加」（もしくは「アプリケーションの追加と削除」）
から「B2 PlugIn -BkASPil」を削除して下さい（下図参照）。

  上記のアンインストールを行っても、当プラグインが作成したデータなどが残ることがあります。それらのデータが残っていると不具合が発生する場合があります。不具合発生の際のトラブル解決としてアンインストールを行いたい場合には、次ページ以降の「不具合が発生したら（２）　当プラグインの完全削除」に書いてある完全に削除の措置を取ることをお勧めします。

  アンインストールをするとホワイトリスト、スパム集計、spam学習データベースなどが消去されますので御注意下さい。ちなみに当プラグインはレジストリには情報を書き込んでいません。


導入した際に不具合が発生したら（１） 一時停止

導入直後に不具合が発生したら（１）　一時停止

  当プラグインを導入してからすぐに不具合が発生した場合、Becky本体が起動するならば当プラグインを一時停止することが出来ます。
  まずは一時停止をさせて不具合が継続するか確認してみて下さい。それでも不具合が継続する場合（Becky自体が起動しないなどの場合）には、一旦当プラグインのアンインストール（完全削除）を行いましょう。

●当プラグインを一時停止してみる

  Becky!が起動する場合には当プラグインをアンインストールすることなく、当プラグインの起動を一時停止することが可能です。この「特定のプラグインの一時停止」はBecky!の標準機能です。

Becky!メニューバー「ツール」－「全般的な設定」を選択
「高度」タブ－右下のプラグインボタン－「BkASPil.DLL」のチェックボックスを外す（下図参照）

  このようにするとBecky!を起動しても当プラグインを読み込みません。なお、この方法で状況が改善されない場合には次で解説している「アンインストールと完全削除」を行って下さい。

  当プラグインのアンインストール（完全削除）は次のページを参照して下さい。


導入した際に不具合が発生したら（２）　完全削除と原因究明

  当プラグインの導入によって「Beckyが起動しない」「メール受信でBeckyが異常終了する」「たびたびBeckyが落ちる」など、Becky本体の動作に致命的な不具合が発生した場合には、まずは当プラグインのアンインストール（→参照：「プラグインの削除」）を行って下さい。

  それでも問題が継続する場合には当プラグインの完全削除を行って下さい。なお「アンインストールと完全削除」は当プラグインに関して何か不具合が発生した場合にも有効です。

●プラグインの完全削除を行う

  Becky!本体が起動しなくなったりした場合には、それでも状況が改善されない場合、当プラグインの完全削除を行って下さい。すなわち

Becky!InternetMailのPlugInフォルダ（→参考：参考資料「PlugInフォルダの場所」）

の中から「BkASPil.dll」など、「BkASPil」の名前の付くファイルを全て削除して下さい（下図参照）。

  なおこの際、参考資料「PlugInフォルダの場所」に書いておりますように、プラグインの入っているフォルダは２カ所の可能性があります。一方のプラグインフォルダのものだけを削除したり、あるいはそこが見つからないまま、削除したと思われる方が多いようですので御注意下さい。どちらのプラグインフォルダからもBkASPil関係ファイルが削除されたことをよく確認して下さい。

  当プラグインはレジストリには情報を書き込んでいません。ですから上記の方法で直らなければ当プラグイン以外に原因があると思われますので、適宜対処して下さい。（ただし、レジストリに関係する不具合に陥る例も報告されています。質問集「Ｑ．プラグインの完全な再インストールをしたいのですが」を参考にして下さい。）

●原因究明

  上記のようにして通常のBecky!使用に支障を無くしてから、時間の余裕のあるときに何が原因になっているか調査しましょう。

質問集（FAQ）
「Ｑ．エラー、異常終了などが出るのですが、確認事項はありますか？」


スパムフィルタの概要

  「フィルタリング機能の仕組みはどうであれ、とりあえず使ってみたい」という場合はこのページを読み飛ばして、次の「フィルタリング機能の基本設定」をお読み下さり、設定を行って下さい。

●当フィルタで用いている二つの方式について

  当プラグインにおけるスパムフィルタリングでは「ブラックリスト参照方式」と「ベイジアンフィルタ方式」を併用しています。

  それらの方式の併用に関しては下図のような流れになっています。

  すなわち、届いたメールはまず、共有化している「ブラックリスト参照方式」のデータベースに基づいてspam判定を行います。そこでspamと判定された場合にはspamであることを「確定」して、spam用メールフォルダに振り分けると同時に、そのメールをベイジアンフィルタ方式用データベースでの学習に自動利用します（これを自動学習と呼びます）。

  共有化している「ブラックリスト参照方式」のデータベースでspamと判定されなかった場合には、ユーザが個別に持っているベイジアンフィルタ方式用のデータベースを用いて、そのメールに対してベイズ理論に基づくspam判定を行います。一定の確率でspamである可能性が高いとされた場合にspamだと「確定」し、やはりspam用メールフォルダに振り分けます。

●二つの方式の比較

 | ブラックリスト参照方式 | ベイジアンフィルタ方式
ユーザの利用方法 | spam登録 | spam学習
利用するもの | IPアドレス | メール内容（ヘッダ含む）に出現する単語
利用結果 | ユーザ間で共有化するデータベースに反映 | ユーザ個々で利用するデータベースのみに反映
当プラグインで対象とするメール | メール言語に関係なし | 日本語、英語
一般的な関係キーワード | DNSBL、ORBS、サーバのブラックリスト、オープンリレー(Open Relay)、オープンプロキシー(Open Proxy) | ベイズ理論、ベイジアンフィルタ

●ベイジアンフィルタで使用している二つの指標

  ベイジアンフィルタでは「spamらしさ」と「真っ当なメールらしさ」の二つを利用して、新しく届いたメールの「spamである確率」を出して判断しています。「spamらしさ」も「真っ当なメールらしさ」も、それぞれ、それまでに蓄積された「spam」と「真っ当なメール」から学習した結果に基づきます。
  この時、spamから「spamらしさ」のデータベースを構築することを「spam学習」、「真っ当なメール」から「真っ当なメールらしさ」のデータベースを構築することを「clean学習」と呼んでいます。

●フィルタリング結果のメールヘッダへの付与

  当プラグインではメールヘッダに判定結果や判定理由を書き加えるようになっています。

メール受信時判定結果
X-BkASPil-Result: none | 通常時
X-BkASPil-Result: spam | spam判定時
X-BkASPil-Result: white | IPアドレス、メアドなどがホワイトリストにあった場合
判定理由追加ヘッダー
X-BkASPil-Comment: MISHOUDAKU | 未承諾広告判定時
X-BkASPil-BLIP: IPアドレス | ブラックリスト参照方式によるspam判定
X-BkASPil-BayesResult:１以下の数字 | ベイジアンヒット時の計算値
その他
X-BkASPil-Learn: spam | ベイジアンフィルタのspam学習実施済
X-BkASPil-Learn: clean | ベイジアンフィルタのclean学習実施済
X-BkASPil-Comment: MANUAL | 判定の訂正後
X-BkASPil-TLD: | TDL拒否時に付記

●ベイジアンフィルタについて

  当サイトがベイジアンフィルタを導入するに当たっては以下のサイトなどにお世話になりました。

  • 池上大介氏の「ベイジアンフィルタについて」
       http://www.tom.comm.waseda.ac.jp/~ike/column/0006.html
  • 増井 俊之氏の「界面駭客日記(31) - SPAM退治」
       http://pitecan.com/ASCII/diary0306.html
  • Shiro Kawai氏訳「スパムへの対策」「ベイジアンフィルタの改善」
      http://www.shiro.dreamhost.com/scheme/trans/spam-j.html
      http://www.shiro.dreamhost.com/scheme/trans/better-j.html


フィルタリング機能の基本設定

  フィルタリングの仕組みを知らなくても、次ページ以下の各種手順を知らなくても、このページの設定だけは行って頂かないとフィルタリング機能が有効に働きませんので御注意下さい。

１．プラグインBkASPilの設定画面を表示する

  画面解説「プラグイン設定画面の表示方法」を参照して設定画面を表示して下さい。

２．spamリスト取得の設定

  「設定」タブの中で、「定期的にListを取得をする」にチェックを入れます。また、同じくそのタブの下の方の設定「SpamFilter機能を使用しない」のチェックが外れているかを確認して下さい。

  きちんとリストが取得できるかが心配な場合は「今すぐ更新」を押してみましょう。設定画面の「aboutタブ」の「現在の登録IP数」に数字が入っていたらspamリストは問題なく取得されています。

（なお、定期的にリスト取得はしたいけれども開始時には取得したくない場合、Shiftキーを押しながらBecky!を起動するか、「高度な設定」タブの「その他の設定」の「起動時にはListを取得しない」にチェックを入れて下さい）

３．振り分け先フォルダの設定

  初期設定ではspamと判定されたメールは「ごみ箱」に送られます。誤って大切なメールが削除されないよう、最初は「ごみ箱」とは異なる別なフォルダに振り分けることをお勧めします。

３．１　「フォルダを選択」にチェックを入れ、「フォルダ選択」のボタンを押します。

３．２　フォルダが選択できるようになりますのでフォルダを指定して下さい（下図参照）。

３．３　以上の設定が終わったら「ＯＫ」を押して設定画面を終了して下さい。

  なお、特定のフォルダを指定した場合、全てのメールアカウント（メールボックス）でspamと判定されたメールが同一フォルダへ振り分けられます。すなわちこの振り分けはメールボックスの境界を越えて機能します。メールアカウント（メールボックス）毎でspamメール移動先を別々にしたい場合にはFAQ「メールボックスの境界を越えて、全てのメールアカウントのspamと判定されたメールが一箇所のフォルダに振り分けられてしまいますが？」を参照して下さい。

  最低限のフィルタリングに関する設定は以上で終わりです。他の設定については画面解説以降の解説を参照して下さい。


振り分けされなかったメールをspam登録

振り分けされなかったメールをspam登録＆学習する

１．振り分けされなかったメールは．．．

  spamであるのに振り分けされなかった場合、それは下記の両者を満たしています。

  • spamリスト（ブラックリスト）にそのspamの情報が入っていない
  • ベイジアンフィルタの学習が不十分

  振り分けされなかった場合には是非、そのメールをspam登録・spam学習して下さい。両者は一回の操作で出来るようになっています。

  あなたがspam登録を行うことにより、その後に同じサーバ発のspamを受け取る他ユーザの所ではspamとしての判定が可能になります。あるいは、あなた自身が再び同じサーバからspamを受け取った場合にフィルタリング出来る可能性があります。
  また、spam学習を行うことにより、たとえ発信サーバがブラックリストに入っていないspamメールでも、内容からspamと判断することが出来る可能性を高めることが出来ます。

  spam登録・学習ではマウスジェスチャーを利用すると大変便利です。それに関しては参考解説「マウスジェスチャーについて」を参照して下さい。
  以下はマウスジェスチャーを使わずに通常のメニューからspam登録を行う方法を解説します。

  なお、
プラグインの設定－「高度な設定」タブ－SpamFilter関係の設定
で「Spam登録時のダイアログを減らす」をチェックしている場合、以下で説明するダイアログは出てきません。

２．メッセージビューからの登録・学習

２．１　登録したいspamを

メッセージビューで閲覧し、その上で右クリックします。出てくるメニューに

「spamメールとして登録＆学習する」

がありますのでそれを選択して下さい（下図参照）。

２．２　登録（申請）するIPアドレスを確認するメッセージが出ますので、「はい」を押して下さい（下図参照）。

２．３　申請受付のメッセージが出て申請は終了です。同時にspam学習も行います（下図参照）。

３．リストビューからのspam登録

２番と同じ動作はリストビューの右クリックからも可能です。リストビュー上でメールを選び、その上で右クリックします。その中の

「spamメールとして登録＆学習する」

を選びます（下図参照）。

  あとは同上です。

４．「spam登録・学習」手続きと実際の登録について

  このページでは「spam登録」と書きましたが、実際には、登録手続きをした場合にそのメールの情報（すなわちIPアドレス）が必ずブラックリストに入るとは限りません。そのあたりの仕組みについては松永香澄解説「spamフィルタの仕組み」（オンライン解説）を参考にして下さい。
  また、実際にブラックリストに入ったかの確認方法については手順解説「spam登録されているかを確認する」を参照して下さい。

  なお、ベイジアンフィルタの為の「spam学習」は基本的に必ずデータベースに反映されます。


誤ったspam判定を訂正する

１．誤って振り分けされるメールとは．．．

  ここでの「誤ったspam判定」とは「spamでないメールがspamメールと判定され、spamフォルダ（ごみ箱フォルダ）に間違って振り分けされる」場合を指しています。一度このような「誤った判定」が行われた場合、次回にも類似のメールが誤って判定される可能性が高くなります。
  これを防止するため、当プラグインではその判定が誤っていたことをプラグインに知らせて頂く必要があります。

  具体的な手続きは続く第２節で説明します。この手続きを行った時にプラグインがどのような処理をするかは第３節で解説します。

２．具体的な判定の訂正方法

  リストビューの右クリックから行います。リストビュー上でメールを選び、その上で右クリックします。その中の「プラグインのspam判定を訂正する」を選びます（下図参照）。

  ダイアログが出ますので「ＯＫ」をクリックして下さい。

３．判定の訂正手続きにより何を行うか

  あなたにとってspamでないメールがspamと判定される理由は以下の二つのどちらかです。

  1. その発信者の利用するメールサーバのIPアドレスがspamリスト（ブラックリスト）に入ってしまっている
  2. そのメールの内容がベイジアンフィルタによりspamっぽいと判定された

  まず（Ａ）についてですが当システムでは、実際にspamメールがそのサーバから発信されているかどうかの確認をDNSBLに基づいて行いますので、たとえそこからの真っ当なメールを受け取る人が存在しても、それにより当システムのブラックリストから外すことはしません。これはシステムの仕組みから言って仕方のないものであり、ユーザ側でローカルに解決して頂く、すなわちあなたのところのBecky!でのみ、問題の発信元のメールを振り分けないようにして頂くことになります。この方法としては、発信者のデータ（IPアドレス、メールアドレス）などをホワイトリストに登録する方法があり、判定の訂正ではこれを行います。

  また「フィルタリングの概要」で解説しているように、（Ａ）によりspamと判定されたメールはベイジアンフィルタに関して自動学習が行われています。よって、この学習を無効にする必要があります。加えて、同様な内容であっても再度ベイジアンフィルタでspamと判定しないよう「clean学習」を行います。すなわち以下のようになります。

Ａの場合に「判定の訂正」で行うこと
→ホワイトリストにIPアドレスを加え、ベイジアンフィルタに関しては「spam学習」データベースからの除去と「clean学習」を行う

  次に（Ｂ）の場合ですが、これはベイジアンフィルタの学習が不十分であることにより発生します。よって以下のようになります。

Ｂの場合に「判定の訂正」で行うこと
→ベイジアンフィルタに関して「spam学習」データベースからの除去と「clean学習」を行う


ホワイトリストに登録する

誤ってspamに振り分けされるメールをホワイトリストに登録する

１．ホワイトリストへの登録とは．．．

  当システムで振り分けされるメールの中にはspamでないものが存在する可能性があります。すなわちユーザに送られたメールがたとえ真っ当な内容であっても、そのメールの発信元サーバないしは中継元サーバ（正確に言えばIPアドレス）がspam発信にも関与し、一般のDNSBLに登録されてしまっている場合、当システムでもブラックリストに入り「spam」と見なされてしまう可能性があります。

  また、IPアドレスに問題が無くても、ベイジアンフィルタによって内容からspamと判定される場合があります。

  このような場合の解決としては、ユーザ側でローカルに解決して頂く、すなわちあなたのBecky!でのみ、そのメールが振り分けされないようにして頂くことが一番簡単です。
  具体的には、たとえばIPアドレス○○がspamリスト（ブラックリスト）に入っている時

  1. 「(自分の場合には)IPアドレス○○からのメールでも、spamと判定しない」
  2. 「(自分の場合には)IPアドレス○○発のメールだとしても、差出人メールアドレスが××ならばspamと判定しない」
  3. 「(自分の場合には)IPアドレス○○発のメールだとしても、宛先アドレス(Toアドレス)が××ならばspamと判定しない」
  4. 「ベイジアンフィルタ方式による判定の結果がどんなにspamらしくても、発信サーバがxx、あるいは差出人メールアドレスが××、もしくは宛先アドレス(Toアドレス)が××ならばspamと判定しない」

のいずれかを設定しておくことで、あなたの場合にはspamと判定されることを避けることができます。Ａ、Ｄで指定されるIPアドレスあるいはＢ、Ｃ、Ｄで指定されるメールアドレスの集まりを「ホワイトリスト」という呼び方をします。

！注意！　ホワイトリストに御自分のメールアドレス、自分の受信サーバのIPアドレスなどが入っていると、spamメールであっても「真っ当なメール」と判断されてしまい、フィルタリング率が著しく低下します。ホワイトリストに御自分のメールアドレス、自分の受信サーバのIPアドレスを入れないで下さい（参考：「Ｑ．spamと判定出来るものが一部しかありません。振り分けされるものが少ないです。」）

２．ホワイトリストに登録されていることを確認する

  後述するような方法で登録された差出人メールアドレスもしくはIPアドレスは

BkASPil設定画面を表示－「ホワイトリスト」タブ

で確認できます。

３．「差出人メールアドレス(Fromアドレス)」および「宛先メールアドレス（Toアドレス）」をホワイトリストに登録する（一通ずつ）

  リストビュー（参考：画面解説「メイン画面の各部名称」）で

リストビュー 右クリックメニュー－「ホワイトリストに追加」－「Fromメールアドレスを追加する(もしくはToアドレスを追加)」

を選ぶと追加できます（下図参照）。

４．差出人メールアドレスをホワイトリストに登録する（フォルダごとまとめて）

  メールフォルダの中にあるメールの差出人メールアドレスをまとめてホワイトリストに登録することが出来ます。

  ツリービューでフォルダを指定し右クリック－「ホワイトリストに追加」

を選ぶと、そのフォルダの中にあるメールの差出人すべてをホワイトリストに追加できます（下図参照）。

  ただしホワイトリストに御自分のメールアドレス、メーリングリストの投稿先アドレスなどが入ってしまった場合、フィルタリング機能が十分に有効にならない現象が発生しますので御注意下さい（振り分け率が極端に低下するなど）。その時にはそれらのメールアドレス（特に御自分のメールアドレス）は手動で削除して下さい。

５．アドレス帳のメールアドレスを一括して登録する

  メールアドレスを集めたBecky標準の「アドレス帳」に登録してあるメールアドレスを、一括してホワイトリストに登録することが出来ます。その方法は

プラグインの設定を表示させる－「ホワイトリスト」タブを開く－「アドレス帳のメールアドレスを追加する」ボタンを押す

  ただしホワイトリストに御自分のメールアドレス、メーリングリストの投稿先アドレスなどが入ってしまった場合、フィルタリング機能が十分に有効にならない現象が発生しますので御注意下さい（振り分け率が極端に低下するなど）。その時にはそれらのメールアドレス（特に御自分のメールアドレス）は手動で削除して下さい。

６．IPアドレスをホワイトリストに登録する

差出人メールアドレスを登録する場合である３番と全く同様な方法で、該当メールの発信、中継IPアドレスをホワイトリストに登録できます。すなわちリストビュー（参考：画面解説「メイン画面の各部名称」）で

リストビューで右クリックメニュー－「ホワイトリストに追加」－「IPアドレスを追加する」

を選ぶと追加できます。

  ホワイトリストのデータの扱いに関して上の操作ではもの足りない、すなわちもっと効率的にホワイトリストの編集を行いたい場合には、質問集の「Ｑ．ホワイトリストを直接編集したいのですが。」の回答を御覧下さい。


既に受信したメールを改めて振り分ける

一旦、受信ボックスに入ったメールも、再度spam判定と振り分けを行うことが出来ます。

リストビュー（参考：画面解説「メイン画面での各部名称」）で再振り分けをしたいメールを複数選択し、右クリックメニューの中で「選択中のメールを再spam振り分け」を選びます（下図参照）。


spam登録されているかを確認する

１．spam登録されているかを調査する

  とあるメールの発信または中継サーバのIPアドレスが当システムのブラックリストに入っているかを確認することが出来ます。これでブラックリストに入っていると分かった場合には、そのメールは受信した際にspamと判定されることを示しています。

２．メッセージビューからの確認

２．１　調査したいメールをメッセージビューで閲覧し、その上で右クリックします。出てくるメニューに

「spam登録状況調査」

がありますのでそれを選択して下さい（下図参照）。

２．２　そのメールの情報を送って良いかが問われますので「ＯＫ」を押します。

２．３　情報画面が出ます。その画面の見方に関しては「Cache DB チェッカの見方」（オンライン解説）をお読み下さい。

３．リストビューからの確認

リストビューの右クリックメニュー－「メールを調査する」－「spam登録状況調査」

を選ぶと確認できます（下図参照）。

２．２　そのメールの情報を送って良いかが問われますので「ＯＫ」を押します。

２．３　情報画面が出ます。その画面の見方に関しては松永香澄解説「Cache DB チェッカの見方」（オンライン解説）をお読み下さい。


フィルタリング機能の停止

  このソフトの機能は大きく分けて「フィルタリング機能」と「spam処置依頼支援機能」の二つから成り立っています（参考→「はじめに」）。もし後者に特化して利用する場合、前者すなわちフィルタリング機能を停止することが出来ます。

  フィルタリング機能はインターネット接続を前提とした機能であるため、インターネットに繋がっていない状況だと通信エラーが発生することがあります。そのような場合にもフィルタリング機能を停止して下さい。

１．プラグインBkASPilの設定画面を出す

  画面解説「プラグイン設定画面の表示方法」を参照して設定画面を表示して下さい。

２．フィルタリング機能の停止

「プラグインの設定」の「設定」タブの「SpamFilterの設定」の中の「SpamFilter機能を使用しない」をチェックします（下図参照）。

以上です。


そもそも処置依頼とは

そもそもspam処置依頼とは

  spam処置依頼とはなんでしょうか？

  spamの性質は郵便チラシや郵送ダイレクトメールと比較されがちです。郵送ダイレクトメール広告やチラシは社会的に黙認され、あまり問題視されていない国が多いことから、電子メールのダイレクトメールすなわちspamに対しても「無視と削除」のアドバイスが基本的に行われてきました。

  しかしながら電子メールというツールは郵便とは様々な相違点があり、一方的な広告送り付け問題が極めて深刻化する性質を持っている為、同一に論じられるべきではありません。そこでspam行為に関しては送信に関係したサーバのネットワーク管理者が対処をするということが基本的なルールとされてきました（RFC2635など）。
  また、「spam発信者はモラルが低く、たとえ受信者が今後の送信を止めて貰うように頼んでも発信者は守らない」「さらに悪質な場合にはspamを一層送ってくる」という傾向があったことも、連絡すべき先はspam発信者ではなく、spam発信者が利用したメールサーバの管理人であるべきとされきた理由です。

  ところが電子メールの場合、発信に利用されたサーバの管理者を見つけるというのはそれほど簡単な行為ではなく、メールヘッダの読み方やインターネット上で公開されているWhoisデータベースの利用法を知っていなければ困難なものです。当プラグインは「発信に利用されたサーバの管理者を見つける」という行為を支援し、spam処置依頼を効率的に行う機能を持っています。

  さらに、スパム問題が深刻化するにつれ、状況は少しずつ変化しています。2003年現在、spamの処置（具体的にはスパム発信者への処置）を依頼する先として以下のようなところが一般化しています。

  1. スパム発信者が発信に利用したネット業者
  2. スパム発信者がスパムの中に記した宣伝サイトを作るのに利用しているネット業者
  3. スパム問題を解決するために法律などの根拠に基づいて作られた機関

  まず１番に関しては前述のように「spam発信に利用されたネット業者（正確に言えばspam発信に利用されたサーバのネットワーク管理者）は対処すべし」という認識がほぼ世界レベルで形成されています。以前の日本のネット業者の中にはインターネットに不案内で、従来の通信事業と同レベルでしか考えられない業者などが対応を拒否する場合がありましたが、そのような憂うべき事態も少なくなっています。

  次に２番に関してはスパムの抑止、撲滅を考えたときに

「宣伝されるものがあるからスパムが発信される」
      ↓
「宣伝されるものを無くしてしまえば取りあえずスパムを送る意味がなくなる」
      ↓
「スパム行為を停止する可能性がある（特に次にサイトを用意するまで）」

という発想から一般的に広まったものです。しかしこれに関しては冤罪の危険性などから対処は困難であると主張する人々もいます。

  そして３番に関してはスパム問題の深刻化した各国で、政府による情報収集機関が指定、設立されるようになった結果としての「苦情先」「通報先」です。

  上のように、スパム発信者に対し短期的・中長期的な対応が出来る機関への連絡を、このプラグインでは「spam処置依頼」と呼んでおり、Becky!を使い、速やかにそのメールを送ることがこのプラグインの機能の一つになっています。なお、ネット業者におけるspam処置依頼先のことを「abuse窓口」などと呼んでいます。

  SpamCopは上記の１番と２番への処置依頼（報告）を支援する外国のシステムです。

  この解説書では当プラグインを使ったspam処置依頼のうち

  1. spam発信に実際に使われたネット業者（サーバ管理者）に送る
  2. 日本の迷惑メールに関する関係官庁に送る
  3. spam宣伝サイトを作るのに利用されているネット業者（サーバ管理者）送る
  4. SpamCopを通じて、１，２のネット業者に送る

の４つの場合についてそれぞれ手順を説明しています。


当システムの構造

  当プラグインを利用したspam処置依頼システムは

  • 処置依頼先を探すためのツール集（対スパムツール集）
  • 上記システムを利用しながら処置依頼メールを作成する当プラグイン

の二つから構成されます。当プラグインは対スパムツール集をBecky!で使いやすくするためのプラグインだと言うことが出来ます。

  当プラグインが無くても、対スパムツール集を使うことは出来ますが、ツール集がなければ当プラグインのspam処置依頼メール作成支援機能の便利さは半減します。
  よって、対スパムツール集のサーバが不具合などの場合には当プラグインの支援機能が制約されます。


ユーザ登録について

●ユーザ登録とは？

  ユーザ登録は当プラグインの前身antispamプラグインの時からありましたが、リニューアルされたBkASPilでのユーザ登録は目的が全く異なります。BkASPilでは「spam処置依頼支援機能」の為にユーザ登録システムが設けられています。
  ユーザ登録をしないと「spam処置依頼メール作成支援機能」は御利用できません。メールヘッダ調査の機能も御利用になれません。

  ユーザ登録の目的は、ユーザの皆様が当プラグインのspam処置依頼支援機能を利用するにあたり、適切な利用方法を認識・確認して頂くためのものです。
  spamの対処では様々な「明らかに間違った方法」がしばしば起こっています。たとえば典型的な間違いの例としては「差出人メールアドレスから送信者の利用したネット業者を判断すること」があります。spam、特に英文spamでは差出人メールアドレスの詐称が行われることが極めて多く、その場合には差出人メールアドレスから判断されるネット業者は対処が不可能であり、一般にそこへ処置依頼の必要はありません（2003年現在）。詐称されたメールアドレスのネット業者は「送信者が利用したネット業者」とは言えないのです。
  スパム受信者に知識がなく、上のような詐称されたネット業者などに対処依頼メールを送った場合、受け取るネット業者も迷惑ですし、肝心なネット業者には処置依頼（苦情）が行かず、スパム受信者の折角の行動も徒労になってしまいます。

  当プラグインの機能の一つである「措置依頼支援」ではなるべく正しい依頼先を見つけだすようになっていますが、基本的な知識のないまま利用方法を間違えてしまうと、やはり間違った場所に処置依頼メールを送る危険性があります。
  そのような状況を少しでも減らすべく、開発チームでは当プラグインを使うためのクイズを設けました。このクイズで学んで頂き、最低限の知識を身につけて頂いてから、この機能を活用して頂きます。御面倒ですが御理解して頂きますよう、お願い申し上げます。

●ユーザ登録の方法

B2ASPilユーザ登録頁
http://b2antispam.s33.xrea.com/cgi/use_regist/multiplequiz.cgi
にて、Becky!で御使用になっている、御自分の受信可能なメールアドレス（複数のアカウントを利用しているならどれでも可能）を入力して、手続きを開始して下さい。

  クイズ方式になっていますが、回答していく毎に、前問のヒントが表示されます。一問一問じっくり熟読しながら回答して下さい。
  なお、何回でも挑戦することが出来ますが、回答途中でブラウザの機能により「戻る」や「再読込」をすると、不正が行われた可能性があると判断され、15分は同じメールアドレスでの回答が出来なくなります。

  クイズの正解率が一定以上になると記入したメールアドレスに登録メールが送られます。それを当プラグインをインストールしてあるBecky!で受信すると登録終了です。

●確認

  ユーザ登録が行われると

BkASPil設定画面－「高度な設定」タブ

の「ユーザ登録データ」にIDとPasswordが記入されます（下図参照）。


基本設定

処置依頼支援機能の基本設定

  処置依頼作成の際には事前に「定型文」（雛形、テンプレート）を作っておいて下さい。面倒な方はspam処置依頼の標準的なフォーマットをWeb上で提供していますので、下記よりダウンロードし、部分的に修正するだけでも良いでしょう。
  以下、その標準テンプレートのダウンロード方法と部分修正方法に関して解説します。

●標準テンプレートの導入

１．標準テンプレートのダウンロード

  標準テンプレートは

http://b2antispam.s33.xrea.com/download/

で配布しています。必要なテンプレートの上で右クリックをして下さい。出てくるメニューの中から「対象をファイルに保存」を選びます（下図参照）。

  ファイルを保存する場所を聞かれると思いますが、以下のフォルダの場所を指定して下さい。

  参考解説「メールボックスとPluginフォルダ場所」で説明している、自分のパソコンのBecky!のメールボックスの場所を御覧下さい。その下には「英数字の訳の分からない並び．ＭＢ」というフォルダがあるはずです。これがBecky!で言う、メールボックスの実体です。複数のメールボックスを利用している場合には複数存在します。

  この中でspamを受け取るメールボックス（フォルダ）を下層フォルダなどから判断します。その下には「＃Ｔｍｌ」というフォルダがあるはずです（上図参照）。テンプレートファイルはそこに保存します。

２．テンプレートの修正

  次に先ほどダウンロードしたテンプレートの一部を変更します。以下はBecky!標準の方法で、ヘルプにも書いてあります。

２．１　まず新規メールを作成します。次にそのメールのメニューから

「ファイル」－「テンプレートを作成/編集」

を選びます（下図参照）。ただし全て御自分で新規からテンプレートを作る場合にはそのまま作成して下さい。

  なお、英語の文章作成に関してはExicite翻訳/Altavista翻訳あるいは桑木野氏による「スパム対処依頼文雛型」なども参考になるでしょう。

２．２　テンプレート一覧画面が出てくるはずですので、ここで編集するテンプレートを選択します（下図参照）。

２．３　デフォルトのテンプレートの文章内容を御自分の状況に合わせて適宜直します（下図参照）。

２．４　「ファイル」－「テンプレートを保存」

で保存した後、終了します。

●利用に慣れてきたら．．．確認ダイアログの省略化

  マニュアルを熟読しなくても良いようにspam処置依頼支援機能ではかなり頻繁にダイアログが出てきます。これを最低限に減らすことが出来ます。

１．プラグインBkASPilの設定画面を出す

  画面解説「プラグイン設定画面の表示方法」を参照して設定画面を出して下さい。

２．その中から「高度な設定」のタブを選択します。

  「処置依頼関連の設定」の「確認ダイアログを極力少なくする」にチェックをして下さい（下図参照）。

以上です。


メールヘッダを解析する

1．リストビューの処置依頼を送りたいspamメールの上で右クリックし、メニューを表示します（下図参照）。

  一番下の方に
「spamメールを報告」－「メール調査後、abuseに送信」
というのがありますのでそれを選んで下さい。

２．確認のダイアログボックスが出て「ＯＫ」を押すと、上記の情報がインターネットを通じて当システムに送られ、解析が始まります（下図参照）。

３．慌てずにしばらくお待ち下さい。最初に画面に出てくるのはメールヘッダです。ヘッダのIPアドレスが赤字で表示されています。


abuse窓口メールアドレスを探す

解析結果からabuse窓口メールアドレスを探す

1．結果が出ました。まず「苦情先の指定」というダイアログが出てきます（下図参照）。

  この時の苦情先の探し方は対スパムツール集の「ヘッダ解析システムhdparの使い方」（オンライン解説）と同じです。もし以下の解説でよく分からない部分があったら、そちらも読んでみて下さい。

  たとえば２つのIPアドレスが抽出されたとします（上図参考）。処置依頼は原則、それぞれのIPアドレスの管理者に送ることになります。この時、「上策の苦情先」と呼ばれる赤字の連絡先が出てくることがあります。これは苦情先としてかなり適切なabuse窓口のメールアドレスです。この場合には「苦情先の指定」のダイアログボックスにもそのメールアドレスを選択肢とするチェックボックスが出ているはずです。適宜、相応しいところにチェックします。上図では緑の矢印に沿ってチェックをすることになります。

  複数出てくるメールアドレスのうち、＠以降のドメイン名が同じ、すなわち同じ会社ならば、特殊な事情がない限り、全てのabuse、postmasterに送る必要はありません。優先順位としてはabuse、postmaster、hostmasterとなります。それを示すため、「abuse」の言葉がつくメールアドレスだけは赤字で表示されるようにしています。

  IPアドレスの中には、赤字で示される「上策の苦情先」が出ない場合があります（上図１番目のIPアドレス参照）。その場合でも「特殊なアドレスです」などの表示でない限り、苦情先はほぼ必ず見つかります。その苦情先はGeekToolsの結果から探すことになります。

  その方法については参考資料「GeekTools(Whois)結果の見方」に詳しく書いていますので、もし以下の解説でよく分からない部分がある場合には、そちらも読んでみて下さい。

２．GeekToolsの詳細モードというリンクを押すと、そのIPアドレスに関係する会社や担当者のメールアドレスが一度に出るようになっています。

  たとえば例として下図のような表示になります。「詳細モード」でない場合には、まず最初に小さくＡＢが並んでいるところだけが出て、ネット業者名だけが分かります。そしてそれ以上は、それぞれの結果を再検索せねばなりません。

  しかし詳細モードでは上に続けて同じページ内にＡの会社データ、その担当者のデータ、続いてＢの会社データ、その担当者のデータが全て出力されるようになっています。

  Ａの会社のデータの所には「技術連絡担当者」が赤字になっていますが、この人が続いてデータが出力されている人物です。そしてそこには［電子メール］と赤い字で書かれていますので、この人がまず送信すべき相手の一人（ネットワーク管理者の一人）であり、ここのメールアドレスがspam処置依頼を送るべき先のメールアドレスの一つです。

  続けてその下に、Ｂの会社のデータと、やはり技術管理担当者のメールアドレスがあります。見方は全く同様です（下図参照）。

３．再述しますと（下図参照）「上策の苦情先」が出たIPアドレスの場合には苦情先メールアドレスが選択肢として出ますので、その中から選択します。それが出なかったIPアドレスの場合にはGeekToolsから検索された関係者をピックアップして空欄に加えます。この時、複数ならばカンマ「,」で区切ります。

４．以上のようにして、送るべきメールアドレスを全て選択もしくは記入したら「ＯＫ」を選択して次に進みます。


テンプレートの選択

次に利用するテンプレートを尋ねてきます。宛先が日本か外国かで依頼分を日本語で書くか英語で書くかを判断し、使うテンプレート（雛形）を変えましょう。「処置依頼支援機能の基本設定」で作成したテンプレートがあるはずです（下図参照）。


メール内容の確認

  以上の操作で処置依頼メールが作成されます。必要があれば文章を手直しします。少なくとも、メールの最後の部分にspamのヘッダと本文が付属していることを確認しましょう（下図参照）。

  以上でメール作成は終了です。このメールを送信して完了です。


官庁への連絡・報告について

●最新の方法を確認しましょう

  関係官庁への報告方法や条件は法律やその運用状況に左右されます。以下の記述は2003年07月現在のものであり、古くなる可能性があります。御利用の際には総務省、経済産業省のホームページもしくはスパム反対サイト、アンチスパムサイトなどで情報を集め、その時点での適切な処置依頼（報告）方法を用いて下さい。

●2003年07月の状況

［通報の条件］

  「特定電子メール適正化法」「特定商取引法」が2002年04月に制定・改訂され、同年７月から施行されています。

法律 | 管轄省庁 | 関係特殊法人 | 関係サイト | 規制対象
特定電子メール適正化法 「特定電子メールの送信の適正化等に関する法律」 | 総務省 | （財）日本データ通信協会 | 迷惑メール相談センター | 送信者
特定商取引法 「特定商取引に関する法律」 | 経済産業省 | （財）日本産業協会 | 表示義務違反メールの情報提供について 再送信禁止義務違反メールの情報提供について | 広告主

  ポイントは

  1. タイトルに「未承諾広告※」を付記。

  2. メール本文に送信者、事業者の名称、住所、電話番号等を明記。

  3. 再び送ってくることを拒否できるための方法をメール中に提示すること。

  4. 受信者が「受信拒否（再送拒否）」をした場合には次から送信してはいない。

  ですが、さらに集約すると

  • 表示義務を遵守すること。

  • 受信拒否された場合に再送しないこと。

の２点となります。どちらかに違反している場合、違法なメールとして通報すべきということになっています。

［具体的な通報先］

  法律は諸々の理由から２つの法律で規制されることになり、その結果、関係団体も２つ（日本データ通信協会、日本産業協会）となっていますが、両者は違法なメールの情報について連絡を取り合っており、通報は片方だけに通報すれば構わないとのことです。

［報告の方法］

  上記サイトを見ると、メールによる報告よりもホームページでのフォームによる連絡の方が望まれているように見えます。しかしメールによる報告も受け付けており、その為のメールアドレスが用意されています。当ツールではメールによる報告をすることを前提としています。


メールの作成と確認

１．リストビューの右クリックメニューより、

「spamメールを報告」－「その他へ送信」を選択

します（下図参照）。

２．次に利用するテンプレートを尋ねてきます。官庁へ報告用のテンプレートを選択します（下図参照）。

３．以上の操作で処置依頼メールが作成されます。必要があれば文章を手直しします。少なくとも、メールの最後の部分にspamのヘッダと本文が付属していることを確認しましょう（下図参照）。

４．　最後に送信して完了です。


URLの解析を行う

１．spamの本文の中（メッセージビュー上）で調べたいドメイン名（URL）をドラッグで選択し、その上で「右クリック－コピー」します　（下図参照）。

２．その後、メール本文（メッセージビュー）の別な場所で右クリックするとメニューが出ます（下図参照）。

「Webサイトの調査」

を選びます。

３．選択したドメイン名を「す～ぱ～もの」に入れた結果が表示されます（下図参照）。


abuse窓口メールアドレスを探す

  URLを調査する「す～ぱ～もの」はもともと説明書（ヘルプ）が無くても出力結果を順次見ていけば、解析できるようになっています。また、ところどころには「注意書き」へのリンクがあり、クリックによりそのポップアップ説明を見ることも出来ます。以下、それらの解説とかなり重複しますが念の為、解説します。

１．入力されたドメインの逆引き、順引き結果がでる

  まず最初の方に「入力したＵＲＬ」「その中で解析するドメイン部分」「そのドメインの逆引き結果」「そのIPの順引き結果」がまとめて表示されます。これ以降、この結果を使って、入力したURLのホームページの作るのに利用されているネット業者を捜すことになります（下図参照）。

２．「レベル０：入力URLのソースを見る」

  スパムの宣伝しているサイトを実際に閲覧することにはいろいろな問題があります。悪意あるプログラムが仕掛けられている可能性も皆無ではありません。ここでは入力されたURLのソースを見ることが出来ます（下図参照）。

  これに関しては「処置依頼先メールアドレスを探す」こととは少し外れる場合が多いので参考資料「spamの宣伝サイトの閲覧とソース」の中で述べてあります。

３．「レベル１：単純な場合」

  個人ユーザがプロバイダーでホームページ作成サービスを利用すると

http://www.example.com/~user/index.html　　　　・・・・（＊Ａ）

などが与えられることがあります。この場合はもっとも単純ということができ、そのサイトが作られているのはネット業者
http://www.example.com/
のサービスになりますので、そのホームページから依頼先窓口を探しましょう（上図参照）。

  NetworkAbuseClearingHouse略してabuse.netは世界中のネット業者の苦情先窓口データベースです。外国のサイトですが日本のネット業者も代表的な所は登録されています。abuse.netに登録されている場合、このレベル１の所に赤字で表示されます。

！注意！詳細は省きますが最近、ここに赤字のメールアドレスが出てきても、後述のレベル２、レベル３を参照すべき場合が多々あります。必ずレベル２以降も確認するようにしましょう。なお、この点に関しては「す～ぱ～もの」の仕様変更を検討中です。

４．「レベル２：逆引きドメイン名からの探索」

  ドメイン名に対応したIPアドレスを探すことを順引き、IPアドレスからそれに対応するドメイン名を探すことを逆引きと言います（参考解説「ドメインとIPアドレス」）。

（１）宣伝サイトのドメイン→（２）IPアドレス→（３）ドメイン

と変換していくと（３）において、ネット業者所有のドメイン（前述のxxx.example.comなど）になることが多々あります。「す～ぱ～もの」ではこの手段によって、宣伝サイトが作られた際に利用されたネット業者を探そうとします（下図参照）。

  まず、３番と同様にNetworkAbuseClearingHouse略してabuse.netで苦情窓口を探し、データベースにあれば表示します。

  次にそれがない場合には、（３）のドメインで、存在しそうなサイトがいくつか出てきます。すなわちネット業者のトップページの可能性が高いURLが出てきます。これらを実際に閲覧して、ネット業者であることを確認し、窓口も確認します（上図参照）。

  ただし（１）と（３）がほぼ同じようなドメインの場合があります。このような場合

  1. （１）＝（３）がスパム発信者のサイトの場合
  2. （１）＝（３）がネット業者の場合

のほぼどちらかになります。スパム宣伝サイトのURLが
http://www.example.com/
などのように、後ろに/（スラッシュ）以降の区分がない場合はスパム発信者のサイトですので閲覧は危険です。（＊Ａ）のような場合には（１）＝（３）がネット業者の可能性が高いですが、100％とは言えません。次のレベル３に行くことを勧めます。

５．レベル３：IPアドレスからの調査

  ４番すなわちレベル２までで適当な窓口アドレスが見つからなかった場合には

（１）宣伝サイトのドメイン→（２）IPアドレス

で出したIPアドレスから、窓口を探します。実はこの方法が一番確実です。これはIPアドレスからWhoisを使って窓口を探す方法です。これについては「GeekToolsの使い方」で解説しています（下図参照）。

６．ドメイン名の登録情報を参照する

  一番下では、解析するドメインの登録情報を閲覧できます（下図参照）。

以前はこの情報は使うべきでないとされていました。その理由は以下のようなものです。

  • ドメイン名の所有者はスパム送信者、あるいはその仲間である可能性が高い。当プラグインの方針は「スパマーが利用しているネット業者」へ対処を要請するものなので、ドメイン名の所有者を調べても意味がない。
  • ドメイン名の登録は偽名や偽住所、無料メールアドレスなどで安易に行うことが出来るため、内容が信頼できない。

  しかしながら最近、このドメイン登録に、スパム送信者がサイトを制作するのに利用しているネット業者（いわゆるホスティングと言われる業者）が出てくることも多くなっているようです。適宜利用して下さい。

  以上をまとめると以下のようなパターンがあります。

（１）宣伝サイトのドメイン－(順引き)→（２）IPアドレス－(逆引き)→（３）ドメイン

 | パターン１ | パターン２ | パターン３ | パターン４
（１）スパム宣伝URLのドメイン名 | スパマーの利用しているネット業者の所有・サイト | スパム発信者の所有・サイト | スパム発信者の所有・サイト | スパム発信者の所有・サイト
（３）ドメイン名 |  | スパマーの利用しているネット業者のもの | 各種 | スパム発信者の所有
（２）IPアドレスの情報 |  | 最上流のネット業者 | 最上流のネット業者 | スパム発信者のもの
参考で出てくる（１）のドメイン登録情報 |  | スパム発信者の情報（捏造の可能性も高い） | スパマーの利用しているネット業者（ホスティング）の情報も入っている | スパム発信者の情報（捏造の可能性も高い）


メールの作成と確認

１．送りたいspamメールを選択して

リストビューで右クリック「spamメールを報告」－「その他へ送信」を選択（下図参照）

２．次に利用するテンプレートを選択します。送信サーバでなく、あくまで宣伝サイトに対する要求であることを強調する文章を選びましょう（下図参照）。

３．以上の操作で処置依頼メールが作成されます。必要があれば文章を手直しします。少なくとも、メールの最後の部分にspamのヘッダと本文が付属していることを確認しましょう（下図参照）。

４．　最後に送信して完了です。


SpamCopとは

  SpamCopは外国のフィルタリング 兼 Spam報告支援システムです。無料ユーザはこのシステムを利用することで、受信したSpamに関係するネット業者に対し、Spam受信報告（処置依頼、苦情）を簡易に行うことが出来ます。これは当プラグインで対スパムツール集を使って処置依頼を送る行為を更に自動化したもの、と言えます。

  SpamCopはこのような自動処置依頼システムを無料ユーザに提供する一方、そこで集められた情報により作られたフィルタリングシステムを有料ユーザに提供しています。また、spam情報の一部をネット上で公開しています。

  SpamCopに関する日本語による解説、あるいはSpamCopに対する見解としては以下のサイトを参照して下さい。

  • 「no spam/」の「SpamCop」他
  • isso氏の「迷惑メール追放」の「Spamcopの使い方」
  • 「Panpukin98 Network」の「SpamCop指南」
  • 「迷惑メールを晒す」の一番下、SpamCopの使い方
  • 当プラグイン制作チーム一員である高崎の「SpamCopに関する見解」

  当プラグインでは、SpamCopを以下のように利用しています。

  • 「フィルタリング機能」・・・spam登録で参照するDNSBLの一つとしてSpamCopを利用している。

  • 「Spam処置依頼支援機能」・・・処置依頼を送る手法の一つとして、SpamCopにSpam受信報告メールを簡易に送ることが出来る。

  当プラグインは申請されたIPアドレスをブラックリストに入れる際にDNSBLを参照していますが、SpamCopは日本語spamも含めて比較的充実したDNSBLを作成してくれる為、当プラグインも結構お世話になっていると言えるでしょう。SpamCopでは寄付を受け付けていますのでよろしかったら協力して下さい。


準備（SpamCopへの登録と当プラグインへの登録）

準備：当プラグインへの登録

  SpamCopへの登録はSpamCopのサイトから行って下さい。
（参考→画面解説「SpamCop登録状況」）

  当プラグインでSpamCopを利用するには各ユーザのSpamCop登録内容を当プラグインにも登録することが必要です。その方法ですが、SpamCopを登録した際に受信したメールを

Becky!のメニュー「ツール」－「手を加えずに転送」

で自分のメールアドレスに送信して下さい（下図参照）。

受信と同時にプラグインに登録されます。登録された内容に関しては画面解説「SpamCop登録状況タブ」で確認できます。


SpamCopにspamを転送する

１．　リストビューの処置依頼を送りたいspamメールの上で右クリックし、メニューを表示します（下図参照）。

  一番下の方に

「spamメールを報告」－「spamcopに送信」

というのがありますのでそれを選んで下さい。

２．直ちにspamcopへ送信するためのメールが作成されます（下図参照）。それを送信します。


返信メールのリンク先を参照する

  当プラグインによる機能ではないですが、spamcopから解析が出来た旨を知らせるメールが届きますので、その中のURLをクリックすると解析結果を表示します（下図参照）。

なお、プラグインの設定ではメールが到着次第、自動で解析結果のページが開くようにすることも出来ます。

BkASPil設定画面－「SpamCop登録状況」タブ

の中の「spamcopの登録状況」の中で下の方にあるチェックボタンをチェックします（下図参照）。

  その設定にしておくと、SpamCopからの返信メールが届き次第、自動的にブラウザが立ち上がり、メールの中に書かれている指定のページを表示します。


プラグイン設定画面の表示方法

  当プラグインでの各種設定は他の多くのプラグインと同様に以下の「プラグインの設定」画面から行います。

１．プラグインBkASPilの設定画面の表示方法

  Becky!のメニューバーから

「ツール」－「プラグインの設定」－「BkASPil Plugin Ver.x.xx」

を選択します（下図参照）。

２．プラグイン設定画面の構成

  プラグイン設定画面は６つのタブ（シート）
「設定」
「高度な設定」
「SpamCop登録状況」
「ホワイトリスト」
「Report」
「About」
から構成されています（下図参照）。それぞれのタブでの設定内容については次頁以降で解説しています。


プラグインの設定「設定」タブ

－「Spam Filterの設定」－

(□チェックボックス)定期的にListを取得をする。（起動時も含む）

  フィルタリングで使用するspamリストを、ネットワーク上のサーバから一定時間毎に自動取得するように設定します。また、Becky!起動時にも取得します。
  spamリストには常に新しいspamデータが登録され、ユーザの所にも刻々と新しいspamが届く可能性がありますので、そのリストは極力最新のデータに保つことが理想です。新しいデータに更新していなければ、その分、フィルタリングの成功率は下がります。お使いのコンピュータがインターネットに常時接続されている場合にはこの設定にチェックをつけることをお勧めします。
  なお、定期的にリスト取得はしたいけれども開始時には取得したくない場合には、Shiftキーを押しながらBecky!を起動するか、「その他の設定」タブで「起動時にListを取得しない」にチェックを入れて下さい。（参考FAQ：「Ｑ．Becky!の起動・動作に時間がかかります。」）

(プルダウンメニュー選択)更新する間隔

  更新する時間間隔を調整できます。短くするほど最新のspamリストが取得できますが、一方でspam取得時にBeckyの動作が固まる現象が報告されています。「質問．CPU使用率が100％になり、Becky操作に支障が出ます」などを参照し、適宜調整して下さい。

(ボタン)今すぐ更新

   spamリストを手動で最新にすることが出来ます。リストが更新されたことは「about」タブで表示されるIP数と最終取得時刻で確認できます。

(□チェックボックス)件名に「未承諾広告」がある場合Spamと見なす

  2002年７月施行の「迷惑メール規制２法」により、一方的に送り付けられる広告メールには「未承諾広告※」の文字を付記することが義務づけられました。（→手順解説「官庁への連絡・報告について」）

  この設定にチェックを入れると、タイトルに「未承諾広告」という文字列が入る場合には、spamリストに入っているか否かに拘わらず、spamと判断してspamリストに入っているとの同様の処置をします。

(○ラジオボタン)Spam該当メールの処置「ごみ箱行き」「フォルダを選択」

  spamと判定したメールを

  • ごみ箱フォルダへ移動
  • 特定のフォルダへ移動

のどちらにするかを選択できます。「特定フォルダを選択」する場合にはその下の「フォルダ選択」のボタンからフォルダを指定して下さい。（参考→手順解説「フィルタリング機能の基本設定」）
  なお、特定のフォルダを指定した場合、全てのメールアカウント（メールボックス）でspamと判定されたメールが同一フォルダへ振り分けられます。すなわちこの振り分けはメールアカウント別メールボックスの境界を越えて機能します。メールアカウント（メールボックス）毎でspamメール移動先を別々にしたい場合にはFAQ「メールボックスの境界を越えて、全てのメールアカウントのspamと判定されたメールが一箇所のフォルダに振り分けられてしまいますが？」を参照して下さい。

（[ボタン]）フォルダ選択

  spamと判定したメールを特定のフォルダに振り分ける場合すなわち上で「フォルダを選択」にチェックした場合、このボタンを押すことで振り分ける先のフォルダを選択できます。上の設定で「ごみ箱行き」をチェックしていると「フォルダ選択」のボタンを押すことは出来ません。

(□チェックボックス)SpamFilter機能を使用しない

  当プラグインの機能のうち、フィルタリングシステムの使用停止させたい場合にはチェックします。フィルタリングシステムはネットワークとデータ情報を交換することを前提としているため、常時接続でない場合にはエラーが出る場合があります。インターネットに常時接続していない場合、あるいは当プラグインのspam処置依頼支援機能を中心に使いたい場合などにチェックして下さい。（参考→手順解説「フィルタリング機能の停止」）

(□チェックボックス)SmallSize IPBLを使用する

  当プラグインを導入したことで「Becky!の動作が重くなった」「Becky!の起動が遅くなった」などの不満がある場合、ここにチェックを入れて使ってみて下さい。通常提供されているリストより小さなリストを取得するようになり、若干の改善が期待できます。ただし利用するブラックリストが小さくないますのでフィルタリング率は下がります。
参考FAQ：「Ｑ．Becky!の起動・動作に時間がかかります。」「Ｑ．しばしばパソコンの動作が停止します（固まります）。」

－「マウスジェスチャーの設定」－

  spam登録の時などに特に便利なマウスジェスチャーに関する設定を行います。参考資料「マウスジェスチャーについて」を参照して下さい。


プラグインの設定「高度な設定」タブ

  このタブでは各種の設定を行うことが出来ます。設定項目が増えたため、さらに複数のタブに分割されました（下図参照）。

お手数ですが設定内容に応じて各解説ページを参照して下さい。

  SpamFilter関係の設定
  処置依頼関連の設定
  Bayesianの設定
  プロキシサーバの設定
  その他の設定


プラグインの設定「高度な設定」タブ　1_SpamFilter関係の設定

－SpamFilter関係の設定－

(□チェックボックス)SpamがHitしたらサウンドを鳴らす。
  spamフィルタリングが行われた際にサウンドが鳴り、ユーザが分かるようにします。

(□チェックボックス)Spam登録時にごみ箱等に移動させない。
  標準の設定では、spam登録＆学習を行うと、そのメールは「設定」タブの「Spam該当メールの処置」で設定した場所に移動します。たとえば特定のフォルダ「Ａ」にspamが振り分けられるようにしていた場合、振り分けされなかったメールのspam登録＆学習を行うと、登録を行ったことによって、そのメールは特定のフォルダ「Ａ」へ移動します。ここでの設定をチェックすると、メールをspam登録＆学習を行ってもそのメールは移動しません。

(□チェックボックス)Spam登録時登録チェックも行う。
  本システムでのspam登録というのは、実質上、spam登録「申請」にしか過ぎませんので実際に登録されるかは分かりません。自分のspam登録申請したメールがspamリストに入ったかどうかは「spam登録調査」で確認できます。（参考→手順解説「spam登録状況を確認する」）
  ここの設定でチェックをすると、spam登録後、続けてspam登録状況調査も行うように出来ます。なお、その登録状況画面の見方は松永香澄解説「Cache DB チェッカの見方」（オンライン解説）を参考にして下さい。

(□チェックボックス)Spam登録時のダイアログを減らす。
      (□チェックボックス)更に減らす
  spam登録を頻繁に行って下さる場合、確認画面（ダイアログ）が出てくるのは面倒だと思いますので、ここにチェックをなさって下さい。spam登録の際にダイアログを減らすことが出来ます。一番少なくしたい場合には「更に減らす」にチェックして下さい。

(□チェックボックス)SpamHit時にフォルダに移動させない。
  この項目にチェックをしていると、当プラグインによるspam判定は行っても、それに基づいてのフォルダ振り分けを行いません。「設定」タブの「フォルダ選択」で受信箱（実際の画面では「!!!!Inbox」）を指定した場合と同様になります。
  BkASPilではBecky標準のフィルタリングマネージャとは別に振り分け動作を行う機能を持っていますが、その機能を利用せず、BkASPilのspam判定機能のみを使いたい場合などにこの設定を利用します。この設定項目と、フィルタリングマネージャのルール別タイミング設定を利用することで各種の仕様を実現できますので、下記のページを参照して下さい。
参考：「フィルタリングマネージャのルール別『タイミング』設定の活用について」

(□チェックボックス)Spam登録時にすぐに送信しない。（キャッシュする）
  この項目はspam登録時に動作が重くなることに関して調整するための設定です。
  spam登録を行うと一時的にCPU能力を消費し、さらにはネットワークにアクセスするため、環境によってはパソコンの動作が一旦停止する、重くなるなどの現象が発生することがあります。特に複数のメールを順次登録していく場合などはそれらが積み重なってなかなか登録がはかどらない場合があります。
  それらの現象が気になる場合にはこの項目にチェックをしてください。これにチェックをすると、登録操作をしても実際には直ぐに登録手続きが行われず、一定数のIPアドレスが蓄えられてから登録手続きを行うようになるため、登録操作時の動作がスムーズなる可能性があります。

(□チェックボックス)Bayesヒット時にIPをバックグラウンドで送信する
  この項目ではベイジアンフィルタ方式でspam判定を受けたメールを、自動的にspam登録させることが出来ます。
  「スパムフィルタの概要」で書いているように、当プラグインではブラックリスト参照方式でspamと判定されたメールは自動でベイジアン方式のためのデータベース構築に利用されます（「自動学習」）。ここでの設定項目はそれとは逆に、ベイジアンフィルタ方式によって皆様のところでspamと判定されたメールをブラックリスト参照方式の共有データベースに反映すべく、自動登録が行われるようにして頂くためのものです。
  御使用のパソコンのスペックが低かったり、ネットワーク環境が十分でない（ナローバンドとか）などの場合には、パソコンの動作が重くなったり、一時的に止まったする場合がありますので、環境が許す場合のみチェックして登録に御協力下さい。
  なおベイジアンフィルタ方式でspamと判定されるメールが多い場合、一通毎に通常のspam登録が行われるとパソコンの動作に大きな影響があるため、前項の「Spam登録時にすぐに送信しない」がチェックされている場合のみ、選択することが出来ます。

(□チェックボックス)X-Spam-Flag:Yesがある場合、フィルターを通さない
  他のフィルタリングツールでspam判定されたメールを、当プラグインで判定する必要がない場合、この項目にチェックをして下さい。


プラグインの設定「高度な設定」タブ 2_Bayesianの設定１

  「Bayesianの設定タブ」の下には、以下の「設定タブ」と、次の頁解説の「データベースの調整タブ」との２つのタブがあります。まず「設定タブ」を解説します。

(□チェックボックス)Bayesianフィルタを使用する

  ベイジアンフィルタ方式を利用する場合にはチェックを入れて下さい。チェックを外すとブラックリスト参照方式のみで判定します。特に不具合がなければチェックしておかれることをお勧めします。

以下、「設定タブ」です。「データベースの調整タブ」は次のページにあります。

(□チェックボックス)自動学習をやめる

  当プラグインではブラックリスト参照方式でspamと判定されたメールは「spam」であることを確定して、ベイジアンフィルタ方式の為の学習に利用しますが、これを「自動学習」と呼んでいます。このチェックを入れると自動学習は行われません。
  ブラックリスト参照方式で誤判定を受けるメール（メールヘッダを参照のこと）が多い場合などはチェックを外すと良いでしょう。ただしここのチェックを外した場合、御自分でspam学習の操作をして頂かないとベイジアン方式によるフィルタはほとんど機能しなくなりますので御注意下さい。

（数値記入）ベイジアンの各種設定数値

  ベイジアンフィルタにより判定をする際の詳細な設定です。詳しい人向けです。

(□チェックボックス)日本語メールはBayesianの対象外とする。

  ベイジアンフィルタ方式に関して日本語メールを判定の対象外とする場合にはチェックを入れて下さい。
  日本語メールは文字コードが異なるため、判定がうまくいかない可能性があります。誤った判定が頻発する場合にはこれをチェックして取りあえず日本語メールはベイジアンフィルタの対象外としてみて下さい。

－－－簡単Bayesian設定－－－
（ボタン）　「強い」　「普通(default)」　「弱い」

  前記の各種設定について簡易に設定することが出来ます。
  「強い」というのは「標準」に比べて「spamらしさ」が低くてもspamと判定することを示しています。「弱い」はその逆です。

－－－方式の選択－－－
  ベイジアンフィルタ方式では一般にいくつかの方式が提案されています。当プラグインではその方式を以下の中から変更することが出来ます。ベイジアンフィルタ方式でのフィルタリングがあまりうまくいかないと思われる場合、他の方式を選択してみて下さい。ただし当チームでも各種方式は十分に運用調査していませんので自己責任でお願いいたします。

「Paul Graham方式」「Gary Robinson Fisher方式」「Gary Robinson方式」


プラグインの設定「高度な設定」タブ 2_Bayesianの設定２

  「Bayesianの設定タブ」の下には、前頁解説の「設定タブ」と、「データベースの調整タブ」との２つのタブがあります。ここでは「データベースの調整タブ」を解説します。

  ここではベイジアンフィルタ方式によって蓄えられた学習データベース（spamデータベース）の初期化や大きさの調整を行うことが出来ます。「メール学習数」「トークン数」の用語については設定「about」タブの解説を御覧下さい。

[初期化]
  データを初期化します。学習したデータが失われ、ベイジアンフィルタ方式によるフィルタリング効果が一時的に低下しますので御注意下さい。

［コンパクト化］
  データベースをおおよそ現在の半分のサイズにします。データベースが肥大化して受信動作などが遅くなっていると疑われる場合はこれを実行してみて下さい。なお、これを実行する前に「保存」でバックアップしておかれると良いでしょう。

［保存］
  spam（もしくはclean）データベースのバックアップを取ることが出来ます。

［復元］
  「保存」で記録したバックアップの復元が出来ます。

［インポート］
  下記の「エクスポート」でファイル化されたデータベースを読みとることが出来ます。警告が出ますように、他のデータベースをインポートすると誤判定が増える可能性があります。

［エクスポート］
  spamデータベースをファイル化します。これにより別なところにある当プラグインで利用することが出来ます。ファイルの拡張子は「.std」がつきます。保存方法はボタンを押して適当な保存先とファイル名を指定して下さい。


プラグインの設定「高度な設定」タブ 3_拒否TLDの設定

  ドメインの一番後ろの部分は「トップレベルドメイン」（略してTLD）と呼ばれます。一般には国名（日本はjp、韓国はkr、中国はcn）がつくことが多いですが、あとは「com」「net」など国には関係ないドメインがあります。

  ここの設定を使うと特定のトップレベルドメインにより、他の判定結果に関係なくspamとして振り分けることが出来ます。外国とのメールやり取りがほとんどなく、縁の少ない外国ドメインの差出メールアドレスとするspamメールが多い場合には設定を試してみると良いでしょう。


プラグインの設定「高度な設定」タブ　4_プロキシサーバの設定

－プロキシサーバの設定－

  プロキシをお使いの場合には適宜設定して下さい。


プラグインの設定「高度な設定」タブ　5_処置依頼関連の設定

－処置依頼関連の設定－

(□チェックボックス)確認ダイアログを極力少なくする
  spam処置依頼メール作成の際、標準では頻繁に確認のダイアログが出てきます。これは処置依頼の手順を理解しやすくするためのものですが、ここの設定でチェックするとそのダイアログを極力減らすことが出来ます。spam処置依頼の手順を十分に覚えた場合にはチェックして下さい。

各種処置依頼支援動作のHotkeyの設定（ヘッダー調査、登録調査、処置依頼送信）

  メールを選択した後にホットキー（ショートカットキー）操作により、上記のような処置依頼支援機能を使うことが出来ます。なお、マウスでの操作の方は別途の機能「マウスジェスチャー」をお使いになることをお勧めします。
  設定方法ですが、まず「削除」を行い、文字欄をクリックすると入力できるようになります。そこで「Ctrl」（コントロールキー）、「Alt」（アルトキー）、「Shift」（シフトキー）などのキーとアルファベット文字キーを同時に押して下さい。文字列欄にその組み合わせが表示されるはずですので、それを確認したら「登録」ボタンを押して下さい。以上です。


プラグインの設定「高度な設定」タブ　6_その他の設定

－その他の設定－

(□チェックボックス)HTML表示を完全にオフライン表示にする
  Becky!の標準ではHTML形式のメールを閲覧した際、画像ファイルをオンラインで呼び出すことがあります。この仕組みを悪用し、受信者側情報をスパム発信者が把握できる場合があります。この設定でチェックをすると、HTML形式のメールを読む場合でもオンライン上のデータは取り込まないようにし、上記のような危険性を避けることが出来るようにできます。

(□チェックボックス)起動時にSpalsh画面を表示しない
  Becky起動時に表示する当プラグインの起動・読み込み画面を消すことが出来ます。なお「表示しない」にしても起動速度はほとんど速くなりません。起動時にspamリストの取得をしない設定は次項を参照して下さい。当プラグインの読み込み自体を停止するには「設定」タブの「SpamFilter機能を使用しない」にチェックを入れることが必要です。

(□チェックボックス)起動時にはListを取得しない
  「設定」タブの「定期的にListを取得する」にチェックしていると、Becky起動時にspamリストを取得しますが、その為に起動が遅くなることがあります。この設定にチェックをしていると定期的に取得はしても起動時には取得しません。
  ただし取得をしないということはspamリストを最新にしないということですので、spamフィルタリング精度が下がる恐れがあります。御了承下さい。

HTTPタイムアウト(msec) ［数字入力］

  「設定」タブの「定期的にListを取得する」にチェックしていると、一定時間毎にspamリストを取得しますが、この際にサーバ側の込み具合によってBeckyが一時的に固まることがあります。この「HTTPタイムアウト」の時間を短くするとリストが取得できない場合に短時間で諦めるため、固まる時間を減らすことが出来ます。「質問．CPU使用率が100％になり、Becky操作に支障が出ます」などを参照し、適宜調整して下さい。
  ただし取得を諦めるということはspamリストを最新に出来ないということですので、spamフィルタリング精度が下がる恐れがあります。御了承下さい。

－－－spam登録、判定訂正のHotkey操作－－－
  メールを選択した後にホットキー（ショートカットキー）操作により、登録、判定訂正が出来ます。なお、マウスでの操作の方は別途の機能「マウスジェスチャー」をお使いになることをお勧めします。
  設定方法ですが、まず「削除」を行い、文字欄をクリックすると入力できるようになります。そこで「Ctrl」（コントロールキー）、「Alt」（アルトキー）、「Shift」（シフトキー）などのキーとアルファベット文字キーを同時に押して下さい。文字列欄にその組み合わせが表示されるはずですので、それを確認したら「登録」ボタンを押して下さい。以上です。
－－－－－－－

(□チェックボックス)起動時のチームメッセージを出さない
  当プラグインはネットワーク上のサーバとの連絡を密にしながら動作すること、改訂がしばしば行われることなどから、重要なメッセージを起動時に表示することがあります。この項目をチェックした場合、そのメッセージを出さないようにすることが出来ます。
  何か特別な事情がない限り、この項目にはチェックをしないことをお勧めします。

(□チェックボックス)動作ログを取る
  当プラグインに関して何かしら不具合が起こる場合、その原因を調査するため当プラグイン動作に関するログを取ることが出来ます。不具合が発生した場合には質問集の「エラー、異常終了などが出るのですが、確認事項はありますか？」を参考に対処し、どうしても解決しない場合には動作ログを開発チームまで送って下さるよう、お願いいたします。
  なお、動作ログは起動毎にプラグインフォルダの中に「BkASPil.log」という名前で作成されますが、前回以前のものは「BkASPil.log.txt」に名前が変更され、開発チームに送られるデータはそのログです。

「開発チーム宛にログを送付する」ボタン
  現時点でのプラグイン動作ログファイルを添付した、開発チーム宛のメールを作成します。


プラグインの設定「SpamCop登録状況」タブ

  SpamCopに関しては手順解説「SpamCopとは」をお読み下さい。

SpamCop Site

  SpamCopのメインサイトです。

SpamCop SignUp

  SpamCopにユーザ登録をする際のURLです。SpamCopを利用してSpam報告（処置依頼、苦情）を行う場合には登録が必要です。この登録は2003年現在、無料です。

－Registration Situation－

SpamCopに登録すると各ユーザに固有の報告フォームURLと報告用宛先メールアドレスが与えられます。当プラグインでSpamCopを利用するための設定を行うと、ここにその登録内容が明示されます。設定に関しては手順解説「SpamCop利用の準備」を参照して下さい。

Your spam to

SpamCopからユーザに与えられた固有の報告宛先用メールアドレスです。

You can submit Spam via the Web here

SpamCopからユーザに与えられた固有の報告用URLです。

(□チェックボックス)A browzer is always opened at mail reception from SpamCop

  指定のメールアドレスにSpam報告メールを送信すると、処理終了後に返信のメールが届きます。その返信のメールの中に、報告先のメールアドレスを最終確認するためのページのURLが示されていますが、この設定にチェックを入れているとその返信メール受信と同時に自動でそのページを開きます。

(□チェックボックス)Sendmail SpamCop without SpamRegistrations

ここにチェックを入れるとSpamCopへメールを送る際に、当システムへのspam登録も一緒に行うことが出来るようにします。


プラグインの設定「ホワイトリスト」タブ

  「ホワイトリスト登録」で登録しているメールアドレス、IPアドレスを確認できます。ホワイトリストに関しては手順解説「ホワイトリスト登録とは」を参照して下さい。

-------------------------
メールアドレスタブ

  ホワイトリストとして登録されているメールアドレスです。ここに登録されているメールアドレスが差出人あるいは受取人（送信先）となっているメールはその発信元ないしは中継元IPアドレスがspamリストに入っていてもspamと判定されません。
  リストの中のメールアドレスを右クリックするとそのメールアドレスをホワイトリストから削除できます。また、新たなメールアドレスを登録したい場合、この下の欄にあるフォームより登録できます。

ボタン［アドレス帳のメールアドレスを追加する］
  Beckyアドレス帳にあるメールアドレスを一度にホワイトリストに入力します。アドレス帳には信頼できるアドレスを多く登録している場合には有用です。
  なお、ホワイトリストに御自分のメールアドレス、メーリングリストの投稿先アドレスなどが入ってしまった場合、フィルタリング機能が十分に有効にならない現象が発生しますので御注意下さい（振り分け率が極端に低下するなどが起こります）。その時にはそれらのメールアドレス（特に御自分のメールアドレス）は手動で削除して下さい。

-------------------------
IPアドレスタブ

  ホワイトリストとして登録されているIPアドレスです。ここに登録されているIPアドレスは、spamリストに加わっていてもspam判定を適用しません。
  リストの中のIPアドレスを右クリックするとそのIPアドレスをホワイトリストから削除できます。また、このタブではIPアドレスを追加することが出来ます。


プラグインの設定「Report」タブ

  当プラグインのフィルタリング機能が動作している場合の

  • メール受信数
  • spamと判定されたメール数

を日毎にグラフ化しています。たとえspamメールであっても当システムでspamと判定できなかったメールは「spamと判定されたメール数」に含まれません。

（[ボタン]）BMP形式で画像を保存

  このグラフを画像形式BMP形式（ビットマップ）形式で出力します。

（[ボタン]）Excel形式で画像を保存

Microsoftの表計算ソフトであるExcelのファイル形式で出力します。


プラグインの設定「about」タブ

Web | 当プラグインの公式サイトのURLです。
Mail | 当プラグイン開発チームへの連絡先メールアドレスです。
現在のspamメール学習数 | ベイジアンフィルタ方式で利用する「spamらしさ」のデータベースを構築するのに、何通のメールを学習したかを示します。大体の目安ですので正確ではありません。
現在のSpamToken数 | ベイジアンフィルタ方式で利用する「spamらしさ」のデータベースの中に含まれる「トークン数（単語数のようなもの）」です。
現在のcleanメール学習数 | ベイジアンフィルタ方式で利用する「真っ当なメールらしさ」のデータベースを構築するのに、何通のメールを学習したかを示します。大体の目安ですので正確ではありません。
現在のCleanToken数 | ベイジアンフィルタ方式で利用する「真っ当なメールらしさ」のデータベースの中に含まれる「トークン数（単語数のようなもの）」です。
現在の登録IP数 | ブラックリスト参照方式で利用しているspamブラックリストに関し、プラグインが読み込んでいる（すなわちフィルタリングに使用している）IPアドレス数を表示しています。 2004/08現在、通常ならば200000（20万）、「設定」タブで「SmallSize IPBLを使用する」にチェックが入っている場合は50000（５万）です。


メイン画面での各部名称

  Becky!のヘルプで解説してあるように、Becky!は「ツリービュー」「リストビュー」「メッセージビュー」の三つの部分から成り立っています。次ページからはそれぞれの右クリックメニューで出てくるBkASPilプラグインに関する選択肢について解説します。


ツリービューでの右クリック

  メイン画面のツリービューのフォルダ上で右クリックをした時に出てくるメニューは以下のようになっています。

「ホワイトリストに追加」

  そのフォルダに入っている全てのメールの差出人メールアドレスをホワイトリストに登録することが出来ます。（→参考：手順解説「ホワイトリストに登録する」）


リストビューでの右クリック

  メイン画面のリストビュー上で各メールを右クリックした場合には以下のようなメニューが出てきます。

「選択中のメールを再spam振り分け」

  このプラグインでは受信と同時に指定のフォルダにspamを振り分けますが、すでに受信してしまったメールもフィルタリング可能です。振り分けをしたいメールを選択し、この「選択中のメールを再spam振り分け」を選ぶことで振り分けが出来ます。

「選択中のメールをSpam判定（テスト）する」

  選択中のメールに関し、ベイジアンフィルタによる判定を行うことが出来ます。ここで出た結果の数値によりspamと判定されるか否かは
プラグインの設定－「高度な設定」－「Bayesianの設定」
での設定値により決定されます。

「メールを学習させる」
－＞「選択中のメールをspam学習」
－＞「選択中のメールをclean学習」
－＞「選択中のメールをspam学習データベースより削除」
－＞「選択中のメールをclean学習データベースより削除」

  ユーザによるspam学習に関係する操作は、基本的に「Spamメールとして登録＆学習する」あるいは「プラグインのspam判定を訂正する」の実行で学習もしくはデータベースの訂正を行うことが出来ますが、当プラグイン導入前のメールを学習させたい場合など、学習に関して細かい操作をしたい場合にはここで行って下さい。

「ホワイトリストに追加」
－＞「Fromメールアドレスを追加する」
－＞「IPアドレスを追加する」

  選択中のメールについて、その差出人メールアドレス（Fromメールアドレス）か、IPアドレスをホワイトリストに登録することが出来ます。（参考：手順解説「ホワイトリストに登録する」）
  登録したメールアドレスは設定画面で確認できます。（→参考：画面解説「ホワイトリスト」タブ）

「Spamメールとして登録＆学習する」

  選択しているメールのIPアドレスをspam情報としてシステムに登録します。（→参考：手順解説「Spam登録・学習を行う」）

「プラグインのspam判定を訂正する」

  spamでないメールがspam判定された場合に実行します。具体的にはホワイトリストへの登録やベイジアン学習の訂正などを行います。（→参考：手順解説「プラグインのspam判定を訂正する」）

「メールを調査する」
－「メールヘッダ調査」

  選択したメールのメールヘッダを解析し、spam処置依頼先を探すことが出来ます。これは手順解説「abuse宛に処置依頼を送る」の中で、ヘッダ調査だけを行う場合のものです。

－「spam登録状況調査」

  選択したメールのメールヘッダに入っているIPアドレスが当システムのサーバのspamリストに加わっているかを調査します。これにより表示される画面の見方については松永香澄解説「Cache DB チェッカの見方」（オンライン解説）を参照して下さい。

「Spamメールを報告」
－「調査後にabuseに送信」

  spam処置依頼を送信します。メールヘッダを解析し、処置依頼先を選択、テンプレートを選んでメールを作成します。（→参考：手順解説「abuse宛に処置依頼を送る」）

－「その他に送信」

  spam処置依頼では必ず「ヘッダ＋本文」のメールを作成する必要があります。メール送信に利用されたネット業者に送る場合とSpamCopに送る場合の両者以外にメールを送る場合に、ここを使うことで「テンプレートの内容＋spamのヘッダ＋内容」のメールを作成することが出来ます。（→参考：手順解説「サイト関係のネット業者に報告」「関係官庁に報告」）

－「SpamCopに送信」

  SpamCopに送る為の「spamのメールヘッダ＋spamの本文」のメールを直ちに作成できます。（参考：手順解説「SpamCopに送る」、画面解説「SpamCop登録状況」）


メッセージビューでの右クリック

  メイン画面のメッセージビュー上で右クリックした際には以下のようなメニューが出てきます。

「Webサイトの調査」

  spam本文の宣伝URLに関係するネット業者を調べます。（→参考：手順解説「宣伝サイト関連ネット業者への処置依頼－spam宣伝URLの解析」）

「Spam登録状況調査」

  選択されたメールの発信されたIPアドレスがspamブラックリストに入っているか、すなわち選択されたメールが当システムでフィルタリングされるかどうかを確認することが出来ます。（→参考：松永香澄オンライン解説「Cache DB チェッカの見方」）

「Spamメールとして登録＆学習する」

  選択しているメールのIPアドレスをspam情報としてシステムに登録します。（→参考：手順解説「Spam登録・学習を行う」）


spam処置依頼の正当性

  spam処置依頼を送ることに関してはインターネットの仕組みを支える半公的機関・組織でも以下のようにアドバイスされており、スパム抑止に向けた取り組みの一環と見なされていることが分かります。
  また日本では2002年７月から所謂「迷惑メール規制２法」が施行され、日本データ通信協会と日本産業協会でも違法なスパムメールの情報提供を受け付けています。（→参考：手順解説「官庁への連絡・報告について」）
  • 「日本ネットワークインフォメーションセンター（JPNIC）」
    http://www.nic.ad.jp/ja/
    の「スパムに関するFAQ」
    http://www.nic.ad.jp/ja/translation/apnic/spam.html
    より。

「スパムに対してなんらかの行動を起こしたい場合、スパマーのISPへ連絡をとるべきです。多くのISPは、自らのネットワークでこのような活動が行われることにより評判が傷付くことを認識しており、スパマーに対してなんらかの行動を起こすことができるでしょう。」

  • 「日本インターネット協会（IAJAPAN）」
    http://www.iajapan.org/index.html
    の
    インターネットのルール＆マナー集『迷惑メール対策編』
    http://www.iajapan.org/rule/rule4mail/index.html
    http://www.iajapan.org/rule/rule4mail/guideline02.html#cont01_6

「迷惑メールの被害を少しでも軽減するために、プロバイダ、所轄の団体や公共機関などへ情報を提供すると、悪質な業者の取り締まりにつながることがあります。

【対策】：プロバイダやネットワーク管理者への情報提供
  プロバイダ（携帯電話会社を含む通信事業者）、企業のネットワーク管理者は、特定のアドレスからのメールを停止するなど、実際に発生している被害を排除してくれる場合があります。もし迷惑メールの深刻な被害に遭ったら、プロバイダやネットワーク管理者に相談しましょう。」


ドメインとIPアドレスの関係

ドメインとIPアドレスについて

IPアドレス

  インターネットでは、基本的にはIPアドレスを基準に通信を行っています。IPアドレスは、通信先のコンピュータを決める住所のようなものになります。

  IPアドレスは、現在主に使われている IPv4 アドレスと、今後標準となって行くであろう IPv6 の２つの規格があります。現在のところ、IPv6 は一部で試験的にサービスが始まっているだけですので、ここでは IPv4 のみを取り扱うことにします。IPv4 アドレスは、0～255 の数字４つを「.」記号でつなげた形で表現されます。例えば、127.0.0.1 のように表記されます。

基本的に、IPアドレスは、通信先が世界中でただ１つになるように決められています。そういったアドレスはグローバルアドレスと呼ばれます。

  しかし、そうでないアドレスもあります。spamメールを見る上では、以下のようなアドレスはグローバルアドレスではないので、注意してください。

127.0.0.1
「自分自身」を表すアドレスです。このアドレス宛に通信しようとすると、自分自身に繋がります。

192.168.0.0 ～ 192.168.255.255
172.16.0.0 ～ 172.31.255.255
10.0.0.0 ～ 10.255.255.255
プライベートアドレスといい、各組織で自由に使って良い住所となります。グローバルアドレスが「東京都新宿区新宿1-2-3」というような住所を表すとすれば、プライベートアドレスは「505号室」のような、その組織内での特定の場所を表すものとして使用されます。

IPアドレスは、最初の数値ほど大きな違いを表し、最後の数字ほど小さな違いを表します。AAA.BBB.CCC.DDD と xxx.BBB.CCC.DDD は、日本とアメリカのように、大きな組織的な違いになります。逆に、AAA.BBB.CCC.DDD と AAA.BBB.CCC.xxx は、新宿1-2-3と新宿1-2-4のような、小さな組織的な違いになります。

spamメールのヘッダを見る上で、違いが小さいIPアドレスがあった場合、そのアドレスは同じ事業者によって使われている可能性が高くなります。

ドメイン(example.comなど)

  インターネットでは、通信先の相手をIPアドレスで決定しますが、メールを送ったりする場合に、IPアドレスで相手を指定するのでは覚えにくく、大変不便です。そこで、IPアドレスに対して覚えやすい名前を付けたものが、ドメインです。

  例えば、「example.com は 10.20.30.40 です」といった情報が登録されています。これらの情報が、DNS というサービスで調べることが出来るようになっています。

  メールの場合、「kasumi@example.com」のようなアドレスになりますが、この「@」以降の名前に直接繋げるわけではないため、更に複雑になっています。

  メールを送る場合、まず「@example.com 宛のメールは、どのドメインに送ればよいか？」ということを調べます。
「@xxxx 宛のメールは mail.example.com へ送って下さい」
といった情報のことを、MXレコードと言います。

  次に、「mail.example.com は 10.20.30.100 です」といった情報を調べます。この情報を Aレコードといいます。

  また、逆にIPアドレスからドメイン名を知りたいことも出てきます。通信はIPアドレスで行われますので、通信を受けた側は「相手は 10.20.30.100 です」といった情報しかわかりません。これでは、どんな相手かわからないため、逆に「10.20.30.100 は mail.example.com です」
という情報を調べられるように、PTRレコードという情報が用意されています。

  まとめると、以下のようになります。

１．メールアドレスの@以降から、送信先のドメインを調べる　=>　MXレコードを調べる
２．ドメインから、接続先のIPアドレスを調べる　=>　Aレコードを調べる
３。IPアドレスから、ドメインを調べる　=> PTRレコードを調べる

  なお、２をすることを「正引き」または「順引き」、３をすることを「逆引き」と呼びます。ただし、これらの情報は必ずしも信頼できるものではない可能性がある点に注意が必要です。MX、A レコードは、そのドメインの持ち主が、PTRレコードはそのIPアドレスの持ち主が、自由に設定できます。

example.com の持ち主が、自分のIPアドレスではないIPアドレスを登録したり、IPアドレスを逆引きした時に、自分のドメインではないでたらめなドメインを返すことも出来てしまいます。


メールボックスとPlugInフォルダの位置

（以下で参考としてあげている「Ｃドライブ」は一般にシステムが入っているパーティションです。複数のOSをインストールしている場合にはDドライブやEドライブになる可能性があります）

●メールボックスの場所

  メールボックスはBecky!導入時に決めるものであり、そのフォルダ名などはユーザにより異なります。Becky!のメールボックスはユーザ名が「user-name」とすると一般に以下のような所にある可能性が高いです。

「C:\Becky!\user-name\」（こちらの方が可能性が高いです）
「C:\Program Files\Rimarts\B2\user-name\」（下図参照）

  「メールボックス」と呼ぶときには用語集で解説しているとおり、ユーザ某のメールデータが入っている全体のフォルダ（領域）を指す場合と、同じユーザでもアカウント毎に異なる領域を指す場合がありますが、前者すなわちユーザ某のメールデータが入っている全体の領域という意味では、Becky!をインストールした際に出来るメールボックスは一ヶ所にしかありません。

●プラグインフォルダの場所

  一方で、Becky!のプラグインをインストールする「プラグインフォルダ」の位置としては

  1. ユーザのメールボックスの所
  2. Becky!のプログラムがある所

の二つの可能性がありますが、これはメールボックスと異なり、両者に併存する可能性があります。プラグイン別にどちらかのフォルダに存在する、すなわちたとえば「プラグインＡ」は１にインストールされているが「プラグインＢ」は２にインストールされている、などの可能性があります。

  具体的にはユーザ名が「user-name」とすれば

  1. ユーザのメールボックスの所「C:\Becky!\user-name\PlugIn」（下図参照）
  2. Becky!のプログラムがある所「C:\Program Files\Rimarts\B2\PlugIn\」

の両者に存在する可能性があります。さらに注意して頂くべきなのは、１番「ユーザのメールボックスの所」に関しては当ページ前半で説明しておりますように、
「C:\Program Files\Rimarts\B2\user-name\」
に存在する可能性もありますので、そうなるとプラグインフォルダの場所も
「C:\Program Files\Rimarts\B2\user-name\PlugIn\」
の可能性があります。

  ややこしいことではありますが、当プラグイン関してのみに限らず、Beckyおよび各種プラグインをお使いになる場合には「Beckyの自分のメールボックスの場所１カ所」と「ご自分のプラグインフォルダの場所２カ所」を把握しておかれることをお勧めします。

  プラグインの完全削除の際には、上記二つのプラグインフォルダから削除されていることを確認しましょう。


マウスジェスチャーについて

  「マウスジェスチャー」とは通常のマウスの機能に加えて、クリック（一回マウスのボタンを押す）やドラッグ（選択してボタンを抑えながら移動する）に特別な意味（命令）を与えるようにすることです。BkASPilでは、操作効率向上のため、この機能を導入しており、「右ボタンドラッグ移動」に各種役割を与えるようにしています。以下、設定方法と使用方法を解説します。

【導入方法】

１．プラグインの設定画面「設定」タブを出す。

  画面解説「プラグイン設定画面の表示方法」を参照して設定画面を表示して下さい。

２．「マウスジェスチャーの設定」で「マウスジェスチャー機能を使う」にチェックを入れます（下図参照）。

３．上下左右の動きに役割を与えます。（下図参照）

設定は以上のみです。

【操作方法】（下図参照）

１．目的のメールを選び、マウスポインタ（矢印）をメール本文の上に持って来ます。

２．右ボタンを押しながら、上で設定した方向に移動させます（気分１ｃｍ？？？くらい）。

３．設定した操作が実行されます。以上です。


GeekToolsWhois日本語版の使い方

  ここではインターネットにおいてIPアドレスからその管理を調べるツールGeekToolsWhois（日本語版）の解説をしたものです。

  GeekTools日本語版は、世界中に分散しているいくつかのWhoisデータベースを参照するので、いつも決まった形式で表示されるとは限りません。また、外国のデータベースの場合には英文で表示されます（韓国のデータは英語と韓国語両方で表示されます、文字化けするように見えるかもしれませんがブラウザで韓国語コードを選択するとハングル表記になります）。

  外国の場合に英文のデータベースだからといって躊躇う必要はありません。データベースにしか過ぎませんから覚えてしまえば読解力など必要ありません。まず、必ず覚えておくべきことは

技術連絡担当者
技術管理者
Technical-Contact
Tech-C
Tech-Email

などの肩書きのついている人々のメールアドレスを探すことです。これが適切な処置依頼先です。

  あるいはそれらがない場合には会社の代表メールアドレスでも構いません。場合によっては「spamなどの悪用に関する連絡はXXXXXへ」などとデータベースの中にわざわざ明記してある場合もありますので、その場合にはそのメールアドレスが見つけるべき処置依頼先アドレスです。

  注意すべきことは「データベースに載っているメールアドレスなら何でも良い」とは限らないことです。たとえば
「通知アドレス」
notify:
changed:
などのメールアドレスは適切な処置依頼先ではありません。それから
IANA
RIPE
APNIC
ARIN
などの組織名あるいはそれらを含むメールアドレスが出てきた場合には適切でない確率が極めて高いのでそこに苦情（処置依頼）を送ってはいけません。調べたIPアドレスに問題がある可能性があります。

５．１　パターン１

  ではまず日本語で出た場合を見てみましょう。右図のように出る場合があります。この時、ネット業者が二段になっています。

  右ではぼかしていますが、それぞれの会社名が書いてあり、その右にIPアドレスが併記されています。これはそれぞれの会社の所有IPアドレスであることを示しています。

  このように二段になっているのは上流と下流に分かれている場合です。基本的には両者の会社に同報配信で処置依頼を送るのが良いですので、両者とも調べます。

  次に右のIPアドレスからリンクが張ってありますのでそこをクリックします。

そうしますと上図のように業者の組織名などのデータが出てきます。この中で「技術連絡担当者」に注目しますが、そこで書いてあるのはおそらくまだメールアドレスではなく、ハンドルネームと呼ばれるものです。

  そこもリンクになっていますので、クリックします。そうすると右図のようになり、今度はその管理者に関するデータが出てきます。

  通常はその「メールアドレス」という欄にメールアドレスが記述してありますので、そこが苦情先（処置依頼先）ということになります。

  上流と下流の業者がある場合に、下流の業者にはメールアドレスが登録されていない場合もあります。その場合には上流の登録先にだけ送ります。

  下流にメールアドレスが載っている場合でも、最初に戻って上流の技術連絡担当者のメールアドレスを調べましょう。

５．２　パターン２

  次に外国の例を見ていきましょう。なお、画面の色が実際と違うのは無視して下さい。外国の結果の代表的な一つに以下のようなパターンがあります。

  ハンドルネームとの関連が若干複雑ですが、まず左図で言うと２の所で、緑で囲った管理責任者と青で囲った技術連絡担当者のハンドルネームを確認します。で、この人達のデータがどこにあるかというと、実は下の方に続けて、それぞれの人の名前や連絡先が書いてあります。

  左の場合、管理責任者と技術連絡担当者が一人づつおり、３の表示が２の青い囲みと等しいことからその人が技術連絡担当者であることが分かります。その人のメールアドレスが正しい処置依頼先です。

  なお注意すべきは１の部分、すなわちこのネット業者の担当範囲があまりに広い

［２０３．０００．０００．０００］－［２０３．２５５．２５５．２５５］

などの場合には何かの間違いで、IPアドレスの管理機関のデータが出てしまった可能性があります。「netname」などを見て、企業らしいことを確かめます。

５．３　パターン３

  また、もっとシンプルで会社とその住所や連絡先、サーバ管理人とそのメールアドレスが書いてある場合もあります（右）。

  ただし、この場合には日本と同じように上流と下流に分かれている場合もあります。そのような場合には最初に左のようにでます。ぼかしていますけれども、

ネット業者名（記号の羅列）

というのが二段になっており、その記号の羅列部分をクリックすると、上のような、それぞれの会社のデータが出てきます。メールアドレスもそこに載っているはずです。

  日本の時と同じように上流と下流の両方のデータベースからメールアドレスを見つけだします。

  なお、前述しましたが、外国のデータベース（５．２、５．３のパターン）の場合には「spamなどの悪用に関する連絡はXXXXXへ」などと明記してある場合もあります。特にスパムの処置依頼に関しては

abuse＠ujauja.com

などのメールアドレスがスパムなどの処置依頼先になることが多いです（abuse窓口）。

  GeekToolsの日本語化にあたり、「abuse」の文字周辺は赤字で表示するようにしてありますので、赤字の文字には注意して下さい。上で述べた「技術連絡担当者」や「Tech-C」の文字も赤字で表示されるようにしています（なお、単にそれらのキーワードが赤くなるようにしてあるだけですので、本当に正しい処置依頼先とは限りません。上で述べた手順で沿って、きちんと探して下さい）。

  以上がGeekTools結果（Whois）結果での、処置依頼先メールアドレスの見つけ方です。


spamの宣伝サイトの閲覧とソース

  ソースというのはホームページの内容を表すプログラムです。プログラムと言っても、ホームページの場合は「タグ」と呼ばれる<　>で囲った部分（HTML言語）を多く持つテキスト形式の文章から成り立つもので、Ｃ言語などの論理式・数式を主体とするプログラムとは随分雰囲気の違うものです。そしてホームページの場合、「ソースを書く」＝「ホームページを作る」という意味になります。

  「悪意あるプログラムが実行される」とは、このテキストで書かれたソースをブラウザ（ホームページ閲覧ソフト）で見ることにより発生します。けれども、そのソースをブラウザを使わずにWindows標準の「メモ帳」などを使い、テキストの文章として見る限りは、ほとんどそのような問題が起こりません。ゆえに怪しいホームページを覗く際には、まずソースを見て問題のあるプログラムがないかなどを確認することが出来るのです。

  一般にホームページのソースは「http://」の前に「view-source:」をつけることで見ることが出来ます。スパムの場合、ありがちなのは

  • すぐ別な頁でジャンプするようになっている
  • 表紙だけそこのサイトで作っており、リンク先は別なところでそちらがメイン

などがあります。そのような場合にはジャンプ先や、リンク先のネット業者に苦情を言うことが必要なときもあるでしょう。

  ただしソースの表す内容がどういう風になっていれば「怪しいか」はある程度HTML言語を知っていなければなりません。けれども前述のようにHTML言語は他のプログラム言語とかなり違い、難しいものではない（技術系の感覚だとこれを本当にプログラムというのかいまいちピンとこないのですが．．．．）ですので、一度学んでみるのも良いかもしれません。

  なおソースを見る際にテキストを見るための「メモ帳」などのソフトが起動しますが、それはほとんどセキュリティ上、問題になることはありません。


フィルタリングマネージャのルール別「タイミング」設定の活用について

  標準のフィルタリングマネージャにせよ、当プラグインBkASPilにせよ、Becky!でフィルタリング機能を使っているユーザにとって重要な改善がBecky!InternetMail本体において2005年２月に行われました。（当然のことですが、改善を行ったのはBecky!の提供・販売元であるリムアーツ様であり、当プラグインを提供している開発チームではありません。）

  すなわちBecky!InternetMailの2.20版より「フィルタリングマネージャ」の「フォルダへの振り分け」のオプションとして「デフォルト」「自動」「手動」のいずれかをルール毎に設定できるようになりました。これはフォルダへの振り分けタイミングをフィルタリングルール毎に「受信直後」「手動」のどちらにするかを選べるようにするための設定です。
  このページでは当プラグインの使い方にも影響する上記設定について若干解説します。

・フィルタリングマネージャのオプション「受信時にフォルダへの振り分けをしない」機能

  「フィルタリングマネージャ」はフォルダへのメール振り分け等のルールを設定する機能ですが、もともと、この「オプション」として「受信時にフォルダへの振り分けをしない」という設定があります。
  メールの受信数あるいは分類しているフォルダ（さらにはその階層）が多いユーザは、受信直後にフィルタリングマネージャの振り分けが行われる場合、受信後に数多くのフォルダを見て回らねばならならないことになるため大変不効率です。そのような場合、上の設定で「振り分けをしない」に選択しておくと、一旦全てのメールは受信ボックスに入りますので新規受信メールはそこで確認し、振り分けはそこでの確認後にユーザが手動で「振り分け」操作を行うことで実行すれば良いため、非常に便利です。このような使い方がどの程度一般的かは分かりませんが、私個人としてはそのような使い方をしている人がかなり多いと推測しています。

  上のような使い方は「受信した全てのメールが真っ当なメールであり、ユーザは受信後に全てのメールの中身を確認する必要がある」という前提のもとに作られたと思われ、実際その場合にはほとんど問題がありませんでした。
  ところが．．．．

・上記機能によりspamフィルタとしてのフィルタリングマネージャ利用が困難に

  上記の設定はBecky標準のフィルタリングマネージャを「spamフィルタ」として使うことを困難にすることとなりました。なぜならばspamフィルタリングでは「spamの可能性が高いメールを排除する」ことが目的なので、振り分け前に受信箱に入ってしまうことは他のメールと異なって適切でないからです。

  BkASPil以外にもBecky!と併用できるspam対策用ツールは「POPfile」「SAProxy」「ウイルスバスター2005の迷惑メール監視機能」などがありますが、それらはメールヘッダやメールのサブジェクトに特定文字を付けるだけであり、実際の振り分け動作は標準機能であるフィルタリングマネージャに依存していました。その結果、上述のような使い方をしているユーザにとってはそれらフィルタリングツールのBeckyでの活用には限界があり、その点でフィルタリングマネージャの設定に関係なく「spamの疑いの大きいメール」を指定のフォルダに強制的に振り分けるBkASPilのフィルタリング機能は魅力的だったと思われます。

・新機能のルール別設定でフィルタリングマネージャをspamフィルタに

  しかしながら、最初に述べたように2005年２月のVer.2.20から「フォルダへの振り分け」のルール別に「デフォルト」「自動」「手動」の中から振り分けタイミングを選択できることになりました。
  この機能を利用することで、BkASPil以外のspam対策ツールでもBkASPilと同様に、spamと判定されたメール「だけ」を受信直後に振り分けることが出来るようになりました。

  すなわち、各種spam判定ツールでタイトルやメールヘッダに加えられた文字列を振り分け条件とするルールを作成、その時のアクションとして「フォルダへの振り分け」を選択、そのオプションとしてタイミングに「自動」を選択します。これによりこの条件に合うspamの疑いが高いメールを受信直後に特定の振り分けることが出来ます。

・当プラグインでの利用

    上記設定は当プラグイン利用の際にも活用することが出来ます。もともとBkASPilにはフィルタリングマネージャに関係なく受信直後にメールを振り分ける機能がありますが、

「プラグインの設定」の表示－「高度な設定」－「SpamFilter関係の設定」

で「spamHit時にフォルダに移動させない」にチェックをし、振り分け操作はフィルタリングマネージャで行うことで、BkASPilの設定では未装備だった以下のような仕様を実現することが出来ます。

  • 各メールボックス別にspamの振り分けられるフォルダを変える（参考FAQ）
  • フィルタリングマネージャの振り分け後にBkASPilの判定で振り分ける（参考FAQ）
  • ユーザ独自のルールでspamとして振り分ける（参考FAQ）
  • 振り分けと同時にごみ箱からも削除する（参考FAQ）


質問集(FAQ)

BkASPil　質問集(FAQ)

御質問・御要望は当プラグインサポートBBSあるいは下記アンケートページへ
当プラグインアンケート「質問事項」
当プラグインアンケート「具体的な要望事項」

2005/08/20 改定　第2.4.8版

質問目次

総合

インストール

動作環境

spamフィルタリング(1)

spamフィルタリング(2)

spam登録＆学習全般

ブラックリスト参照方式絡み

ベイジアン学習方式絡み

spam処置依頼支援機能

ユーザ登録

操作・動作全体

設定画面

トラブル一般１　各種不具合

トラブル一般２　解決しないとき

その他

総合
Ｑ．スパムメールが多くて困っています。Beckyをメールソフトとして導入して、このspam対応プラグインBkASPilを使うとスパムは減りますか？
Ｑ．当解説書やプラグインの設定で使われている○○という用語が分かりません。
Ｑ．当プラグインに関して質問があります。
Ｑ．当プラグインに関してＸＸという要望があるのですが？
Ｑ．このツールを使うユーザはどのようなことが求められますか？

インストール
Ｑ．どのようにインストールするのでしょうか？
Ｑ．以前のバージョンの当プラグインを導入しています。新しいバージョンを導入したいのですが、上書きインストールで良いのでしょうか？
Ｑ．インストール時「Please Install Becky! ver.2.08.00 and later」と出てインストールできません。
Ｑ．インストールしたのにBeckyで当プラグインが認識されていないようです。
 Ｑ．[重要] インストールしたらBecky!がおかしくなりました。
Ｑ．[重要] プラグインの完全な再インストールをしたいのですが。

動作環境
Ｑ．他のソフトとの相性はどうなっていますか？共存できるのでしょうか？
Ｑ．Becky英語版で不具合が出ます。
Ｑ．IMAPには対応していないのですか？
Ｑ．ネットに接続していない状況でエラーが出ます。

spamフィルタリング(1)　全般
Ｑ．受信した個々のメールが当プラグインで振り分けされた（あるいは振り分けされなかった）理由を知りたいのですが？
Ｑ．[頻繁] メールを受信することなくメールサーバ上で消すことは出来ませんか？
Ｑ．[頻繁] 振り分けと同時にごみ箱の中からもすぐに消すようにして欲しいのですが。
Ｑ．[重要] 振り分けが全くされないようです。
Ｑ．[重要] spamと判定されるものが一部しかありません。
Ｑ．spamとして振り分けされたメールは既読になるようにしてほしいです。
Ｑ．フィルタリングマネージャの振り分けがされてから、当プラグインでのspam振り分けをしてほしいです。 !改訂!
Ｑ．メールボックスの境界を越えて、全てのメールアカウントのspamと判定されたメールが一箇所のフォルダに振り分けられてしまいますが？
Ｑ．日本語以外（英語のみ）のメールを振り分けてほしいのですが？
Ｑ．[お勧め] ユーザ独自のフィルタリング条件を追加出来るようにしてほしいのですが。 !改訂!
Ｑ．当プラグインは学習するシステムだそうですが、手っ取り早く学習させる方法はありませんか？

spamフィルタリング(2)　意図しないフィルタリング（振り分け）
Ｑ．[重要] まっとうなメールの多くがspamと判定されてしまいます。
Ｑ．[重要] 自分が送信したメールがspamと判定されました。どうしたら良いでしょうか？
Ｑ．[重要] 真っ当なメールがspamと判定されました。そのメールは他の人の所でもspamと判定されるべきではないと思うのですが、どうしたら良いのでしょうか？
Ｑ．[重要] ある人（ある場所）から届くメールがスパムと判定されてしまうのですが、自分のところでspamと判定されてほしくありません。
Ｑ．メーリングリストからのメールがspamと判定されてしまいます。投稿者が違うのでホワイトリストへの登録もきりがありません。
Ｑ．ホワイトリストに登録していないのにホワイトリストに入っているという判定を受けます。
Ｑ．B2 の設定で「重要度１または２のメールは削除を禁止」としているとspam登録しても「ごみ箱」に移動せず、コピーされる。

spam登録＆学習全般
Ｑ．spam登録の際に動作が重くなります。
Ｑ．登録と学習の両者同時ではなく、どちらか一方だけを行いたいのですが。
Ｑ．[重要] うっかりspamでないメールを登録＆学習してしまいました。どうしたら良いでしょうか？
Ｑ．複数のメールを一度にspam登録・学習したいのですが。
Ｑ．[お勧め] ホワイトリストへの登録を簡単に行いたいです。 !改訂!
Ｑ．ホワイトリストを直接編集したいのですが。
Ｑ．「spam登録＆学習」操作をすると勝手にメールがごみ箱フォルダに入ります。
Ｑ．スパム学習をさせるとBeckyが異常終了します。

ブラックリスト参照方式に関すること(spam登録、spamリスト)
Ｑ．[重要] spamでないメールをうっかりspam登録してしまったところ、実際にspamブラックリストに登録されてしまったようです。どうしたら良いでしょうか？
Ｑ．本当にspam登録されたのか確認したいのですが。
Ｑ．「現在の登録IP数」が200000（20万）以上になりません。
Ｑ．DNSBLに登録されていないIPアドレスのメールは、「spam登録」をしても意味がないのでしょうか？

ベイジアンフィルタ学習方式に関すること(spam学習など）
Ｑ．本当に学習が進んでいるのかどうしたら確認できますか？
Ｑ．ベイジアンフィルタについて詳しく知りたいのですが。
Ｑ．学習トークン数が100万以上になりません。
Ｑ．あるパソコンのBkASPilで学習したspamデータを、他のパソコンにあるBkASPilプラグインでも利用したいのです。
Ｑ．ベイジアンによる振り分けの場合にフラグが付く仕様にしてほしいのですが。
Ｑ．旧バージョン「antispamプラグイン」で提供されていたspam処置依頼支援機能を使いたいのですが。
Ｑ．旧バージョン「antispamプラグイン」で提供されていたspamcop利用支援機能を使いたいのですが。

処置依頼支援機能に関すること
Ｑ．ユーザ登録を行ったのに、spam処置依頼メール作成支援機能を使えません。
Ｑ．処置依頼支援を使っていたら『苦情先の指定』などのダイアログボックスなどが見えなくなってしまいました。
Ｑ．支援機能を利用する際のダイアログ（確認メッセージ）が頻繁で鬱陶しいのですが。
Ｑ．メールヘッダを見ている画面で「spamメールを報告する」の動作を行うと、メール本文が引用されずにメールヘッダが二重で引用されます。

ユーザ登録
Ｑ．ユーザ登録で、回答中に失敗し、初めからになりましたがメールアドレスを受け付けてくれません。
Ｑ．複数のメールアドレスを所有していますが、登録するのは一つのメールアドレスだけで良いのでしょうか？
Ｑ．登録されたデータはどのように使われているのでしょうか？
Ｑ．登録データを削除したいのですが。
Ｑ．ユーザ登録を一度しましたが、別なパソコンでも登録して処置依頼支援を使いたいです。
Ｑ．[重要] 再インストールしたためにユーザ登録が消去されてしまいました。
Ｑ．[重要] 登録完了メールを無くしてしまい、再登録できません。
Ｑ．[頻繁] 登録しているメールアドレスを変更したいのですが。

操作・動作全体
 Ｑ．当プラグインを導入しているとたびたび外部にアクセスしているようですが何をしているのですか？
Ｑ．spam登録やspam学習を効率的に行うため、それらの動作のためのショートカットキーの機能をつけて欲しいのですが。 !改訂!
Ｑ．[お勧め] マウスジェスチャーとはなんですか？（効率よく操作がしたいです）
Ｑ．マウスジェスチャーがうまく動作しません。
Ｑ．[重要] Beckyの起動・動作に時間がかかります。 !改訂!
Ｑ．[重要] しばしばパソコンの動作が停止します（固まります）。
Ｑ．[重要] CPU使用率が100％になり、操作に支障が出ます。
Ｑ．メールの受信に時間がかかります。
Ｑ．複数のパソコンで異なるバージョンのBkASPilを使っているのですがスパム判定の差や動作の挙動が両者で異なります。
Ｑ．「Becky起動時にLISTを取得しない」にチェックを入れているのですが、それが機能せず、毎回起動時にプログレスバーが出ます。
 Ｑ．[頻繁] 「メールヘッダー調査」の機能を使うことが出来ません。

設定画面
Ｑ．設定にあるReportのデータはどこにありますか？
Ｑ．設定にあるReportに関して不具合・要望があります。

トラブル一般１　各種不具合
Ｑ．ダウンロードした後の解凍、実行が出来ません。
Ｑ．サーバに関するエラーが出ます。
Ｑ．特定のメールを受信するとBeckyが異常終了します。
Ｑ．他のBeckyプラグインを停止させないとエラーが発生するのですが。
Ｑ．「プラグインの設定」を中心として、日本語部分が文字化けし、各種設定が出来ません。
Ｑ．「高度な設定」の「HTML表示を完全にオフライン表示にする」をオンにすると使用しているブラウザがオフラインモードになってしまうのですが？
Ｑ．BkASPilのトップページには「Ver.2.XXXX の提供を開始しました」と書いてありますが、ダウンロードのページには古いバージョンしか置いてありません。
Ｑ．メール受信時に動作が停止し、進みません。

トラブル一般２　解決しないとき
Ｑ．[重要] おかしくなったので、とにかく元に戻したいのですが。
Ｑ．[重要] エラー、異常終了などが出るのですが、確認事項はありますか？ !改訂!
Ｑ．プラグインの完全削除をしようと思いますが、プラグインフォルダの中にBkASPilのファイルがありません。
Ｑ．[重要] トラブルに関して開発チームに連絡をとる場合に注意することはありますか。 !改訂!
Ｑ．開発チームにメールを送ったのですが返事が来ません。あるいはサポート掲示板に投稿したのですがレスがつきません。

その他
Ｑ．自分の会社の事務効率化のため、becky!のPlug-inの外注開発を依頼したいのですが。
Ｑ．[頻繁] spam対策としてメール発信者に偽装エラーメールを送る機能はないのでしょうか？
Ｑ．解説書（ヘルプ）の画面が青色の時と緑色の時があるのですがどう違うのですか。
Ｑ．このプラグイン「BkASPil」はなんと呼べば良いのですか？
Ｑ．「設定」のaboutタブでのサイトが「http://b2antispam.s33.xrea.com/」になっていません。
Ｑ．当プラグインのメインサイトはどこなのですか。
Ｑ．このプラグインの為に何か手伝えることが自分にありますか？
Ｑ．このツールを使って私の情報が漏洩する可能性はありますか？開発チームの人はどのように私の情報を用いるのでしょうか？
Ｑ．開発チームに連絡が取りたいです。

総合 インストール 動作環境
spamフィルタリング(1) spamフィルタリング(2) spam登録＆学習全般　 ブラックリスト参照方式絡み ベイジアン学習方式絡み
spam処置依頼支援機能 ユーザ登録 操作・動作全体 設定画面
トラブル一般１　各種不具合　　 トラブル一般２　解決しないとき　　 その他

総合

Ｑ．現在、他のメールソフトを使っていますが、スパムメールが多くて困っています。Beckyをメールソフトとして導入して、ここのプラグインBkASPilを使うとスパムは減りますか？

Ａ．　まず、届いている迷惑なメールは本当にスパムメール（一方的迷惑広告メール）でしょうか？ウイルスメールなどをスパムに分類してしまう方々がいます。

参考：迷惑メール撲滅私的調査会　spam質問集質問
「本当にスパム？（＝一方的迷惑広告メール）」
http://www2g.biglobe.ne.jp/~stakasa/spam/spam-FAQ.html#muci-zhende

  もし受け取っておられるメールが本当にspamメールだったとします。その場合に、メールソフトBeckyを導入し、そのプラグインとして当チームで開発しているBkASPilを利用しても、スパムが届くこと自体を速やかに減らすのは難しいと思われます。

  まず当プラグインは「スパムである確率が高いもの」と「そうでないもの」を分けて、別々なフォルダに分類する、仕分け作業の負担を減らす為の機能を持っています（フィルタリング機能）。受信自体をしないことは当プラグインでは出来ません。これについては「スパムフィルタの概要」をお読み下さい。
  なお、最近では各種プロバイダーも迷惑メール対策のサービスを有料・無料で提供するところが多くなっています。御自分の利用なさっているプロバイダーでもそういうサービスがないか、お調べになることをお勧めします。

  さて、当プラグインではフィルタリングとともにspam処置依頼支援機能も柱の一つになっています。2005年現在スパムメール問題はインターネットの中の解決すべき重要な問題として意識されるようになっており、技術的・政治的な取り組みが目指されています。
  そのような各種の対策・対応の中で「spam受信者が発信に利用されたネット業者に対処を依頼し、spam発信者による発信を止めてもらう」という活動があります。このことが多くの人により速やかに行われることで、ネット業者がspam発信者に対して厳しく、迅速な対処で接し、spam発信が抑止されると言う考えです。この考えに基づき、このような行動を支援するための機能が設けられています。

  このような行動は直ちに自分のところに届くspamの現象には結びつくとは限りませんが、少しでもspamの抑止力になると信じ、あなたが無視するだけのspam一通一通に対して、アクションを起こしている方々がいます。もしあなたがそのような考え方に賛同して頂けるならばspam処置依頼に御協力願います。

目次　総合へ

Ｑ．当解説書やプラグインの設定で使われている○○という用語が分かりません。

Ａ．まず用語集をお調べ下さい。そこにない用語はgoogleででも調べて下さい。それでも「どうしても分からない」「どうも当プラグイン開発チームが勝手に作った造語のようだが用語集にもない」などの場合には下記の次の設問「質問があります」で質問して下さい。

目次　総合へ

Ｑ．当プラグインに関して質問があります。

Ａ．出来る限り以下の手順で調べて下さい。

  1. 質問集（本書）を読む。
  2. キーワードで解説書（本書）を検索し、関係記述がないか調べる。
  3. 当プラグインサポートBBSに質問を投稿する。（なるべくそこの過去ログにもざっと目を通して下さい。）
  4. 当開発チームにメールを送る。（メールアドレスはこちらを御覧下さい。）

なお、質問内容が個人情報に絡み、公にしたくない場合には３を飛ばして４をなさっても構いません。なお、開発チームは御返答が出来るとは限りませんので御容赦下さい。

目次　総合へ

Ｑ．当プラグインに関してＸＸという要望があるのですが？

Ａ．出来る限り、以下の手順で要望を出して下さい。

  1. 当プラグインサポートBBSに参加して、要望を投稿する。
  2. そこでの開発者チームあるいは参加者の反応を見る。
  3. 要望が直ぐに叶えられそうにないならば「BkASPil for B2 意見募集・アンケート　具体的な要望事項」に投票しておく。
目次　総合へ

Ｑ．このツールを使うユーザはどのようなことが求められますか？

Ａ．開発チームは以下のような方々を歓迎します。

  • spam登録を積極的に行って下さる方。
  • spam処置依頼を積極的に行って下さる方。

  以下のような方々は当プラグインの使用を御遠慮下さい。

  • 当解説書「免責」内容にに同意できない方
  • 開発の士気を下げるような態度で当ツールに関する意見、提案を述べられる方
目次　総合へ

インストール

Ｑ．どのようにインストールするのでしょうか？

Ａ．「プラグインのインストール」をお読み下さい。

目次　インストールへ

Ｑ．以前のバージョンの当プラグインを導入しています。新しいバージョンを導入したいのですが、上書きインストールで良いのでしょうか。

Ａ．　一般的な話ですが、あるソフトの古いバージョンがインストールされているパソコンに、同ソフトの新しいバージョンをインストールしたい場合、大きく分けて以下の２通りの方法があります。

  • 新規のインストールと同様の手順でインストールする（以前のバージョンを消さないので「上書きインストール」などと言う）
  • 旧バージョンのソフトをアンインストールし、改めて新しいバージョンのインストールを行う

  当プラグインのインストールではどちらの方法を行うべきかについて述べます。、
  当プラグインBkASPilの前身として2003年夏まで提供されていたantispamプラグインがありましたが、導入しているのがその「antispamプラグイン」の場合にはBkASPilを導入する際に旧版をアンインストールしてから、BkASPilを新規インストールして下さい。

  以前のバージョンがBkASPil　Ver.1.xx以降である場合には基本的に上書きインストールで導入可能となっております。ただし当プラグインは比較的改訂が多く、またバージョンアップ毎に上書きインストールでの正常動作の徹底的検証を行っているわけではないため、上書きインストールでは不具合が発生することがあります。もし新しいバージョンを導入したことで何か調子が悪くなった場合には、アンインストールを行い、再度、新規インストールをして下さい。（参考質問「再インストールとは？」）

目次　インストールへ

Ｑ．インストールしたのにBecky上でプラグインが認識されていないようです。

Ａ．まずはBeckyの設定でプラグインが読み込まれるようになっているかを確認しましょう。その手順は

Becky!のメニューバーで「ツール」－「全般的な設定」を選択
                                              ↓
                                            「高度」タブ－右下のプラグインボタン

となります。その画面でBkASPilが読み込みされるようになっているか御確認下さい。その画面のサンプルは「当プラグインの一時停止」に挙げたものを参照して下さい。

  そこできちんと当プラグインの読み込みがされる設定になっている場合には、プラグインの再インストールを行って下さい。
参考：「Ｑ．プラグインの完全な再インストールをしたいのですが」

  それでも解決できない場合には「Ｑ．エラー、異常終了などが出るのですが、確認事項はありますか？」を参照して下さい。

目次　インストールへ

Ｑ．インストール時「Please Install Becky! ver.2.08.00 and later」と出てインストールできません。

Ａ．上の表示は「Beckyのバージョン2.08以降のバージョンをインストールして下さい」という意味です。

  動作環境に書いておりますように、当プラグインはBecky! ver.2.08以上が必要です。Becky! ver.2.08以上をインストールして下さい。
  Beckyのバージョンアップの方法についてはここで詳説しませんが、ソフト一般のインストール方法については
質問「以前のバージョンの当プラグインを導入しています。新しいバージョンを導入したいのですが、上書きインストールで良いのでしょうか」
などを参考にして下さい。Beckyは上書きインストール可能ですので、
Becky!公式サイト
より最新版をダウンロードし、実行して下さい。（パソコンに詳しくない方は実行ファイル形式の方をダウンロードすることをお勧めします。）

目次　インストールへ

Ｑ．インストールしたらBecky!がおかしくなりました。

Ａ．「導入した際に不具合が発生したら」の（１）と（２）を参照して下さい。御利用を続けたい場合には、完全な再インストールを行ってみることをお勧めします。その手順については「Ｑ．プラグインの完全な再インストールをしたいのですが」の回答を参照して下さい。

目次　インストールへ

Ｑ．プラグインの完全な再インストールをしたいのですが。

Ａ．通常問題がない場合には「プラグインの削除」を行うだけで構いませんが、トラブルなどに伴う再インストールの場合には以下の手順で行って下さい。

１．Beckyを終了する。
２．当プラグインの削除を行う。
３．関係するファイルを削除する（プラグインの完全削除）。
  なお、この際にプラグインの入っているフォルダは２カ所の可能性があります。一方のプラグインフォルダのものだけを削除したり、あるいはそこで見つからないまま、削除したと思う方が多いようですので御注意下さい。どちらのプラグインフォルダからもBkASPil関係ファイルが削除されたことをよく確認して下さい。
４．Beckyを起動して当プラグインが削除されたことを確認する。すなわち「プラグイン設定画面の表示方法」でBkASPilの設定がないことと、更には「プラグインの一時停止」の設定の場所にもBkASPilがないことを確認する。
５．当プラグインのインストールを行う。
６．Beckyを起動し、当プラグインが読み込まれることを確認する。

  なお、上記措置では当プラグイン関係のデータ（グラフ、ホワイトリストなど）は削除されますので御了承下さい。

  さらにですが、当プラグインをインストールしたBeckyが異常終了することに絡み、レジストリ操作による改善方法が報告されています。しかしながらレジストリの操作に関しては誤った操作をした場合、WindowsOSが起動しなくなる危険性もあります。よく御理解の上で試みて下さい。

［異常終了に関し、報告されている改善方法］
レジストリエディタにより
\HKEY_CURRENT_USER\Software\RimArts\B2\Settings
のActivePlugins キーを削除し、Becky! にすべてのプラグインを再認識させる。

目次　インストールへ

動作環境

Ｑ．他のソフトとの相性はどうなっていますか？共存できるのでしょうか？

Ａ．十分に確認されていませんが特に問題は発見されていません。ウイルスバスター、ノートンセキュリティ、SAProxy、POPFileなどとの共存可能が報告されています。
  なお、一部のBecky用プラグインと併用した場合の不具合が報告されています。
参考「Ｑ．他のBeckyプラグインを停止させないとエラーが発生するのですが。」

目次　動作環境へ

Ｑ．Becky英語版で不具合が出ます。

Ａ．恐縮ですが当プラグインは日本語版Beckyのみの対応となっております。
（対応未定の御要望は当プラグインアンケート「具体的な要望事項」へ）

目次　動作環境へ

Ｑ．IMAPには対応していないのですか。

Ａ．基本的には対応できないと考えて下さって構いませんが、「選択中のメールを再spam振り分け」を使うことで多少代用できます。画面解説「リストビューでの右クリック」を参照して下さい。

目次　動作環境へ

Ｑ．ネットに接続していない状況でエラーが出ます。

Ａ．当プラグインは常時接続での利用を前提としています。特にフィルタリング関連でサーバと頻繁に通信を行いますので、ネットに接続していないとエラーが多発する場合があります。

  その場合には手順解説「フィルタリング機能の停止」の方法でフィルタリング機能を停止して下さい。

目次　動作環境へ

spamフィルタリング(1)　全般

Ｑ．受信した個々のメールが当プラグインで振り分けされた（あるいは振り分けされなかった）理由を知りたいのですが？

Ａ．当プラグインは個々の受信メールに対する判定結果をそれぞれのメールヘッダに「X-BkASPil-」とつく行で記録します。よって受信メールが振り分けされた（もしくは振り分けされなかった）理由を知りたい場合にはメールヘッダを御覧下さい。

  付与した行にどのような意味があるかは「スパムフィルタの概要」の頁を御覧下さい。これにより受信者の意図しない振り分け（あるいは振り分け回避）が行われた場合の原因調査をすることが出来ます。
  なお、意図しない振り分けについては本頁の質問集「目次　spamフィルタリング(2)」も御参照下さい。

目次　spamフィルタリング(1)へ

Ｑ．メールを受信することなくメールサーバ上で消すことは出来ませんか？

Ａ．出来ません。当プラグインではメール全体を利用してspam判定を行うため、「受信せずに」＝「その内容を読みとることなく」ということは不可能です。

  なお、受信直後に完全に削除し、一切spamが目に触れないようなフィルタリング手法については「Ｑ．振り分けと同時にごみ箱の中からもすぐに消すようにして欲しいのですが。」を御参照下さい。

目次　spamフィルタリング(1)へ

Ｑ．振り分けと同時にごみ箱の中からもすぐに消すようにして欲しいのですが。

Ａ．完璧に正しい判断をするspamフィルタリングを求めるのは困難です。なぜならなんとかして受信者に受け取らせようとするのがスパムメール（spam）の性質だからです。その結果、spamであるメールをspamと判定できない誤判定や、spamでないメールをspamと判定する冤罪が発生する可能性が常にあります。そのような場合に、大事なメールが無断で削除される危険性を鑑み、直ちに完全削除する機能はなくなっております。御理解願います。

  しかしながら、当プラグインはspam判定結果をメールヘッダに記録します。
  すなわち「フィルタリング結果のメールヘッダへの付与」で書いているように当プラグインでspamと判定された場合には、「X-BkASPil-Result: spam」の行が残ります。このこととBecky標準の「フィルタリングマネージャ」の「KILLフィルタ」を組み合わせると、お望みのような「直ちに完全削除」も実は可能になります。「KILLフィルタ」に関してはBeckyのヘルプ「ルールの編集」ページの「アクション」の項目を御覧下さい。

  ただし繰り返して言いますようにspamフィルタリングに完全なものはあり得ませんので、大事なメールを永久に失う危険性を覚悟した上で、自己責任で御利用下さい。

参考：「フィルタリングマネージャのルール別『タイミング』設定の活用について」

目次　spamフィルタリング(1)へ
Ｑ．振り分けが全くされないようです。

Ａ．以下の手順で御確認下さい。

０．インストール後に「フィルタリング機能の基本設定」は行いましたか？

１．動作環境に合っているか確認する。

２．メールヘッダを見て当プラグインによるヘッダ判定が記されているかを確認する。

３．「設定」タブ－SpamFilterの設定で以下の二つを確認する。
    ・「定期的にListを取得する」にチェックが入っているか？
    ・「振り分け先」が意図するフォルダになっているか？「今すぐ更新」も押してみる。
  また「プラグインの設定」の「高度な設定」タブの「Bayesianの設定」で以下を確認。
    ・「Bayesianフィルタを使用する」にチェックがついているか？
  さらに「プラグインの設定」の「高度な設定」タブの「SpamFilter関係の設定」で以下を確認。
    ・「SpamHit時にフォルダに移動させない」のチェックがはずれているか？

４．「ブラックリスト参照方式」に関しては、設定の「about」タブで登録IP数が20万もしくは5万になっているかを確認する。
  spam判定できなかったメールについてリストビューでの右クリックから
「spam登録状況を確認する」
を行う。そこで出てくるホームページで、このspamの関係IPアドレスがブラックリストに入っているかをチェックする。
  ブラックリストに入っていなかったのならば、振り分け出来なかったことは異常ではありません。spam登録に御協力下さい。ブラックリストに入っているのに振り分けられない場合には、しばらく様子を見て同現象が続くなら開発チームへの報告をお願いします。

５．「ベイジアンフィルタ方式」に関しては、spam判定できなかったメールについてリストビューでの右クリックから「選択中のメールをspam判定する」をクリックし、その値を確認する。
  その値が「プラグインの設定」の「高度な設定」タブの「Bayesianの設定」で設定された値よりも小さい場合は正常動作です。spam学習を行い、同様な内容のメールが今後はspam判定されるようにして下さい。学習を行っているのに振り分けが全くされない場合、「プラグインの設定」の「about」タブで「学習メール数」「トークン数」が学習するごとに増加することを確認して下さい。
  もしそれらの動作に問題がある場合には、プラグインの再インストールを行い、それでも現象が続くようなら開発チームまで御相談下さい。

目次　spamフィルタリング(1)へ
Ｑ．spamと判定出来るものが一部しかありません。（振り分けされるものが少ないです。）

Ａ．まず、大変失礼なことを申し上げて恐縮なのですが、ウイルスメールや嫌がらせメールをspamメールだと思いこむ方がときどきいらっしゃいます。当然のことながらそのようなメールは当プラグインでフィルタリングできませんので、もう一度spamメールの意味をご確認下さい。

  別な可能性としてホワイトリストに御自分のメールアドレスやIPアドレスが入っている可能性があります。ホワイトリストのメールアドレスは受信メールの「Toアドレス」にも適用されるからです。すなわち受信したメールの「Toアドレス」にホワイトリストのメールがあった場合にはspamとしての判定は受けません。振り分けに失敗したspamメールのメールヘッダを確認し、
X-BkASPil-Result: white
の記述がある場合にはその可能性があります。ホワイトリストを確認するか、それを一旦クリアして、様子を見て下さい。

  それと異なるようでしたら「Ｑ．振り分けがまったくされないようです」の回答と同じ点を確認して下さい。

  当プラグインではユーザの方々にフィルタリング成功率のアンケート回答をお願いしています。そこで他の方々のフィルタリング成功率と御自分のものを比較して、誤差範囲内にあるかをお調べ下さい。spamの届くパターンには様々な場合があり、場合によっては当プラグインでの効果が薄くなってしまう方も出てくると考えております。

目次　spamフィルタリング(1)へ
Ｑ．spamとして振り分けされたメールは既読になるようにしてほしいです。

Ａ．当プラグインは判定結果をメールヘッダに記述します。そのこととBecky標準のフィルタリングマネージャを組み合わせることで、当プラグインでspam判定されたメールを既読にすることが出来ます。

１．フィルタリングマネージャを起動

２．「新規ルール」ボタンを押す

３．「条件の追加」でヘッダに「X-BkASPil-Result」を選択(もしくは作成)、文字列に「spam」指定。

４．アクションでは「振り分け」で「フラグをつける/既読にする」を選択。さらに「既読にする」のチェックボックスにチェック。

  以上です。

目次　spamフィルタリング(1)へ

Ｑ．メールボックスの境界を越えて、全てのメールアカウントのspamと判定されたメールが一箇所のフォルダに振り分けられてしまいますが？

Ａ．これは仕様です。ただし以下の設定で各ユーザにて対応出来ると思われます。

１．「プラグインの設定」の表示－「高度な設定」－「SpamFilter関係の設定」

２．上記の中の「spamHit時にフォルダに移動させない」にチェックをつける。

３．各メールボックスのフィルタリングマネージャの設定で、ヘッダ「X-BkASPil-Result」が「spam」の時に任意のフォルダに振り分けられるようにするルールを作成する。
  この時、そのルールの「タイミング」を「自動」に設定して下さい。それにより受信と同時に振り分けられます。

参考：「フィルタリングマネージャのルール別『タイミング』設定の活用について」

目次　spamフィルタリング(1)へ
Ｑ．フィルタリングマネージャの振り分けがされてから、当プラグインでのspam振り分けをしてほしいです。

Ａ．仕様です。ただし以下の設定で対応出来ると思われます。

１．「プラグインの設定」の表示－「高度な設定」－「SpamFilter関係の設定」

２．上記設定の中の「spamHit時にフォルダに移動させない」にチェックをつける。

３．フィルタリングマネージャの振り分けルールの最後のルールとして、ヘッダ「X-BkASPil-Result」が「spam」の時に特定のフォルダに振り分けられるようにするルールを作成する。

参考：「フィルタリングマネージャのルール別『タイミング』設定の活用について」

目次　spamフィルタリング(1)へ
Ｑ．日本語以外のメールを振り分けてほしいのですが？

Ａ．当プラグインを利用しなくても、Beckyの標準機能である「フィルタリングマネージャ」の利用により英語のみ（日本語が入っていない）メールを特定のメールフォルダに振り分けることが出来ます。「英語のみ」のメールと言うよりも、日本語のメールでは平仮名が使われていないメールはあり得ないということを前提に、平仮名が一字もない場合を英語のメールだと判定するものです。

１．フィルタリングマネージャを起動

２．「新規ルール」ボタンを押す

３．「条件の追加」でヘッダに「body」を選択、文字列に「あ-ん」を指定、ラジオボタン「ある時」「ない時」では「ない時」を選択、チェックボックスで「正規表現」を選択。

４．アクションでは「フォルダへの振り分け」、タイミングで「自動」を選択。

５．振り分けたいフォルダを指定する。

  以上により、ひらがなの「あ」から「ん」までが一文字もないメールを振り分けることが出来ます。

参考：「フィルタリングマネージャのルール別『タイミング』設定の活用について」
参考：質問「ユーザ独自のフィルタリング条件を追加出来るようにしてほしいのですが。」

目次　spamフィルタリング(1)へ

Ｑ．ユーザ独自のフィルタリング条件を追加出来るようにしてほしいのですが。

Ａ．BkASPilはメールを受信直後に指定のフォルダに振り分けますが、その振り分ける条件として当プラグイン独自の判定（すなわちブラックリスト参照とベイジアン学習）の他に、ユーザ独自の条件（たとえば特定のIP、メールアドレス、メールソフトなど）を加えられるようにしてほしいという要望があります。
  このようなユーザ個別の独自条件を、開発チームでは「ローカルなspam条件設定」などと呼んでいますが、恐縮ですがそのような機能の導入予定はありません。これは当プラグインBkASPil開発では
「Beckyの標準機能で可能な機能は極力装着しない」
という方針を立てており、「ローカルなspam条件設定」はBecky標準の機能「フィルタリングマネージャ」で設定可能と考えているからです。

  特にBecky本体のフィルタリングマネージャの機能に関しては、2005/02のVer.2.20から、ルール個別の振り分けタイミングを「自動」（受信直後）、「手動」、「デフォルト」から選べるようになりました。これにより、フィルタリングマネージャの「オプション」で「受信時/送信時にフォルダへの振り分けをしない」にチェックをして受信直後には振り分けないようにしている方でも、spamに関するルールだけは個別に振り分けタイミングを「自動」にすることで、受信直後に振り分けることが出来るようになりました。
  BkASPilの設定で「標準のフィルタリングマネージャのようにいろいろな条件をつけてほしい」と思っていた方は、一層便利になったBecky標準のフィルタリングマネージャを是非活用して下さい。

参考：「フィルタリングマネージャのルール別『タイミング』設定の活用について」

  なお余談ですが、BkASPilの開発で前述のような方針を立てたのは、BkASPilの前身である「b2antispamプラグイン」の開発時、少しでもフィルタリングに便利と思われる機能をどんどん取り入れていった結果、似たような機能がプラグイン自体の中ですら重複するまでに至ってしまい、混乱を招いたことからの反省に基づくものです。

  加えてBkASPilで扱うspamリストは、フィルタリング精度向上の為に大きなデータとなっており、それによりBkASPilの動作もかなり重くなっています。余計な機能（Becky標準で代用できる機能）をつけないことは少しでも動作を軽量化する目的にも合致しております。御理解下さい。

目次　spamフィルタリング(1)へ
Ｑ．当プラグインは学習するシステムだそうですが、手っ取り早く学習させる方法はありませんか？

Ａ．当プラグインはブラックリスト参照方式とベイジアンフィルタ方式の２本立てであり、「フィルタシステムの概要」にあるとおり、後者の方式では学習を行います。もし純粋に前者だけの方式ですと、2005年７月現在50～60％のフィルタリング率ですが、後者の方式を取り入れることで最終的には90％以上になるのが一般的です。そうなる前に学習が必要なわけですが、基本的には「自動学習」により行っていただくと良いと思います。

  しかしながらなるべく早急にフィルタリング率を向上させたいという場合には、他の人の学習済みspamデータを取り込む方法（インポート）があります。これについては「高度な設定」の「データベースの調整」をお読み下さい。インポートするデータは「ダウンロードページ」にあります。なお、所詮は他人のデータですので、誤判定が多い可能性があるのは御理解願います。判定が間違った場合にはきちんと「判定結果の訂正」をして頂かないとフィルタリング率は向上しません。

  なお、ユーザ皆様の利便性のため、導入当初の段階でspam学習データベースを取り込んでおりますので、まずは様子を見られることをお勧めします。

目次　spamフィルタリング(1)へ

spamフィルタリング(2)　意図しないメールのフィルタリング

Ｑ．まっとうなメールの多くがspamと判定されてしまいます。

Ａ．まずメールヘッダを見て、「スパムフィルタの概要」のページを参考に、どのような理由でspamと判定されているかを御確認下さい。

  すなわち、まずメールヘッダに
X-BkASPil-Result: spam
はあるはずですが、
X-BkASPil-BLIP: XXX.XXX.XXX.XXX
と
X-BkASPil-BayesResult:１以下の数字
のどちらがあるかを確認して下さい。

１．前者(X-BkASPil-BLIP: XXX.XXX.XXX.XXX)のメールが多い場合
  手順解説「spam登録されているかを確認する」 をお読みになり、判定されてしまうメールのヘッダに含まれるIPアドレスが実際にサーバに登録されていることを確認して下さい。

  もし登録されている場合にはそれは正常動作です。その場合には以下の質問を参照して下さい。

参考質問
「Ｑ．真っ当なメールがspamと判定されました。そのメールは他の人の所でもspamと判定されるべきではないと思うのですが、どうしたら良いのでしょうか？ 」
「Ｑ．ある人（ある場所）から届くメールがスパムと判定されてしまうのですが、自分のところでspamと判定されてほしくありません。」

  なお、対処療法として小さいサイズのブラックリストを使ってみて下さい。
その方法は「プラグインの設定-設定タブ」で

(□チェックボックス)SmallSize IPBLを使用する

にチェックを入れて下さい。

２．後者(X-BkASPil-BayesResult:１以下の数字)のメールが多い場合

  ベイジアンフィルタ方式でフィルタ判定されるものが多いようです。とりあえずは
「誤ったspam判定を訂正する」
の操作を行うことをお勧めします。
  また、「高度な設定タブ 2_Bayesianの設定１」での

簡単Bayesian設定　「強い」　「普通(default)」　「弱い」

の設定を「弱い」にしてみて下さい。
  それでも解決できない場合には同じ設定個所の「方式の選択」で別な方式を試されることお勧めします。

  それらでも駄目な場合には対処療法になりますが、ベイジアンフィルタ機能を停止して下さい。具体的には「高度な設定タブ 2_Bayesianの設定１」で

(□チェックボックス)Bayesianフィルタを使用する

のチェックをはずして下さい。
  しかしながら「ブラックリスト参照方式」だけでのフィルタリングには限界があります。あなたの環境の元でベイジアンフィルタがうまく利用できないことには何か原因があると思われますので、お時間のある時に調査なさると良いでしょう。

目次　spamフィルタリング(2)へ

Ｑ．自分が送信したメールがspamと判定されました。どうしたら良いでしょうか？

Ａ．これには
「自分宛に（も）送ったメールがspam判定された」
「メーリングリストに投稿した際に自分の投稿がspamと判定された」
などの場合があると思われますが、当プラグインではspamの判定に２方式用いていますので、どの方式によりspamと判定されたか知ることが重要です。

  まずはメールヘッダを御覧下さい。その中に当プラグインがつけたヘッダがあるはずですので「スパムフィルタの概要」を御覧になり、spamと判定された理由をお確かめ下さい。

X-BkASPil-Result: spam
X-BkASPil-BayesResult: x.x
となっている場合、問題のメールはベイジアンフィルタによってspamと判定されたことを示しています。あなたが発信したメールが英文メールであり、それが上記のような判定を受けた場合、あなたのお書きになった英文メールの内容が「spamらしかった」ということを示しています。また、その判定はあなたのパソコンでのみspamと判定されただけで、他の受信者のところではどのように判定されたかは全く不明です。
  同様な内容をspamと判定されないようにするには「clean学習」を行うことによって可能ですが、その場合、あなたへ届く真のspamがベイジアンフィルタでspamと判定できなくなる可能性があります。

  次に
X-BkASPil-Result: spam
X-BkASPil-BLIP: xxx.xxx.xxx.xxx（←４つの数字です）
となっている場合には下記のようになります。

・「自分宛に（も）送ったメールがspam判定された」

  あなたの使用したネット業者のメールサーバがブラックリストに掲載されている可能性が高いです。このブラックリストとは当プラグインのspamリストに加え、当システムが参照したDNSBLのブラックリストに掲載されているということです。
  ブラックリストに掲載されたままの場合、あなたの送ったメールがspamと判定されて受信者の所でゴミ箱フォルダ等に振り分けされてしまったり、最悪の場合には宛先の人に届かなかったりしてしまう可能性があります。
  まずは「spam登録されているかを確認する」を行って、御自分の利用したネット業者のIPアドレスがブラックリストに入っていること、およびそのDNSBLのホームページを確認して下さい。そして利用しているネット業者のお客様担当にメールもしくは電話等で対処依頼・苦情を伝えましょう。

  DNSBLにも様々なポリシーがありますので一概には言えませんが、一般論としてDNSBLに入ることはサーバ管理者にとって不名誉なことです。DNSBLに入っていることはそのネット業者を使ったspammerに対して、サーバ管理者がきちんとしたアクションを取っていないことの証であり、厳しく言えば管理業務の怠慢と言えるからです。また、そのネット業者を利用している真っ当なユーザ（顧客）が迷惑を被る可能性が高くなり、そのネット業者のメールサービスの質の低下（電子メールの信頼性低下）を招くのです。
  ですから、御自分の利用したネット業者のサーバがDNSBLに入っているということは重視すべきことですので、以下のようなメールをお客様担当に送りましょう。

「担当者様へ　御社を使っている○○という者です。使わせて頂いているメールサービスのサーバのうち
IPアドレス xxx.xxx.xxx.xxx のものが
http://xxx.xxx.xxx
（以上の二つは必ず明記しましょう）
という所のブラックリストに入っているようです。当方としては分かりませんけれども、失礼ですがそちらのサーバ管理者様がspam対処を十分にしていない為に、上記ブラックリストに入ったままの可能性があるのではないでしょうか。御対処をお願いいたします。」

  この行動はあなたの利用するネット業者がspam対処に甘い場合、それを厳しくするきっかけとなり、このような行動を皆が行うことでspam問題に積極的に取り組むネット業者が増えるきっかけになると考えます。

・「メーリングリストに投稿した際に自分の投稿がspamと判定された」

  あなたの使用しているメールサーバー、もしくはメーリングリストの配送サーバーがブラックリストに掲載されている可能性が高いです。
  まずは「spam登録されているかを確認する」を行って、御自分の利用したネット業者のサーバと、メーリングリストの配送サーバのどちらがブラックリストに入っているのかを調べましょう。

  御自分の利用したネット業者がブラックリストに入っていた場合は前項での記述を参考して、御自分のネット業者に連絡を取りましょう。
  メーリングリストの配送サーバーがブラックリストに掲載されている場合、あなたに不利益になることはありませんが、可能であればその配送サーバーの管理者に対し、ブラックリストに掲載されていることを通知してください。

  なお、上記のいずれの場合も「取りあえず自分の所ではspamとして判定されないようにしたい」という場合には「Ｑ．ある人（ある場所）から届くメールがスパムと判定されてしまうのですが、自分のところでspamと判定されてほしくありません」の回答を参照して下さい。

目次　spamフィルタリング(2)へ

Ｑ．真っ当なメールがspamと判定されました。そのメールは他の人の所でもspamと判定されるべきではないと思うのですが、どうしたら良いのでしょうか？

Ａ．当プラグインではspamの判定に２方式用いていますので、どちらの方式によりspamと判定されたか知ることが重要です。

  まずはメールヘッダを御覧下さい。その中に当プラグインがつけたヘッダがあるはずですので「フィルタリング結果のメールヘッダへの付与」を御覧になり、spamと判定された理由を御確認下さい。

X-BkASPil-Result: spam
X-BkASPil-BayesResult: x.x
となっている場合、問題のメールはベイジアンフィルタによってspamと判定されたことを示しています。その判定はあなたのパソコンでのみspamと判定されただけで、他の受信者のところではどのように判定されたかは全く不明ですので、他の人のところでの判定を気にするのは杞憂です。
  同じようなメールが、あなたのところでは今後spamと判定されないようにするには「clean学習」を行うことによって可能ですが、その場合、あなたへ届く真のspamがベイジアンフィルタでspamと判定できなくなる可能性があります。その発信者のメールアドレスをホワイトリストに入れる方法もあります。

  次に
X-BkASPil-Result: spam
X-BkASPil-BLIP: xxx.xxx.xxx.xxx（←４つの数字です）
となっている場合には下記のようになります。

  その「真っ当なメール」がspamと判定されたのは、spamメールが発信・中継されたのと同じサーバ（プロバイダーのコンピュータ）から発信されているからだと思われます。そしてその結果、そのサーバは海外のブラックリスト（DNSBL）に載っています。よってそのブラックリストから除かれない限り、そのサーバから送り出されるメールはspamと判定されてしまいます。詳しくは「判定ミスの理由」（オンライン解説）をお読み下さい。

  しかしながらプラグイン動作の不具合も考えられます。まずは「spam登録されているかを確認する」の説明に従ってspam判定されたメール（正確に言えばメールの発信IPアドレス）が本当にspamリストに入っているかを確認して下さい。もしもそこでspamリストに入っていないメールが振り分けされてしまっているならば、プラグイン動作の不具合が考えられますので「Ｑ．プラグインの完全な再インストールをしたいのですが」の方法に従い、当プラグインの完全な再インストールを行ってもう一度様子を見て下さい。

  なお「取りあえず自分の所ではspamとして判定されないようにしたい」という場合には「Ｑ．ある人（ある場所）から届くメールがスパムと判定されてしまうのですが、自分のところでspamと判定されてほしくありません」の回答を参照して下さい。

目次　spamフィルタリング(2)へ

Ｑ．ある人（ある場所）から届くメールがスパムと判定されてしまうのですが、自分のところでspamと判定されてほしくありません。

Ａ． ホワイトリストの設定を行って下さい。メーリングリストのサーバがブラックリストに入った場合にはIPアドレスを、特定の個人の方からのメールがspam振り分けされる場合には差出人メールアドレスをホワイトリストに入れるのが有効です。

  なお「真っ当なメールがspamと判定されました。そのメールは他人の所でもspamと判定されるべきではないと思うのですが、どうしたら良いのでしょうか？」の回答も御参照下さい。

目次　spamフィルタリング(2)へ

Ｑ．メーリングリストからのメールがspamと判定されてしまいます。投稿者が違うのでホワイトリストへの登録もきりがありません。

Ａ． ホワイトリストの設定でＭＬサーバのIPアドレスもしくはＭＬへの宛先アドレスをホワイトリストに入れて下さい。

目次　spamフィルタリング(2)へ

Ｑ．ホワイトリストに登録していないのにホワイトリストに入っているという判定を受けます。

Ａ．ホワイトリストのIPアドレスは受信したメールのメールヘッダ全体、ホワイトリストのメールアドレスは受信したメールアドレスの「Fromアドレス（差出人メールアドレス）」「Toアドレス」に反映されます。
  もし御質問のように感じる場合にはホワイトリストに登録されたIPアドレス、メールアドレスが本当にホワイト判定されたメールヘッダ「全体」にないか確認して下さい。

目次　spamフィルタリング(2)へ

Ｑ．B2 の設定で「重要度１または２のメールは削除を禁止」としていると、spam登録しても「ごみ箱」に移動せず、コピーされだけです。

Ａ．ごみ箱にいかなかった spamを「Spam として登録＆学習」してごみ箱に移動する際に、
１．Spam に重要度「高」のマークがついていて、
２．B2 の設定で「重要度１または２のメールは削除を禁止」をチェックしている
場合、「マークを解除」してから Spam 登録しても、ごみ箱に「移動」されずに「コピー」されて、元のメールはまた重要度マークが元通り「高」が設定されてしまいます。

  これは重要度の高いメールを削除できないBecky本体の仕様です。ヘッダに記述された「X-Priority」がある限りはプラグインの動作で削除することは出来ません。

目次　spamフィルタリング(2)へ

spam登録＆学習全般

Ｑ．spam登録の際に動作が重くなります。

Ａ．重たい原因にもよりますが、軽減できる可能性があります。

「高度な設定」タブ－1_SpamFilter関係の設定

の「Spam登録時にすぐに送信しない（キャッシュする）」

にチェックをして下さい。詳しくはその上記頁解説を御覧下さい。

目次　spam登録＆学習全般へ

Ｑ．登録と学習の両者同時ではなく、どちらか一方だけを行いたいのですが。

  基本的には両者同時に行って頂きたく思います。「spam登録＆学習」の命令の場合、同じメールを複数回重複して学習することなどについては自動的に避けるようになっていますので、そのようなことを心配して頂く必要はありません。
  なお、spam学習・clean学習についてはユーザが利用する際の柔軟性を高めるため、単独で各種の詳細な命令が出来るようになっています。リストビューの右クリックから「メールを学習させる」の各命令をお使い下さい。ただしこれはベイジアンフィルタによる振り分けの誤判定が多いなどの場合に適宜お使いになればよく、特に問題が発生していない場合には「spam登録＆学習」と「判定の訂正」のみで対応可能のはずです。

目次　spam登録＆学習全般へ

Ｑ．うっかりspamでないメールをspam登録＆学習してしまいました。どうしたら良いでしょうか？

  まず「spam登録」の方についてですが、リニューアルされたBkASPilでは、皆様が行う「spam登録」というのは、正確に言えば「spam登録申請」です。申請が行われた場合に、必ずしも登録されるのではありません。よって実際にブラックリストに入るとは限りません。これ以上に関しては「spamでないメールをうっかりspam登録してしまったところ、実際にspamブラックリストに登録されてしまったようです。どうしたら良いでしょうか？」をお読み下さい。

  それから「spam学習」に関してはリストビューの右クリックより「選択中のメールをspam学習データベースより削除」を実行して下さい。

目次　spam登録＆学習全般へ

Ｑ．複数のメールを一度にspam登録・学習したいのですが。

Ａ． spam登録については登録先サーバーの負荷の都合上、一度に多くのIPを送信させる事は出来ない為、現在の仕様になっております。spam学習に関しては複数のメールの一括登録が可能になっています。リストビューで複数のメールを選択し、右クリックのメニューから

「メールを学習させる」－「複数選択中のメールをspam学習」

を選択して下さい。

目次　spam登録＆学習全般へ

Ｑ．ホワイトリストへの登録を簡単に行いたいです。
Ｑ．ホワイトリストを直接編集したいのですが。

Ａ．まず、Beckyのアドレス帳に入っているメールアドレスを一括してホワイトリストに登録することが出来ます。ホワイトリストには信頼できる相手のメールアドレスを登録していることが多いので、一括して登録できるのは便利だと思います。手順は「ホワイトリスト」タブの解説を参照して下さい。ただし御自分のメールアドレスがホワイトリストに入った場合、spamであってもspamと判定されなくなってしまうメールが多くなりますので御注意下さい。一括登録後、御自分のアドレスはホワイトリストから削除なさることをお勧めします。（参考「Ｑ．spamと判定されるものが一部しかありません。」）

  なお、ホワイトリストはCSV形式のテキストファイルという、かなり一般的な形式で作られております。よってWindows標準のテキストエディタ「メモ帳」などで編集できます。

  プラグインがインストールされているフォルダの中に
「BkASPil.whi」－メールアドレスのホワイトリスト
「BkASPil.wh2」－ipアドレスのホワイトリスト
がありますが、その二つがホワイトリストの実体です。これらのファイルをメモ帳などのエディタで直接編集することが可能です。

  なお「CSV形式」とはexcelなどの一般的な表計算ソフトによっても編集しやすくなっている形式であり、「,」（コンマ）と改行から作られているデータです。もし表計算ソフトをお持ちならば上のファイルの拡張子（.whi .wh2）を「.csv」という名前に変え、表計算ソフトで読み込ませれば自由にデータを編集できます。編集した後、元の拡張子に戻して下さい。

目次　 spam登録＆学習全般へ

Ｑ．「spam登録＆学習」操作をすると勝手にメールがごみ箱フォルダに入ります。

Ａ．仕様です。設定で変更可能です。もし勝手に移動させたくない場合には設定で

「高度な設定」タブ－「SpamFilter関係の設定」

の「Spam登録時にごみ箱等に移動させない」にチェックをして下さい。

目次　 spam登録＆学習全般へ

Ｑ．スパム学習をさせるとBeckyが異常終了します。

Ａ．一度

「高度な設定」→「Bayesianの設定」→「データベースの調整」

にてSpamデータ、Cleanデータの保存を行ってから、初期化を行ってどうなるか確認してみてください

  もしそれで解決した場合、なんらかの原因でspamデータベースが破損してしまった可能性があります。申し訳ありませんが今までのベイジアンspamデータは諦めて一から学習し直して下さい。

目次　 spam登録＆学習全般へ

ブラックリスト参照方式絡み(spam登録、spamリストなど)

Ｑ．本当にspam登録されたのか確認したいのですが。

Ａ．以下の解説を参照して下さい。

手順解説「spam登録されているかを確認する」

目次　ブラックリスト参照方式絡みへ

Ｑ．spamでないメールをうっかりspam登録＆学習してしまったところ、実際にspamブラックリストに登録されてしまったようです。どうしたら良いでしょうか？

  当プラグインBkASPilでは、皆様が行う「spam登録」というのは、正確に言えば「spam登録申請」です。申請が行われた場合に、必ずしも登録されるのではありません。

  登録するか否かの基準に関してですが、登録申請が行われたメールのIPアドレスが、当プラグインが選定している海外のspamブラックリスト（DNSBL）のいずれかに入っているかをチェックします。このチェックは申請が行われた後、時間をおいて複数回行われますが、その時に、海外のブラックリストに入っていたことが判明した場合、当プラグインのブラックリストにも追記します。このあたりの仕組みについては香澄氏の解説頁（オンライン解説）を参照して下さい。
  実際にそのメールのIPアドレスが登録されてしまっているかの確認は「Ｑ．spam登録されたかを確認したい」で回答していますので、そちらを参照して下さい。

  不運なことに、間違ってspam登録申請をしてしまったそのメールのIPアドレスが、たまたま上述の海外のブラックリスト（DNSBL）に入っていた場合には、当プラグインでもspamリストに加えられます。そしてそのIPアドレスは、海外のブラックリストから外されなければ当プラグインのブラックリストからも外されません。これは仕様です。

  このような場合、spam登録申請をしたあなたに責任があるというよりも
「海外のブラックリストに登録されるような状態にしているサーバ（ネット業者などのメール送信の為のコンピュータ）の管理者が悪い」
と言うスタンスを、当開発チームでは取っています。ですからあなたが責任を感じる必要はありませんし、また当プラグインの開発チームも責任を取る、ないしは行動を起こすつもりはありません。

．．．．とはいうものの、当プラグインのブラックリストに入れたことに関しては、あなたの行動が直接的な原因だった可能性が大きいのは確かなので、非常に気になるかもしれませんが、それは無視して頂くしか仕方ないのです。
  2003年に一時導入をしていた特定アンテナ（β版解説頁参照）と呼ばれるシステムのうち、特定個人をアンテナにする手法は特定個人に届く「メールの全て（spamか否かに拘わらず）」についてspam登録申請するシステムでした。すなわち、あなたがうっかり行ってしまった無関係なメールのspam登録申請ですが、同じことを当システム自体が積極的に行っていたことになります。ですからあなたが後ろめたく思うのならば、上記の特定アンテナを導入した場合に開発チームとしても後ろめたく思わなければならないことになります。

  もしどうしても気になるのならば、登録されてしまったそのIPアドレスのサーバ管理者に「あなたのサーバは海外のブラックリストに入っているようですが、御存じでしょうか？適宜対処なさることをお勧めします」などのメールを送れば良いでしょう。
  その際に当プラグインのことを述べるのはあまり適切ではありません。なぜなら、当プラグインでは対処しようが無く、サーバ管理者は、まずspam発信を許している、もしくは許すような設定にしている自分のサーバの不備を直し、その後で、ブラックリストからの除外に関してはブラックリスト運営者に直接連絡を取る、というのが行われるべきものだからです。

目次　ブラックリスト参照方式絡みへ

Ｑ．「現在の登録IP数」が200000（20万）以上になりません。

Ａ．仕様です。当システムで提供している通常のspamリストは、最新の20万IPを上限としてそれより古いIPは自動的に削除されています。これはそれ以上IPを増やした場合に「Beckyの起動が重い」「操作時に固まる」と言った事が発生してしまう為であり、20万IPという数は開発チームが経験に基づいて決定したものです。これはサーバー側の都合にも関係します。
  なお、プラグインの設定の設定タブにおいて「SmallSize IPBLを使用する」を選択した場合、標準よりも小さい５万IPのリストを使用します。

目次　ブラックリスト参照方式絡みへ

Ｑ．DNSBLに登録されていないIPのメールは、「spam登録」をしても意味がないのでしょうか？

Ａ．ほぼ、意味はありません。ただし、一部DNSBLでは問い合わせがあったことをきっかけに調査を開始する場合があります。従ってspam登録をきっかけにDNSBLに問い合わせをすることで、その後調査が進み、DNSBLに登録されるというケースもあります。
  また現在は「spam登録」はユーザ個々で作成されるベイジアンフィルタの為の「spam学習」と一緒になっており、「spam登録＆学習」という一回の操作で済みますので、「spam登録」にも御協力下さいませ。

目次　ブラックリスト参照方式絡みへ

ベイジアンフィルタ方式絡み(spam学習など)

Ｑ．本当に学習が進んでいるのかどうしたら確認できますか。

Ａ．「プラグインの設定」の「about」タブを御覧下さい。「現在のspamメール学習数」「現在のSpamToken数」が増えていれば学習は行われています。

目次　ベイジアンフィルタ方式絡みへ

Ｑ．ベイジアンフィルタについて詳しく知りたいのですが。

Ａ．すでにいろいろな方々がネット上でもベイジアンフィルタについて書いていらっしゃいますので、適宜googleででもお調べになると良いでしょう。なお、当開発チームでは「スパムフィルタの概要」で紹介しているリンク先などを参照させて頂きました。

目次　ベイジアンフィルタ方式絡みへ

Ｑ．あるパソコンのBkASPilで学習したspamデータを、他のパソコンにあるBkASPilプラグインでも利用したいのです。

Ａ． ベイジアンフィルタ方式により学習したデータは、他のパソコンのBkASPilでも使えるように、エクスポート（抽出）、インポート（取り込み）の操作が出来ます。「高度な設定タブ 2_Bayesianの設定２」を参照して下さい。

目次　ベイジアンフィルタ方式絡みへ

Ｑ．学習トークン数が100万以上になりません。

Ａ．仕様です。トークン数が増えると動作が重くなりますので100万を上限としております。

目次　ベイジアンフィルタ方式絡みへ

Ｑ．ベイジアンフィルタ方式でspam判定されたものはベータ版の時のようにフラグが付く仕様にしてほしいのですが。

Ａ．フラグ機能はBecky標準の機能であり、別途様々な目的に使っている人がいると思われるので、当プラグインで利用するのはあまり望ましくないと考えています。ベータ版で上記のような仕様にしていたのは一時的な仕様のつもりでありましたので、正式に採用する予定はありません。

  しかしながら当プラグインではメールヘッダに判定結果を書き込むようになりましたので、Beckyのフィルタリング機能を使えば上記仕様を再現することも可能です。フィルタリングマネージャで以下のような設定にしてみて下さい。（感謝：Shi-chan氏、Nat氏）

ヘッダ『X-BkASPil-Result』
文字列『spam』が『ある時』
    And
ヘッダ『X-BkASPil-BLIP』
文字列『.』（半角ピリオド）が『ない時』

上記の条件の時、下記の動作をするようにする。

右下の「アクション」欄の内容を
『振り分け』、『フラグを付ける』
にし、さらに
『フラグを付ける』
のチェックボックスにチェック

  具体的な手順は次のようになります。まず下図のように赤い箇所を設定し、「ルールの追加」ボタンを押します。

  これに加えて下図のように赤い箇所を設定し、「条件を追加」-「絞り込み条件として追加」を押します。

  そうするとルールのツリーには以下のようなルールが加わります。

  このようなルールが入っているとブラックリスト参照方式でspamと判定されず、ベイジアンフィルタ方式でspamと判定されたメールにはフラグが付きます。

目次　ベイジアンフィルタ方式絡みへ

spam処置依頼支援機能

Ｑ．ユーザ登録を行ったのに、spam処置依頼メール作成支援機能を使えません。

Ａ．まず、

プラグインの設定－BkASPil設定－高度な設定タブ

の画面で「UserID」に文字列が入っているか御確認ください。（グレーになっていて操作することが出来ないのは正常です。）
  次に動作環境を満たしているかもう一度御確認して下さい。当ツールはIMAPに対応しておりませんので、御理解下さい。

目次　spam処置依頼支援機能へ

Ｑ．旧バージョン（antispamプラグイン）で提供されていたspam処置依頼支援機能を使いたいのですが。

Ａ．spam処置依頼支援機能についてはユーザ登録制度を継続します。ユーザ登録の目的が変わりますので、再度、登録をして頂きます。こちらの方法でユーザ登録を行って下さい。

目次　spam処置依頼支援機能へ

Ｑ．旧バージョン(antispamプラグイン)で提供されていたspamcop利用支援機能を使いたいのですが。

Ａ． こちらの方法でユーザ登録を行って下さい

目次　spam処置依頼支援機能へ

Ｑ．処置依頼支援を使っていたら 『苦情先の指定』などのダイアログボックスなどが見えなくなってしまいました。

  このシステムを使うとき、ダイアログボックス（返答を求める小さなWindow）が見えなくなってしまうことがあります。あるいは処置依頼先の解析結果ページも見えなくなることがあります。それは単に他のWindowページの下に隠れてしまったからです。それを前面に出したいときには、下のタスクバーを見て、それらしきものを探し出しましょう。

●グループ化していない場合：

●グループ化している場合　Becky!の所をクリックするとantispamプラグイン関係のバーが出てきますので、それを選ぶと前面に出てきます。

目次　spam処置依頼支援機能へ

Ｑ．支援機能を利用する際のダイアログが頻繁で鬱陶しいのですが。

Ａ．簡略化できます。こちらを参考にして下さい。

目次　spam処置依頼支援機能へ

Ｑ．メールヘッダを見ている画面で「spamメールを報告する」の動作を行うと、メール本文が引用されずにメールヘッダが二重で引用されます。

Ａ．申し訳ありませんが仕様です。「spamメールを報告する」の動作は本文を閲覧した状態で行って下さい。

目次　spam処置依頼支援機能へ

ユーザ登録

Ｑ．ユーザ登録で、回答中に失敗し、初めからになりましたがメールアドレスを受け付けてくれません。

Ａ．ユーザ登録のクイズに解答中、不適切なページの移動をするとしばらく同じアドレスでの解答を受けつけません。15分待って下さい。

目次　ユーザ登録へ

Ｑ．複数のメールアドレスを所有していますが、登録するのは一つのメールアドレスだけで良いのでしょうか？

Ａ．はい。

目次　ユーザ登録へ

Ｑ．登録されたデータはどのように使われているのでしょうか？

Ａ．各種トラブルに備え、念のためにメールアドレス、ID、パスワードなどを記録していますが、開発チームでは特にそれらを使うことはありません。また正答率は記録していません。開発チームの個人情報取扱指針はこちらを参考にして下さい。

目次　ユーザ登録へ

Ｑ．登録データを削除したいのですが。

Ａ．登録サイトに行き、そこでの指示に従って下さい。そこでの手続きにより、サーバ上にあるユーザ情報は完全に消去されます。なお、開発チームは別途、このデータをバックアップしていることがあります。

目次　ユーザ登録へ

Ｑ．ユーザ登録を一度しましたが、別なパソコンでも登録して処置依頼支援を使いたいです。
Ｑ．再インストールしたために登録が消去されてしまいました。

Ａ．　「再インストールをしたので、もう一度antispamプラグインに登録させたい」「複数のパソコンを使っており、別なパソコンのBeckyでも同じIDで登録したい」、そのような場合は登録時に届いたメールを、そのままの形で自分の上のアドレスに転送します（下図参照）。

新しい環境でそのメールを新たに受信すると、その環境でもIDが登録されます。ですからプラグイン登録完了のメールは大切に取っておきましょう。

  なお、ユーザ登録サイトで再発行の手続きを取ることも可能です。

目次　ユーザ登録へ

Ｑ．登録完了メールを無くしてしまい、再登録できません。

Ａ． ユーザ登録サイトに訪問して登録完了メールの再発行手続きをすることが出来ます。そこでの指示に従って下さい。

Ｑ．登録しているメールアドレスを変更したいのですが。

Ａ．大変恐縮ですが現在のところ、ユーザ登録のメールアドレスを変更するためには、旧アドレスでの登録を削除し、新しいメールアドレスでの新規登録をして頂く方法しかありません。すなわち再度、ユーザ登録クイズに答えて頂かなければなりません。それらはユーザ登録サイトから行って下さい。
  御面倒ですがお願いいたします。

目次　ユーザ登録へ

操作・動作全体

Ｑ．当プラグインを導入しているとたびたび外部にアクセスしているようですが何をしているのですか？

Ａ．当プラグインは、フィルタリング機能にせよ、処置依頼支援の機能にせよ、外部サーバとの密な連携で機能しています。

●起動時

  • バージョンアップファイルの読み込み
  • 「ブラックリスト参照方式」のIPBLの読み込み
      →設定タブで停止可能。

●操作時

  • IPアドレスリストの送信（spam登録時など）
  • メールヘッダーの送信（ヘッダー調査時など）

●平常時

  • 「ブラックリスト参照方式」のIPBLの読み込み
    →設定タブで停止可能。
  • IPアドレスリストの送信
    →「SpamFilter関係の設定」で「Spam登録時にすぐに送信しない（キャッシュする）」にチェックが入っていると実行される。特に「Bayesヒット時にIPをバックグラウンドで送信する」にチェックが入っていると登録操作をしなくてもアクセスが実行される。
目次　操作・動作全体へ

Ｑ．spam登録やspam学習を効率的に行うため、それらの動作のためのショートカットキーの機能をつけて欲しいのですが。

Ａ．まず、「spam登録」と「spam判定訂正」に関してはショートカットキー（ホットキー）の設定が出来るようになりました。
「高度な設定」－「その他の設定」
で行って下さい。

  さらに処置依頼支援機能関係（ヘッダー調査、登録調査、処置依頼送信）もホットキーの設定が可能になっています。
「高度な設定」－「処置依頼関連の設定」
で行って下さい。

  なお、当プラグイン操作を効率的に行うための機能については、マウスジェスチャーも設けています。現在のところは上記以外のショートカット機能の充実は考えておりませんので、まずはマウスジェスチャーの御利用をお願いいたします。

目次　操作・動作全体へ

Ｑ．マウスジェスチャーとはなんですか？

Ａ．マウスジェスチャーとは通常のマウスの機能に加えて、クリック（一回マウスのボタンを押す）やドラッグ（選択してボタンを抑えながら移動する）に特別な意味（命令）を与えるようにすることです。BkASPilでは、操作効率向上のため、この機能を導入しており、「右ボタンドラッグ移動」に各種役割を与えるようにしています。
  設定、使用方法については参考資料「マウスジェスチャーについて」を参照して下さい。

目次　操作・動作全体へ

Ｑ．マウスジェスチャーがうまく動作しません。

Ａ．確認ですが「マウスジェスチャーについて」での設定を行いましたでしょうか？

  改めて以下の点をもう一度御確認下さい。

１．プラグインの設定「設定」タブで「マウスジェスチャーを使う」にチェックが入っているか？
２．ドラッグする方向に「spam登録＆学習」が選択されているか？
３．「メッセージビュー」の上で操作しているか？（他のビューの上では動作しません。）
４．十分な距離をドラッグしているか？（私が初めて使った時にも、引っ張る距離が足りなくて動作せず、チームメンバーにヘルプミーしました　^_^;;）

以上。

目次　操作・動作全体へ

Ｑ．Becky!の起動・動作に時間がかかります。

Ａ．Ver.1.1以降、起動時に遅い仕様は改善しておりますが、それでも遅く感じる場合、以下の方法を検討して下さい。

  • 起動時に遅い原因として、起動時のspamリスト取得が考えられます。「BkASPilプラグインの設定」の「設定」タブで「自動でList取得をする」にチェックをしている場合には、「高度な設定タブ　6_その他の設定」の「起動時にはListを取得しない」にチェックをするか、あるいはそこにチェックしなくても、Shiftキーを押しながらBecky!を起動すると、spamリストを取得しないで起動することが出来ます。これらにより起動が若干速くなる可能性があります。

  • 起動時を含む運用に関し、利用するspamブラックリストに小さいサイズのものを使うことで若干軽くすることが出来ます。プラグインの設定の設定タブにおいて「SmallSize IPBLを使用する」にチェックを入れて下さい。なお、この場合、フィルタリング成功率が下がりますので御注意下さい。

  • 起動時を含む運用に関し、ベイジアンフィルタ方式のspamデータが（パソコンのスペックの比して）大きすぎるという場合もあるようです。「Ｑ．メールの受信に時間がかかります。」と同じく、「spamデータベースの調整」にてデータベースのコンパクト化をお試し下さい。

  • 起動時に関して「高度な設定タブ　6_その他の設定」に「起動時にSpalsh画面を表示しない」という設定がありますが、多分これにチェックをしても時間は早くならないでしょう（汗）。

  • 「高度な設定タブ　1_SpamFilter関係の設定」の「CPU使用率に関係なくDNSBLを更新する」のチェックは外しておくと良いでしょう。
  • spam受信時の動作に関しては「Ｑ．メールの受信に時間がかかります。」を参照して下さい。

  • spam登録時の動作に関しては「Ｑ．spam登録の際に動作が重くなります。」を参照して下さい。

  • 最後の手段として、フィルタリング機能を使わない場合にはその機能を停止させることで動作を軽くすることが出来ます。プラグインの設定の設定タブの「SpamFilter機能を使用しない」にチェックを入れて下さい。

（御意見は当プラグインアンケート「具体的な要望事項」へ）

目次　操作・動作全体へ

Ｑ．しばしばパソコンの動作が停止します（固まります）。
Ｑ．CPU使用率が100％になり、Becky操作に支障が出ます。

  これは仕様です。状況としては「メール取得時」と「spamブラックリスト（IPBL）取得時」に発生すると考えられます。特に後者の場合、Beckyの円滑な使用に支障が出るようです。根本的な解決は出来ませんが、以下のような設定変更で軽減出来る場合があります。

  • 「高度な設定タブ－1_SpamFilter関係の設定」での「CPU使用率に関係なくDNSBLを更新する」のチェックが外れているかをまずは確認。
  • 「高度な設定タブ－1_SpamFilter関係の設定」での「Bayesヒット時にIPをバックグラウンドで送信する」のチェックが外れているかも確認（グレーでも可）。
  • 「高度な設定タブ－6_その他の設定」にて取得タイムアウト時間を短くする（ただしspamリストが最新に更新されにくくなりますのでフィルタリング精度が落ちます）
  • 「設定タブ」の「更新する間隔」を長くし、spamリストの取得頻度を減らす（ただしspamリストが最新にされにくくなるのでフィルタリング精度が落ちます）
  • 「設定タブ」の「SmallSize IPBLを使用する」にチェックをして小さいサイズのspamリストを使用する（フィルタリング精度が落ちます）
目次　操作・動作全体へ

Ｑ．メールの受信に時間がかかります。

Ａ．ベイジアンデータが増えてくると受信動作が重たくなります。

「高度な設定」タブ－Bayesianの設定タブ－「データベースの調整」タブ

にて「コンパクト化」を行って様子を見て下さい。

目次　操作・動作全体へ

Ｑ．複数のパソコンで異なるバージョンのBkASPilを使っているのですがスパム判定の差や動作の挙動が両者で異なります。

Ａ．当ツールでは改訂を頻繁に行う時期があるため、その際に仕様などが変わることが多く、御質問のような違いの原因は突き止めかねます。そもそも最新版以外での動作も保証できません。原則、最新版を利用して下さい。

目次　操作・動作全体へ

Ｑ．「Becky起動時にLISTを取得しない」にチェックを入れているのですが、それが機能せず、毎回起動時にプログレスバーが出ます。

Ａ．当プラグインの起動時に行うことはspamリスト取得だけではありません。ですから上記設定でもプログレスバーが出るのは仕様となります。

  ちなみに
「高度な設定タブ」－「1_SpamFilter関係の設定」
での
(□チェックボックス)SpamFilter機能を使用しない
にチェックを入れていても、プログレスバーが出ることがあります。これも同じです。

  ただしプログレスバーが出ることはともかく、それも含めて起動時間がどれくらいかかるかはお使いのパソコンの仕様（スペックの高さ）に左右されますので御了承下さい。

目次　操作・動作全体へ

Ｑ．「メールヘッダー調査」の機能を使うことが出来ません。

Ａ．「メールヘッダ調査」機能を利用するには「ユーザ登録」が必要です。これは調査結果を正しく理解するには一定の知識が必要で、それを確認させて頂くためです。御理解下さい。

目次　操作・動作全体へ

設定画面

Ｑ．プラグイン設定にあるReportのデータはどこにありますか？

Ａ．プラグインがインストールされているフォルダの中の
「BkASPil20XX.csv」
がレポートグラフ用のデータです。

目次　設定画面へ

Ｑ．設定にあるReportに関して不具合・要望があります。

  以下の要望、不具合については仕様ですので御了解下さい。

  • （SpamMailの数）＞（ReceivedMailの数） の場合、月別(Month History)の場合は正しく表示するが、週間(Week History)の場合は、縦軸(Count)の最大値がReceivedMailの数になっており、SpamMailのグラフが振り切れる。
  • 年が変わると昨年以前のグラフが見ることが出来ない。

  どうしても改善を希望する場合には当プラグインアンケート「具体的な要望事項」での投票をお願いします。

目次　設定画面へ

トラブル一般１　各種不具合

Ｑ．ダウンロードした後の解凍、実行が出来ません。

Ａ．ダウンロードしたデータが完全でなく、ファイルの一部しかダウンロードできていない場合に、解凍・実行でエラーが出る件が報告されています。「ダウンロードページ」に記述してあるプラグインのファイルサイズを確認して頂き、ダウンロードしたデータと容量が一致していることをご確認下さい。もし容量が異なる（足りない）場合、解凍・実行できないのはそれが原因です。その場合には元のファイルを削除して改めてダウンロードするか、別な場所にダウンロードして下さい。

  ダウンロードがしばしば完全でないまま終わる原因については目下不明であり、調査中です。とりあえず完全な容量のものがダウンロードできるまで頑張ってみて下さい。どうしても出来ない場合は開発チームまでご一報下さい。これについて何か原因となるものをご存じの方、開発チームまで御連絡下さると有り難く思います。

目次　トラブル一般１へ

Ｑ．サーバに関するエラーが出ます。

Ａ． 当プラグインは、spamフィルタリング機能にせよspam処置依頼メール作成支援機能にせよ、開発チームで提供しているサーバと密な連携をすることで機能しています。そのため、外部サーバとのやり取りに関して不具合が発生すると、当プラグインの正常動作に大きく影響します。
  サーバに関するエラーが出る場合、原因として主に３つ考えられます。

１．その利用者の環境では外部のサーバを利用することに不具合がある。
２．当開発チームで提供しているサーバが動いていない。
３．外部サーバの場所が変更されており、あなたのBkASPilは古いサーバを参照しようとしている。

１．「その利用者の環境では外部のサーバを利用することに不具合がある」場合

  これについては様々な場合があり、簡単にはアドバイスできません。プロキシーの設定により解決する場合もあります。まずは御利用のネットワークのサーバ管理者に相談なさることをお勧めします。

２．「当開発チームで提供しているサーバが動いていない」場合

  開発チームで提供しているサーバが不具合の場合には、BkASPil公式ページのトップ
http://b2antispam.s33.xrea.com/index.html
もしくはサポート掲示板
http://b2antispam.s33.xrea.com/cgi/cybbs/cyclamen.cgi
で告知したり、話されている可能性が高いです。御確認ください。
  サーバは各種事情により、一定時間停止する場合などがあります。御理解願います。

３．「外部サーバの場所が変更されており、あなたのBkASPilは古いサーバを参照しようとしている」場合

  利用している外部サーバの場所等は状況に応じて変更される為、BkASPilでは日が変わるごとにその問い合わせをどこにするかのデータも外部サーバから取得します。
  よって日付が変わるのをとりあえずお待ち下さい。

  なおお急ぎになる場合は、Beckyを一旦終了し、BkASPilのインストールされているフォルダからBkASPil.iniを削除して再度Beckyを起動すると、最新のデータを取得します。ただしその場合には各種BkASPilの設定は初期化されますので、御注意下さい。
  削除しなくても上記BkASPil.iniファイルを編集できる場合には
SerialVerLimit=XXXXXXXXXXXXXX
の行を削除すれば、次回の起動時に最新のデータを取得できます。

目次　トラブル一般１へ

Ｑ．特定のメールを受信するとBeckyが異常終了します。

Ａ．原因はいろいろ考えられます。とりあえず一旦当プラグインの再インストールを行い、再現するか御確認下さい。。

目次　トラブル一般１へ

Ｑ．他のBeckyプラグインを停止させないとエラーが発生するのですが。

Ａ．おそらく競合が起こっているものと思われます。申し訳ありませんが、当方では他のプラグインとの相性はサポート外とさせて頂いております。
  当プラグインの使用を停止するか、競合するプラグインの使用を停止して対応して下さい。
  なお、どのプラグインと競合したかについての情報は開発の上では参考にさせて頂きます。（競合しないようにする為の対応は保証できません。）

目次　トラブル一般１へ

Ｑ．「高度な設定」の「HTML表示を完全にオフライン表示にする」をオンにすると使用しているブラウザがオフラインモードになってしまうのですが？

Ａ．Becky!のIEブラウザ（メールビュー）はWindowsのIEコンポーネントを使用しています。そのため、Windowsの機能である”オフライン”を行わなければ完全なオフライン状態になりません。BkASPilでのこのオプションはそれを実現させていますが、Windowsハンドルの取得に失敗しまれにオフライン→オンラインの切り替えができない時があるようです。不都合の方がいらっしゃいましたらこのオプションは使わないようにお願いします。
（Becky!の標準仕様である「htmlをテキストに変換」を使ってください）

目次　トラブル一般１へ

Ｑ．「プラグインの設定」を中心として、日本語部分が文字化けしてしまいます。

Ａ．OSの機能である「地域と言語のオプション」の「標準と形式」で「日本語」以外を選択した場合、プラグインの設定等で文字化けが起こることが報告されております。これは仕様です。

  しかしながら英語版Windowsにせよ、日本語版Windowsにせよ、一時的に「地域と言語のオプション」の「標準と形式」を「日本語」にすることで設定が出来、特に問題なく使えるようだ、という報告も受け取っております（ただし開発チームでの確認はしておりません）。御面倒ですが当プラグインの設定の時には一時的にでも上記を変更して対応して下さい。

  2004/03現在、当プラグインの英語版作成の予定はありません。もしどうしても希望する場合には当プラグインアンケート「具体的な要望事項」において、英語版提供に関する投票・投稿をお願いします。

目次　トラブル一般１へ

Ｑ．BkASPilのトップページには「Ver.2.XXXX の提供を開始しました」と書いてありますが、ダウンロードのページには古いバージョンしか置いてありません。

Ａ．おそらく利用者様の環境がProxy（プロキシー）を使用しておられ、ダウンロードのページではキャッシュが読み込まれているものと思われます。各種設定を見直して、最新のページを閲覧して下さい。proxy、キャッシュ等についてはネット上に各種情報があり、またインターネットの基本的な事項ですので、各自解決して頂きますようお願いします。

目次　トラブル一般１へ

Ｑ．メール受信時に動作が停止し、進みません。

Ａ．メール受信時に受信動作が進まなくなる現象が報告されています。そのようになるとベッキーを強制終了しないとその状態から抜けられません。

  この現象はメール容量が大きい場合に発生することがあるようです。このような場合、そのメールの発信者のメールアドレスなどをホワイトリストに登録してみて下さい。なお、この現象については改善を予定しています。

目次　トラブル一般１へ

トラブル一般２　解決しないとき

Ｑ．おかしくなったので、とにかく元に戻したいのですが。

Ａ． プラグインの完全削除を行って下さい。それで直るはずです。それで直らなければ当プラグイン以外に原因があると思われますので、適宜対処して下さい。

  Pluginフォルダは２カ所の可能性がありますので、御注意下さい。これについては「メールボックスとPlugInフォルダの位置」を参照して下さい。

目次　トラブル一般２へ

Ｑ．エラー、異常終了、不具合などが出るのですが、確認事項はありますか？

Ａ．当プラグインをインストールして、もしエラーなどが出るようになった場合、以下の手順で問題点を探して下さい。

【Ａ．注意点】

  • 動作環境を参照し、お使いの環境に合っているか御確認ください。
  • 最新版のBecky!にしていますか？
  • 旧バージョン（antispamプラグイン）をアンインストールしましたか？

【Ｂ．取りあえずプラグインを再インストールして見る】
  なにはともあれ、プラグインの完全な再インストールを行ってみて下さい。その方法については「Ｑ．プラグインの完全な再インストールをしたいのですが」の回答を参照して下さい。

【Ｃ．原因がBkASPilであることを確認】
（以下、基本解説「不具合が発生したら」も参照のこと）
１．「ツール」－「全般的な設定」の「高度」タブ
で「プラグイン」ボタンを押す。
２．BkASPilのチェックを外す
  異常が出るか？
  ↓└→出ない→【Ｄ．他のプラグインとの関係】へ
  異常が出た。
３．「Pluginフォルダ」のBkASPil関係のファイルを削除（基本解説「プラグインの完全削除」を参照のこと）
  異常が出た。
    ↓
  原因は当プラグインではないと思われます。

【Ｄ．他のプラグインとの関係】
  前述のプラグインのチェックで、BkASPilのみチェックし、それ 以外のチェックを外し、Beckyを再起動。
    ↓└→出ない→他のプラグインを一つずつチェックをつけていく→共存して問題となるプラグインを特定
    異常が出た。

【Ｅ．機能を減らしてみる】
１．「マウスジェスチャー」の機能を外してみる（参考解説「マウスジェスチャーについて」を参照）
２．「定期的にListを取得する」のチェックを外してみる（画面解説「設定」タブを参照）

【Ｆ．他のソフトとの関係】
  出来るだけ他のソフトを終了してみる

【Ｇ．開発チームに連絡】
 プラグインの設定－「高度な設定」タブ　6_その他の設定
で「動作ログを取る」にチェックをして、おかしい動作を再現させて下さい。それが再現した時点で速やかに「開発チームにLOGを送付」ボタンを押し、ログファイルが添付されたメールを開発チームまで送って下さるよう、お願いいたします。

目次　トラブル一般２へ

Ｑ．プラグインを完全削除しようと思いますが、プラグインフォルダの中にBkASPilのファイルがありません。

Ａ．プラグインのファイルがある場所は２通りの可能性があります。両者からファイルが削除されていることを御確認下さい。これについては参考解説「プラグインフォルダの位置」を参照して下さい。

目次　トラブル一般２へ

Ｑ．トラブルに関して開発チームに連絡をとる場合に注意することはありますか？

Ａ．まずは御自分で極力自己解決を図って下さい。

１．この質問集、あるいは解説書（オンライン版）をお読みになり、解決するアドバイスやヒントがないか、御確認ください。

２． サポートBBSにも目を通して下さい。あるいはその検索機能なども御利用下さい。

３．「Ｑ．エラー、異常終了などが出るのですが、確認事項はありますか？」を御覧になり、そのアドバイスの内容をまずは実行して下さい。

４．まずはサポートBBSを御利用下さい。開発チームに限らず、アドバイスを下さるかたが出る場合もあります。また、同じトラブルにあっている人が情報提供してくれる場合もあり、開発チームとしてはそれが助かります。

５． サポートBBSにせよ、メールでの連絡にせよ、以下のような内容を書いて下さい。

ａ．起こる出来事の概略。以前に問題なかった時期はあるのかなど、いつ頃から発生したかも明記して下さい。

ｂ．それに対してユーザ様が行って下さったこと。具体的には３番で紹介しているようなＡからＦのアドバイスについて、当プラグインの再インストールなどを中心にどの程度試してみたか、それでも発生するのか、何か変化が出たのかを明記して下さい。

ｃ．お使いの環境について、トラブルと関係ありそうなことがありましたら明記して下さい。

ｄ．画面解説「高度な設定タブ」　6_その他の設定
で、「動作ログをとる」にチェックをし、不具合が発生したらその時点ですぐに「開発チーム宛にログを送付する」のボタンを押すと、動作ログがファイルとして添付したメールが作成されます。これにａ～ｃのようなことをお書き添えの上、チームに送って下さい。

  動作ログだけでトラブル内容を何も明記していない場合には、対処のしようがなく無視しますので御注意下さい。

ｅ．そのメールに対し、開発チームとしましてはまもなく御返事を出させて頂くこともあれば、返事を出すことなく、次回バージョンアップなどで対応する場合もあります。あるいは報告内容が不十分な時には無視してしまう場合も多いです。
  しかしながら、頂いたメールは半年や一年のスパンで見直すこともあります。よって丁寧な内容のトラブル報告につきましては、すぐには対応できなくても半年～年のスパンで検討を開始する場合もありますので、気長に待って頂ければ有り難く思います。

  なお、開発チームはあくまでボランティアの個人の集まりで成り立っています。単純な人間ですので、誉められたり感謝されたりすると素直に喜び、開発意欲が増す場合があります。逆に、ボランティアであることを考慮して頂けず、一般の商品のサポート同様の対処を要求されたりすると、つむじを曲げる場合もあります。チームへの文面には御注意下さい。ただしメールの返事や掲示板投稿のレスがなくても、それがチームメンバーがつむじを曲げたからだとは全く限りませんので御理解願います。

目次　トラブル一般２へ
Ｑ．開発チームにメールを送ったのですが返事が来ません。あるいはサポート掲示板に投稿したのですがレスがつきません。

  開発チームは2004年３月現在、３人で構成されており、連絡先メールアドレスに送った場合には各メンバーに配信され、各々出来る範囲でサポートしております。しかしながら（フリーソフト制作者ではありがちだと思いますが）当開発チームは気まぐれな部分がありますので、ユーザの皆様の要望や質問に十分にお答えできない場合がしばしばあります。

  比較的答えやすい質問には回答することが多いですが、返答をしそこねる場合もしばしば発生しております。特に以下のような場合には返事をし損ねることが多いようですので、御了解下さい。

  • マニュアルに載っているレベルの質問の場合
  • 質問よりも要望の性質が強い場合（この場合には極力「当プラグインアンケート「具体的な要望事項」にも投稿・投票して下さい）
  • 不具合報告の場合には、不具合状況・利用者の環境・利用者の取った手順などが、頂いた情報では十分ではないとき
  • ユーザ環境がかなり特殊である場合
  • すでに報告が多数上がっている場合
  • 近々、改訂により改善の見込みのある場合
  • 当チームがボランティアで開発していることを考慮して頂けない雰囲気の場合（滅多にありません）

  また、不具合報告やそれについての質問の場合には回答「不具合が出た場合」を参照し、回答「完全な再インストール」を中心とした対処をお取りになり、それによって不具合が改善されないかを確認し、その旨（どのような対処を取ったのか）を明記した上で不具合報告、質問を行って下さい。

  返事が来なかったり、レスがされない場合にはもう一度上のことを御確認下さり、必要であれば再度、御連絡、あるいは掲示板でしたら投稿に催促のレスをつけてください。それでも御意向に添えない場合もあると思いますけれども、開発チームとしてはきちんとチェックしており、後々に反映させる場合もありますので、御理解頂きますようお願い申し上げます。

目次　トラブル一般２へ

その他

Ｑ．自分の会社の事務効率化のため、becky!のPlug-inの外注開発を依頼したいのですが。

Ａ．当開発チームはspam対策用のpluginを開発するためだけに集まったメンバーであり、他の目的のpluginに関しては扱いかねます。

  また、チームメンバーのうち、plugin開発の技術を持つBNR32は
http://homepage1.nifty.com/redwing/
の左「software」で紹介しておりますようなオンラインソフトを作っておりますが、開発の請負はしておらず、更には現在多忙なこともあり、受け付けかねます。

  なお、もし御希望のプラグインが少しは汎用性のあるもの（一般にも使う人が多そうなもの）である場合にはBecky!のプラグインについて話すネットワークコミュニケーションの場所で「こんなプラグインが欲しい」と叫んで細かい仕様を提示すれば、誰か作ってくれる人が出るかもしれません。

目次　その他へ

Ｑ．spam対策としてメール発信者に偽装エラーメールを送る機能はないのでしょうか？

Ａ．　spamの多くが差出人を詐称するので、「発信者（のように見える者）」に対してエラーメールを送ることは第三者に迷惑をかける危険性が多大にあります。よってそのような実状を鑑み、上述の機能は当ツールから除去されました。
  もし他のツールで同様なことを試みられる場合には以下のサイトなどで各種の危険性を熟知した上で行って下さい。

参考：
「迷惑メール撲滅私的調査会」の「間違い１：スパムの差出人アドレスを正しいものだと思いこむ」
  http://antispam.stakasaki.net/huangtang-chuli.html#01

「Fight spam on the Net!」の「"From:"に返信する自称『spam対策ツール』」
  http://ssss.jp/~trombik/email/aho.html

目次　その他へ

Ｑ．解説書（ヘルプ）の画面が青色の時と緑色の時があるのですがどう違うのですか。

  当プラグインの解説書には３種類あります。それについては「この解説書(ヘルプ)の構成と注意点」に書いておりますが、オフライン（ネット接続していない状況）で見ることが出来る正式版・簡略版は青色、ネット接続の状況で見ることの出来るオンライン版が緑色の色調で作られています。
  正式版、簡略版の全てのページの下からはオンライン版の各ページにリンクが張ってあり、簡略版・正式版で閲覧しているページを直ちにオンライン版のページに替えることが出来ます。しかしオンラインの画面を見ているのか、オフラインの画面を見ているのか判別しにくいので、オンライン版は緑色にしてあります。

目次　その他へ

Ｑ．このプラグイン「BkASPil」はなんと呼べば良いのですか？

Ａ．私（高崎）もよく分かりません（汗）。（高崎自身は）「名前などは些細なこと」と思っていたら、ユーザＭＬでも、開発チーム内でも意見をまとめ損なってしまいました。「名前はねえ　大切なんだよ」ってのを思いっきり無視しました。ごめんなさい。
  取りあえず「BkASPil」とつけたBNR32氏は「アスピリン」と呼びたかったようですが、「日本語にせよ英語にせよ、既成の言葉と極力同じにしないように」ということで却下されました。
  私・高崎は取りあえず「ビーケーアスピル」と呼んでいます。

目次　その他へ

Ｑ．「設定」のaboutタブでのサイトが「http://b2antispam.s33.xrea.com/」になっていません。
Ｑ．当プラグインのメインサイトはどこなのですか。

Ａ．「aboutタブ」でのURLが
http://b2antispam.s33.xrea.com/
になっていないのは、当プラグインの発起人であり、プラグインプログラムの制作者であるBNR32氏の判断です。これは仕様です。
  しかしながら当プラグインの正式な紹介サイトURLは
http://b2antispam.s33.xrea.com/
となっておりますので御了解願います。

目次　その他へ

Ｑ．このプラグインの為に私が何か手伝えることはありますか？

  • 当システムの根幹であるspam登録に御協力下さい。
  • フィルタリング率の報告に御協力下さい。
  • spamが多く届き、またもはやspamしか届かないメールアドレスを持っている場合、囮アンテナとしての提供に御協力下さい（→参照：オンライン解説「囮アンテナについて」）

  当チームはメンバー的にも、利用環境（サーバ等）に関してもかなりぎりぎりの所で運用しております。もし当システムの存在意義を重視してくださり、何かリソースを提供できる場合には協力して頂けると有り難いです。なお、それに関する募集はホームページ上などで随時行わせて頂きます。

目次　その他へ

Ｑ．このツールを使って私の情報が漏洩する可能性はありますか？開発チームの人はどのように私の情報を用いるのでしょうか？

Ａ．当チームは当システムにより得られる個人情報の保護に極力努力するつもりです。ただし100％事故が発生しないことを保証するものではありません。個人情報取扱指針を参考にして下さい。

目次　その他へ

Ｑ．開発チームに連絡が取りたいです。

Ａ．関連サイトに記したメールアドレスから連絡をお願いします。

目次　その他へ


用語解説

  以下の解説は当プラグインを使う人々向けに書かれた用語集です。この用語集の目的は当プラグインの解説書を読む方々が最低限、意味を把握できるようにするものです。その為、厳密に正しい意味の解説になっているとは限らず、むしろ「分かりやすい」ことを目指しています。知識の十二分にある方は納得できない点もあるかもしれませんが上記のような目的であることを御理解下さいますよう、お願いいたします。
  なお、

  • 上記のような目的であることを考慮しても解説があまりに間違いすぎる
  • トラブルを生む誤解を与える可能性がある
  • ネット初心者、メール初心者に十分に分かりやすく、同時に一層正確である記述の仕方がある

とお考えになる場合には開発チームまで御連絡下さると有り難く思います。参考にさせて頂きます。

［独自］　当プラグイン制作にあたり、ほぼ独自に作成した用語。他では通じない可能性が高いので御注意下さい。
［専門］　当プラグインで独自に作った用語ではないものの、spam問題が深く論じられる時くらいしか出てこない「spamに関してかなり専門的」な用語。
［一般］　一般的なインターネット、コンピュータ用語。

[インターネットの用語]
  「IPアドレス」
  「サーバー」（「サーバ」）
  「サーバ管理者」（「サーバー管理者」「ネットワーク管理者」）
  「差出人メールアドレス」（「差出人アドレス」「Fromアドレス」）
  「テンプレート」
  「ドメイン名」（「ドメイン」）
  「ネット業者」（「インターネット業者」）
  「NIC」（「ネットワークインフォメーションセンター」「ニック」「nic」）
  「Whois」
  「メールヘッダ」（「メールヘッダ」「ヘッダー」「ヘッダ」）
［スパムメールに関する用語］
  「SpamCop」
  「スパムメール」（「spamメール」「spam」「一方的迷惑広告メール」「迷惑メール」）
  「スパムメール規制２法」（「迷惑メール規制２法」）
  「スパムメール発信者」（「スパマー」「spammer」）
  「特定電子メール適正化法」「特定商取引法」
  「（財）日本データ通信協会」「（財）日本産業協会」
  「未承諾広告※」
［フィルタリング機能に関係する用語］
  「冤罪」
  「学習データベース」
  「囮アンテナ」
  「clean学習」
  「自動学習」
  「spam学習」
  「spam登録」
  「spam登録・学習」
  「（spam）ブラックリスト」（「IPBL」「ＢＬ」「spamリスト」）
  「spamレポート」
  「DNSBL」
  「特定アンテナ」
  「特定個人アンテナ」
   「フィルタリングマネージャ」
  「ブラックリスト参照方式」
  「振り分け」「フィルタリング」
   「ベイジアンフィルタ（Bayesian Filtering）」
   「ベイジアンフィルタ方式」
  「ホワイトリスト」
［当プラグイン処置依頼作成支援機能に関係する用語］
  「abuse窓口」
  「上策、中策、下策の苦情先」
  「spam処置依頼」（「対処依頼」「処置依頼」「spam報告」「spam苦情」）
  「メールヘッダ解析」
  「ユーザ登録」
［その他の用語］
  「antispamプラグイン」
  「完全削除」
  「HT（Hyper-Threading）」
  「プラグイン」
  「β版」（べーたばん）
  「マウスジェスチャー」
  「メールアカウント」
  「メールボックス」

［インターネットの用語］

「サーバー」（「サーバ」）［一般］

  ISP（プロバイダ）やホスティング業者などが使っているコンピュータ。ホームページの設置、メールの送受信など、インターネットにおいて重要な役割を果たす。24時間体制で受けつけなければならないので、普通は常時電源が入ったまま。
  あなたが自分に届いているメールを見る際、プロバイダー等に接続すると思うが、サーバと呼ばれるコンピュータは、あなたが自宅のコンピュータにメールデータを引き取ってくれるまで保管してくれる役割も果たしている。すなわちあなたのコンピュータにメールが来る前にメールが保管されている「メールボックス」のある所。
  郵便で言えば自分の家の郵便受と最寄りの郵便局の合体みたいなものか。

「サーバ管理者」（「サーバー管理者」「ネットワーク管理者」）［一般］

  サーバを管理する人。この解説書ではサーバ管理者とネットワーク管理者をほとんど同義に使っているが、「ネットワーク管理者」とはサーバもしくはその集まりがネットワークで結ばれている場合にそのネットワーク全体を管理する人のこと。ネットワークがインターネットと繋がっている場合には対外的な責任者となり、その連絡先は各国のNICに届けられている。ネットワークの責任者である「運用責任者」と各種技術絡みの設定等を行う「技術連絡担当者」がいる。前者は必ずしもコンピュータに詳しいとは限らないし、それが仕事とも限らないみたいなので、spam処置依頼はなるべく後者の人に送る。
  スパムへの対処で苦情先が良く分からない場合、spam送信サーバのこの方達に苦情を送る。これらの人々は少なくともNICに登録されているので送信サーバの管理者が分からないことは、ほぼ無いからであり、またそういう苦情を受けるのがこの人々の責務であるからだ。
  spam被害者にとって最悪なサーバ管理者とは言うまでもなくサーバを管理する人がスパマー自身の場合である。だがこの場合でも大概は上流のネット業者が存在し、苦情先は存在する。次に困るのはサーバ管理者がspam問題に知識のない人だが、これに関してはほとんどいなくなりつつある。
  比較的多いのはスパムへのポリシーがよく分からないサーバ管理者であるが、この場合、「サーバ管理者」というよりも「ネット業者の一担当者＝ネット業者の一社員」という場合がほとんどである。

「差出人メールアドレス」（「差出人アドレス」「Fromアドレス」）［独自］

  一般の日本語メールソフトで「差出人」として表示されるメールアドレスのこと。メールヘッダでは「From:」を冒頭とするメールアドレスであることから「Fromメールアドレス」とも呼ぶ。メールヘッダのFromメールアドレスは詐称が容易に出来るので決して安易に信頼してはならない。

「テンプレート」［一般］

  同じような文章を書く際に利用される定型化された文章のこと。Outlook Expressでは「雛型（ひながた）」と呼ばれている。
  当プラグインの「spam処置依頼支援」の特徴は、苦情先検索ツールと連携していることもさることながら、選択されたメールのヘッダと本文を含むメールを作成できる、言い換えれば「任意の文＋spamのヘッダ＋spamの本文」というテンプレートのメールを速やかに作成できることであると言える。
  なお、Becky!などの高機能なメールソフトでは返信メールを書く際に、元のメールのタイトルや差出人、発信日などを返信メールの中に自動的に配置することができ、その際に雛形のその部分に書き入れておく文字はマクロシンボルと言われる。たとえばテンプレートの本文中に\aなどを記入しておけば、メール某にそのテンプレートで返信しようとすると、\aの所にはメール某の差出人アドレスが書き込まれる。
  テンプレートについて詳しくはBecky!のヘルプを参照のこと。

「ドメイン名」（「ドメイン」）

IPアドレスの代わりに人間が理解しやすいように表現されているネット上の住所を表す文字列。すなわち「biglobe.ne.jp」「nifty.com」のように英数字と「．」（ピリオド）の組み合わせから成り立つ。「．」（ピリオド）で区切られた文字は後ろから順に「トップレベルドメイン」「第ニレベルドメイン」．．．と呼んだりする。トップレベルドメインには「jp」（日本）、「kr」、（韓国）、「cn」（中国）などのように国別のものの他、「com」「net」などがある。
  住所のようなものだと述べたが、実際には人名に近いと言えるかもしれない。
→参考：参考資料「ドメインとIPアドレス」

「メールヘッダ」（「メールヘッダ」「ヘッダー」「ヘッダ」）［一般］

  通常、メールを見ると本文と送信者・宛先・件名・日時のみが表示される。けれども実は別なところを見ると、そのメールが送られてきた経路などが記録されている部分があり、前述の送信者・宛先などはそれに基づいて表示される。
  spam送信の場合、送信者アドレスは信用できないので、その追求にはメールヘッダを利用することになる。いわば受信者が犯人を追及するかなり唯一の手がかり。携帯電話のメールでは当初、メールヘッダを見ることは一部のキャリア以外不可能であったが、迷惑メール対策の為にヘッダの閲覧が可能になりつつある。
  メールソフトBecky上でのメールヘッダ閲覧の方法は、Beckyのヘルプのキーワード「ヘッダ」の項目を参照して頂きたい。

「ネット業者」（「インターネット業者」）［独自］

  インターネットに関係する業者には様々なものがある。代表的なものには以下のようなものがある。

  • ISP（インターネットサービスプロバイダー）・・・インターネット接続仲介業者。通常「プロバイダー」と呼ばれ、一般的なエンドユーザが企業や大学を通さず、インターネットに接続する為の役割を果たす。もっともシンプルな接続形態は、電話と同レベルのアナログ回線を利用してパソコンをプロバイダーのアクセスポイントと呼ばれるサーバに接続し、そこを通じてインターネットに繋げる方法である。
      プロバイダーは接続業だけでなく、ホームページ領域提供サービスやメールアドレスサービス（メールアカウント提供サービス）なども兼ねることが一般的になっている。

  • ホスティング業者・・・ネット上に繋がれたサーバもしくはホームページスペースなどを貸し与える業者。ネット接続手段を既に持つユーザに対し、接続すること以上のサービスを提供する業者であり、サービス内容や規模には様々なものがある。一般にISPほどの設備投資、設備維持費を必要としないために、零細な業者もとても多いようである。

  • 無料ホームページ、メールアドレスサービス・・・広告収入を中心に一般ユーザには無料でホームページやメールアドレス（メールアカウント）を貸与する業者。代表的なものとしてはマイクロソフトが母体のHotmail、WWWインデックスサービスとして有名なYahoo!が提供しているものなどがある。

  いずれの場合もspam発信者に利用（悪用）されることがある。メール発信での利用がもっとも基本的な悪用のされ方だが、その場合でも必ずしもメールアカウント提供サービスのみが利用されるとは限らない。CGIなどのプログラムを設置できるホームページスペースサービスの場合に、そのスペースにメール発信プログラムを置き、そのプログラムでspam行為が行われることもあるのだ。あるいはISPからは接続サービスだけ受け、サーバは自分のところで用意し（いわゆる「自前サーバ」）、spam発信や宣伝サイトの設置は全て自分のサーバで行う場合もある。
  ホームページスペースはspam宣伝サイトを置く場所として利用されるのは言うまでもないが、特にspammerが利用しがちなのが転送メールアドレスや転送URLシステムである。これらのサービスは無論、真っ当なユーザに使われれば大変便利で皆の役に立つものである。だがサービス提供者が少しでも油断するとspam発信者のような悪意ある者によって徹底的に利用されてしまう。
  各種サービスがspam発信者に利用された際、そのことに対してどのようなアクションを取るかは様々であるが「spam行為者への厳しい対処」と「悪用されにくいような形に変えたサービス提供」が基本になっていると言えよう。

「NIC」（「ネットワークインフォメーションセンター」「ニック」「nic」）［一般］

  IPアドレス、ドメイン名などを割り当てる、民間の非営利機関。
  spamの苦情は基本的にサーバ管理者に処置依頼をすることが基本だが、受け取ったspamがどこのサーバが関係しているか、要は苦情先を調べる必要があるため、これらに関するデータベースを持つＮＩＣに間接的・直接的にお世話になる必要がある。
  各国にはそれぞれNICがあり、日本の場合はＪＰＮＩＣ（ジェーピーニック）。
  世界レベルでは３地域（アメリカ大陸中心ARIN、ヨーロッパ大陸中心RIPE、太平洋中心APNIC）に統括機関があり、各国NICはどこかの下にデータベースを提供している。歴史的経緯もあるようで、正確な記述ではないが詳細については割愛。
  私の頁で紹介している検索頁では、このＮＩＣのデータベースを総合的に調べるホームページを用いている。本来、３地域別統合機関のデータベースを調べるのが確実、もっといえば各国別のＮＩＣを調べるのがもっとも確実だが、数字の羅列のＩＰアドレスからいきなりそれをするのは困難なので、統合的なサービス頁が作られて、それを利用するのが便利。

「IPアドレス」［一般］

  ネット上の住所のようなもの。現在の標準規格IPv4では「123.234.245.12」など、０～255範囲内の数字が４つ並び、各数字の間がピリオドで区切られている文字列（数字４つの組み合わせ）で表される。
→参考：参考資料「ドメインとIPアドレス」

「Whois」［一般］

  IPアドレスもしくはドメインの管理者を登録してあるデータベースのこと。

［スパムメールに関する用語］

「スパムメール」（「spamメール」「spam」「一方的迷惑広告メール」「迷惑メール」）［一般］

  当プラグインでの「迷惑メール」「スパムメール」とはおおむね以下のようなものを指すこととする。

「受信者の承諾なしに一方的に送りつけられる宣伝・広告を目的とする電子メール。受信者のうちのごく一部からでも反応が出ることを期待し、大部分の受信者が受ける迷惑性を徹底的に無視しながら、不特定多数に対して大量・広範囲に配信される傾向を強く持つ。宣伝・広告とは言えないものの、酷似した手法で行われることの多い詐欺を目的とした大量配信メールもこの定義内容に含まれる。」

  以下、「迷惑メール」「スパムメール」の用語問題について述べておく。
  日本では携帯電話の電子メールが社会問題化した2001年以降、マスコミを中心に「スパムメール」を「迷惑メール」と呼ぶようになったが、2003年現在でも、この言葉の正確な定義が社会に十分浸透しているとは言い難い。特に一般のメールユーザは自分にとって迷惑なメールならば安易に「迷惑メール」と呼んでしまう傾向が続いており、ウイルスメール、嫌がらせメールは無論のこと、日本では嫌われがちなHTML形式のメール、マナー違反のメールまで「迷惑メール」と言ってしまう。
  「迷惑メール」の語が広まる以前から、スパム問題に関心を持つ者の中にはそのメールの性質を正確に表現するため「一方的迷惑広告メール」などと呼ぶ者もいたが十分に浸透しなかった。社会問題化して法律論議が始まると、この問題の関係官庁である経済産業省は「電子メールによる一方的な商業広告の送りつけ問題」という言葉を使用したりしているが、「迷惑メール」に替わる用語を定着させようとした様子は見られない。（参考用語：「迷惑メール規制２法」）
  そもそも舶来の「spam mail」の語自体が俗語から出発しており、一番有力な語源はホーメルフーズ社の固有商品名「SPAM」であるとされている。もともと何の意味も持たなかった「spam mail」という語は日本語の「迷惑メール」よりも一層曖昧さを持っていたと言って良く、それに替わる正式名称としてUCE(Unsolicited Ccommercial E-mail )、UBE(Unsolicited Bulk E-mail)などの言葉も作られた。だが米国ではすっかりspamの用語が定着し、法律論議の中で堂々と使用されることも珍しくないようだ。ホーメルフーズ社は自社の製品名が上記の意味で使われることは諦めてしまったようで、そのかわりに「一方的迷惑メール」の意味で使う場合には小文字「spam」で表現する旨を主張している。

  当解説でのこの言葉の利用法について述べる。この問題をよく知らない人々に向けて「迷惑メール」という言葉を使った場合、その性質が深く論じられることのないまま、単に「迷惑なメール」の意味に受け取られる可能性があり、「広告」とか「宣伝」とか「大量配信」などの「spamの基本的性質」すら持たないメールに関して議論がされてしまう危険性がある。
  その一方で「spam」「スパムメール」という言葉は定義が厳密ではないものの、「新語」であることから議論をする際には必ず定義問題に触れざるを得ないと思われる。曖昧な日本語の「迷惑メール」の語を使って不十分な認識のまま議論が行われるよりは、新語「スパム」を使うことでその定義問題を考える機会を生み出す方が弊害が少ないと判断し、当プラグインおよび当解説では「spam」「スパムメール」の言葉を使うようにしている。

「スパムメール規制２法」（「迷惑メール規制２法」）［独自］［専門］
「特定電子メール適正化法」「特定商取引法」［一般］

  2001年、日本では携帯電話の電子メール機能を利用したスパムメール問題が深刻化、社会問題化した。それをきっかけにその年度の後半に迷惑メールに対する規制の法整備の議論が活発化し、2002年４月に上記２法として結実した。2002年７月より施行。詳しくは手順解説「官庁への連絡・報告について」を参照のこと。

「スパムメール発信者」（「スパマー」「spammer」）［一般］

  スパムを発信する者、あるいは発信した者達のこと。

「（財）日本データ通信協会」「（財）日本産業協会」［専門］

  スパムメール規制２法で、関係官庁から情報収集の役割等を与えられた特殊法人。違法なスパムに関する情報を収集し、それらに基づき、関係官庁が対処を行うとされている。詳しくは「官庁への連絡・報告について」を参照。

「送信者」「広告主」「事業主」 （spam報告先として関係してくるので 法律の中でここら辺に関して知っておく必要アリ）

「未承諾広告※」（「！広告！」）［一般］

  スパムメール規制２法で、一方的に送りつけられるメールに関して、タイトル冒頭への付記が義務づけられた言葉。2002年２月～７月までは「特定商取引法」の規則で「！広告！」であったが、その後の法整備で変更された。

「SpamCop」［専門］

  外国のspam自動報告・フィルタリングシステム。詳しくは「SpamCopとは」を参照のこと。

［フィルタリング機能に関係する用語］

「ブラックリスト参照方式」［独自］

  当プラグインで用いている２つのフィルタリング方式のうちの一つ。ユーザ間でspamに関する情報（ブラックリスト）を共有化することで、spam判定を行う。具体的に共有化するのは当プラグインの場合、IPアドレスである（余談だが前身であるantispamプラグインではメールアドレスを共有化情報としていた）。
  詳しくは当ヘルプの「スパムフィルタの概要」、松永香澄解説「spamフィルタの仕組み」（オンライン解説）などを参照のこと。

「ベイジアンフィルタ方式」［専門］

  当プラグインで用いている２つのフィルタリング方式のうちの一つ。すなわちベイジアンフィルタを用いた方法。ベイジアン学習により、スパムの内容を分析し、その結果を新たなメールの判定に用いる。
  詳しくは当ヘルプの「スパムフィルタの概要」などを参照のこと。

「自動学習」［独自］

  当プラグインではブラックリスト参照方式によりspamと判定されたメールは「spam」と確定してベイジアンフィルタ方式の為の学習に利用するが、これを「自動学習」と呼ぶ。
  詳しくは当ヘルプの「スパムフィルタの概要」などを参照のこと。

「spam登録」［独自］

  最新の「ブラックリスト」でフィルタリング出来なかった場合に、ユーザがそのスパムメールの情報（具体的にはIPアドレス）をシステムに提供し、その情報をブラックリストに加えること。それによってその後、同じ（spamアドレス発信の）spamを検知できるようになる。
  ただし当システムでは「登録＝ブラックリストへの追加」ではなく、実際にブラックリストに加えるかはDNSBLに登録してあるかどうかから判断するので、ユーザが出来るのは正確に言えば「spam登録申請」だと言える。→参考：松永香澄解説「spamフィルタの仕組み」（オンライン解説）
  具体的な手順は手順解説「spam登録・学習を行う」を参照のこと。

「spam登録・学習」［独自］

  当ツールでは「ブラックリスト参照方式」におけるspam登録と「ベイジアンフィルタ方式」におけるspam学習を手動で同時に行うことが出来るようになっている。その両者を併せてこのように呼ぶ。
  具体的な手順は手順解説「spam登録・学習を行う」を参照のこと。

「spam学習」［独自］

  spam判定を行うためにspamメールからデータを抽出すること。当プラグインでは「ベイズ理論」に基づきspamデータベースを構築していくことを指す。
  なお、spamデータベースは実際には「spamらしさ」と「真っ当なメールらしさ」に関する二つのデータベースから成っており、メールは両者を使って判定される。それぞれのデータベースを構築する学習を前者は「spam学習」後者を「clean学習」と呼んでおり、当プラグインでは「spam学習」という言葉をそのような狭い意味で使う場合もある。

ベイジアンフィルタ方式の為の行為 | spam学習 | spam学習 | 「spamらしさ」のデータベース構築
 |  | clean学習 | 「真っ当なメールらしさ」のデータベース構築
ブラックリスト参照方式の為の行為 | spam登録 |  | ユーザー間共有データベースの構築

  詳しくは当ヘルプの「スパムフィルタの概要」などを参照のこと。

「clean学習」［独自］

  spamデータベースは実際には「spamらしさ」と「真っ当なメールらしさ」に関する二つのデータベースから成っている。メールのspam判定は両者を使って為されるが、「真っ当なメールらしさ」のデータベースを構築するためのデータ構築を「clean学習」とこのプラグインでは呼んでいる。
  詳しくは当ヘルプの「スパムフィルタの概要」などを参照のこと。

「学習データベース」［独自］

  当プラグインのspam学習、clean学習で学習されたデータベースのこと。

「フィルタリングマネージャ」［独自］［専門］

  フィルタリング機能を使うためのBecky!InternetMail標準のツール。Windows標準のメーラーOutlookExpressでの「メッセージルール」に該当するが、その機能よりも遙かに柔軟で使い易く、そこもBecky!InternetMailの魅力の大きな一つになっている。
  2005年２月のVer2.20より、重要な改善がされ、spamフィルタリングツールとしても利用しやすくなった。
参考：「フィルタリングマネージャのルール別『タイミング』設定の活用について」

「spamレポート」［独自］

  当プラグインで全メール受信数とフィルタリングを行ったものの統計を自動で取っている機能。画面解説「プラグインの設定 Reportタブ」参照。

「DNSBL」［専門］［独自］

  メールサーバにおいて、DNS（ドメインネームサーバ）レベルでのフィルタリングを行うブラックリストシステムのこと。DNS（ドメインネームサーバ）とはIPアドレスとドメイン名の対応付けを行うシステムの総称であるが、その対応付けの際にブラックリストを参照し、問題のあるサーバからの要求を受け付けないようにする、というものがDNSBLの根本的発想である。

  DNSBLの考えが広まったのは、ORBS(Open Relay Behaviour-modification System)というブラックリストシステムがアラン・ホジソン(Alan・Hodgson)氏によりボランティアで設営され、多くのサーバ管理者に任意で利用されるようになったのがきっかけのようだ。ORBSはオープンリレーと呼ばれるspam発信を助長するセキュリティの甘いサーバをブラックリスト化したもので、spamへの強い問題意識を背景として作られた。

  spam問題は当初、エンドユーザよりもサーバ管理者にとって、より一層深刻なものであった。すなわち、勤勉なサーバ管理者にとっては自分の管理するサーバへのspamメール被害が頭痛の種であり、怠慢なサーバ管理者にとっては自分の気がつかぬうちにspam行為の幇助（オープンリレー）をしてしまうトラブルを引き起こすことになった。ORBSは「良識有るサーバ管理者」にはそのspam被害を少しは減らすツールとなり、悪意のない、しかしspam行為を看過している怠慢なサーバ管理者にその自覚を促すシステムとなったのである。
  だが問題性のあるサーバのブラックリスト化は、ブラックリストに載せられた企業からの法的な攻撃を発生させることになった。各種トラブルを経てORBSの名を持つシステムは消滅したが、そのシステムは名前を変えて複数の子孫へと受け継がれることとなる。

参考情報　HOTWIRED　2001/07/02より
「存続の危機を生き延びる迷惑メール防止情報サイト」
http://www.hotwired.co.jp/news/news/20010704202.html

  2003年現在、上記記事の時よりも、より多くの、そして多様なDNSBLシステムが併存し、世界中のサーバ管理者により利用されている。当プラグインではこのブラックリストを二次的に利用している。詳細は松永香澄解説「spamフィルタの仕組み」（オンライン解説）を参照のこと。

「冤罪」［独自］

  スパムメールでないメールがフィルタリングなどでスパムと判定されてしまうこと。ただしスパムメールであるかの判断は必ずしも万人で一致しないので、冤罪かどうかも微妙に意見が分かれる場合もある。

「囮アンテナ」［独自］

  スパムしか届かないメールアドレスから当プラグインで利用するスパム情報を集める手法。松永香澄「囮アンテナについて」オンライン解説を参照のこと。

「特定個人アンテナ」［独自］

  スパムの受信者の多い人々から迅速に情報を得る方式。β版運用時手っ取り早くブラックリストを作成するために導入された。「BkASPilのフィルタリングシステムに関する検討課題」オンライン解説参照のこと。
  囮アンテナの導入により、廃止予定。

「特定アンテナ」［独自］

  当プラグインでの特殊用語。当プラグインは原則的に、多数のユーザに自分の受け取ったspamを登録をして貰うことを前提に作られているが、特定アンテナはそれ以外の手法でスパムを集める手段を指す。「特定個人アンテナ」「囮アンテナ」などがある。

「（spam）ブラックリスト」（「IPBL」「ＢＬ」「spamリスト」）［専門］

  ブラックリストというと一般には「注意人物の一覧」などを指す。spamの場合も同じだが、その際に使う情報は「差出人の名前」「差出人のメールアドレス」「メールのタイトル」「スパム内容の要約」「発信されたサーバ（IPアドレス）」など様々なものが考えられる。ブラックリストに載っていれば「実際にどうかはともかく」スパムと判定し、ブラックリストに載っていなければスパムと判定しない。つまりブラックリストは情報共有型フィルタリングシステムの根幹である。
  当システムの前身である「antispamプラグイン」ではブラックリストの情報として「差出人のメールアドレス」を使用していた。BkASPilでは「発信されたサーバ（IPアドレス）」を使っている。「IPアドレスXXX.XXX.XXX.XXXがブラックリストに入ってしまった」というのは「XXX.XXX.XXX.XXX」から発信されるメールがスパムと判定されてしまうことを示す。

「振り分け」「フィルタリング」［一般］

  受信したメールを、その中身の性質から自動で特定のフォルダに選り分けること。あるいはフォルダに入れないで、完全に削除してしまう場合も言う。当プラグイン（BkASPil）の前身である「antispamプラグイン」では完全に削除する選択設定も導入していたが、spamでないメールをユーザが失うことを恐れ、当プラグインではその設定を無くしている。
  フィルタリングでは「どの段階でフィルタリングするのか」「何を基準にフィルタリングするのか」という二つの大きなポイントがある。「どの段階で」という点に関しては「サーバでの保存の段階」「ユーザのメールソフトでの段階（これを「クライアントのレベルで」などともいう）」の二つが主なものであり、「何を基準に」という点では様々な手法が考えられている。当プラグインが用いている「ユーザ間でのspam情報の共有」「ベイジアンフィルタ方式」などもそれぞれ一手法である。spamフィルタリングでは完璧な手法というのが見つかっておらず、それぞれの手法で長所、欠点がある。可能ならば組み合わせて使うことが効果を発揮する。
  なお、自分がもともと受け取りたいメールを「分類する」という意味のフィルタリングは特に問題ないが、spamフィルタリングのように本来不必要なメールを取り除く為のフィルタリングというのは極めて受動的な対応であり、根本的な解決法ではないという意見もある。

「ホワイトリスト」［専門］

  ブラックリストとの対比として出来た言葉。ブラックリストが「注意すべき人物の一覧」なのに対し、同じ言い方をするならば、ホワイトリストは「絶対に信用できる人物の一覧」「信用する人物の一覧」である。
  ブラックリストは警察が発表する犯罪者リストのようなものだが、一方で、あなたの頭の中にある家族、友人、知り合いなどの中で「絶対に信頼できる人物」「信頼する人物」の一覧がホワイトリストといえる。例えば今、警察が配布していた「犯罪者リスト」を見ていたらあなたのホワイトリストの中の一人が入っていたことに気がついたとする。その後すぐ、彼があなたの家に尋ねてきた。あなたは彼を家に招き入れるだろうか？もし招き入れるなら、その人物はあなたにとって確かにホワイトリストに入っている人物と言える。
  メールでのフィルタリングの場合も全く同様だが、フィルタリングの場合にはブラックリストすなわち「怪しげ人物リスト」があるという前提になっており、そのブラックリストに入っていようがいまいが、信頼する人々のことを指す。「人々」と書いたが「何を」フィルタリングの条件にするかによって異なり、「差出人メールアドレス」「IPアドレス」「タイトル」などいろいろ考えられる。
  当システムは現在「差出人メールアドレス」「IPアドレス」でホワイトリストを作ることができ、その中に入っている差出人からのメールあるいはIPアドレスからのメールは、ブラックリストに入っていてもフィルタリングしない。
  当プラグインでの具体的な手順は手順解説「ホワイトリスト登録を行う」を参照のこと。

「ベイジアンフィルタ（Bayesian Filtering）」

  ベイズ理論（ベイズ統計学）という手法を使い、過去のメールの判定・学習結果から、新たに届いたメールがspamであるかどうか判定する機能を持ったフィルタリング手法。
  具体的には、過去のメール（学習するメール）の本文もしくはメールヘッダから、そこに現れる各単語の出現頻度を単語同士の関連性も含めて数値化し、それらに基づき新しいメール（判定する対象とするメール）に含まれる単語とその組み合わせから、そのメールが過去に「spam」とされたメール群にどれほど近いかを確率的に決定するものである。ベイズ理論の詳細は「スパムフィルタの概要」で紹介しているリンク先などを参照されたい。

［当プラグイン処置依頼作成支援機能に関係する用語］

「abuse窓口」［専門］

  スパム発信など、ネットワークの悪用に関する情報を受け付ける為に、ネットワーク管理者が設けている苦情受付窓口（大概はメールアドレス）。設定するようにRFCで推奨されていると聞く。
  インターネット上での悪用行為には実に様々なものがものがあり、スパム問題はごく一部にしか過ぎない。しかしabuse窓口への苦情ではspamに関するものが多数になっているらしく、海外のネット業者は自社サイトやWhois登録などで「spamや○○に関する苦情はabuse@xxx.comへ」などと明記していることが多い。
  NetworkAbuseClearingHouse略してabuse.netという大変有用なサイトがあり、ドメイン名からそのドメインに関するネット業者の苦情窓口を探すことが出来る。なお、差出人のアドレスは信用できないので、そのアドレスのドメイン名からabuse窓口を見つけ、そこに依頼をすることなどは原則的として行ってはいけない。

「spam処置依頼」（「対処依頼」「処置依頼」「spam報告」「spam苦情」）［独自］

  spamを受信したユーザが、スパム発信者が発信に利用（悪用）したネット業者や、spamで宣伝されたサイトに関係するネット業者に対し、スパム発信行為もしくはスパム発信者に何らかの処罰をするよう、依頼・要求すること。さらにはスパムメール問題を扱う公的機関に対して情報提供を行うことも含む。
  通常、ネット業者は「悪用された」だけなので、「苦情」という若干強い言葉は控え、「処置依頼」「報告」などと言ったりする。
  一番理想的なのは「報告」で済むことである。すなわち「報告」しただけで、そのspamとスパム発信者への処分に東奔西走してくれるネット業者にはまさしく「報告」だけで良いからだ。
  だがネット業者の中には「はい、そうですか、その問題は当社とは無関係です。当社の顧客とあなた様の問題です。御報告有り難うございました」などと言う、本当に「報告」で終わらせようとするネット業者が、昔はしばしば、現在でも希に存在し、そういう場合にははっきりと「処置依頼」だと分かる文面を送らねばならない。
  そして何回も処置依頼をしても同じネット業者からのスパム発信が繰り返されたり、根本的な解決を試みるような姿勢が見えないと、当然のことながらspam受信被害者の口調は「苦情」になっていく。
  ただしどんなに強い口調になっても、あまりにヒステリックになったり、罵詈雑言を浴びせたり、ネット業者とスパム発信者が同罪であるような書き方は慎んだ方が良い。担当者も人間であり、感情的な苦情メールは決してネット業者に前向きに取り組む気力を起こさせず、むしろ処置依頼者達への反感を強めるだけだからだ。

「メールヘッダ解析」［独自］

  メールヘッダからspam対応で必要な各種情報を読みとること。代表的なものとして、メールの発信元あるいは中継元サーバのIPアドレスを見つけることなどがある。
  メールヘッダでは捏造、偽造できる部分も多いので注意する必要がある。

「ユーザ登録」［独自］

  当プラグインを使用する際に開発チームにユーザとしての登録を行うこと。BkASPilではspam処置依頼支援機能を使うために必要。詳しくは「ユーザ登録について」を参照のこと。

「上策、中策、下策の苦情先」［独自］

  メールヘッダ解析ツール制作者の一人Ｔが勝手に呼ぶようになったもので「分かりにくい」と不評もある。処置依頼窓口を探す蔡に、いろいろなメールアドレスが出てくるが、適切さに応じて呼んだ言葉である。厳密に解説すると以下のようになる。

  • 「上策のメールアドレス」
      ネット業者自身が、そのメールアドレスを自社の苦情窓口として認識し、公開しているもの（abuse＠云々などが多い）。世界レベルではメールの苦情といえばスパムが代表的なので、このような窓口を用意しているネット業者はスパムへの問題意識を比較的持っていると考えて良く、一応前向きな対処が期待できる。
    （ただし厳重なスパム対応、対処をしているかは別。）
  • 「中策のメールアドレス」
      上策のメールアドレスを設けていない場合に、GeekToolsなどのWhois結果で出てくる「管理人のアドレス」のことを指している。比較的、個人アドレスすなわち担当者のメールアドレスであることが多い。
      本来、このメールアドレスはスパムには限らない、そのIPアドレスに関する各種問題が発生したときの連絡窓口であり、原則としてIP登録の際には必ず届け出なければならないものである。
      IP登録を行っている全てのネット業者がスパムへの意識が高いとは限らず、このメールアドレスへ送ってもきちんと対処してくれるかは分からないという点で（私は）中策と呼んでいる。
      しかし、本来、ネットワーク管理者はスパムに関して対応する責任を持つので、スパム苦情をこの人に出すのは間違いでは全くない。仮に、別な正式な窓口（上策に相当するもの）があったとしても、中策のメールアドレスは同じ会社の人であるから転送してくれるはずである。
  • 「下策のメールアドレス」
      通常は必ず上策、中策が見つかる。希にそれらがない場合に、Whois結果などからみつけたアドレスに送るしかない。場合によっては一応、関係者の苦情先であることもあれば、次の「論外のメールアドレス」である危険性もあるので注意すべきである。
  • 論外のメールアドレス、間違ったメールアドレス
      明らかに送っても仕方のない連絡先。NICのアドレスや、明らかに詐称されたヘッダの情報に基づいて送る苦情先。先方にとってまさしく「迷惑なメール」になってしまうので避けるべきものである。

［その他の用語］

「antispamプラグイン」［独自］

  当プラグインBkASPilの前身。2002年12月にBNR32氏が発案、製作開始した。ユーザ間でspamの情報（具体的には発信者のメールアドレス）を共有化することを特徴とした。2003年８月本プラグインBkASPilの正式リリースにより停止。詳しくは「当プラグインの歴史」にて。

「HT（Hyper-Threading）」［一般］

（2003年現在）IntelのPentium4の3.06GHz以上のCPUで装備された技術。一つのプロセッサで２つの処理を平行に行うことが出来るシステム技術。言い換えれば一つの物理的なプロセッサを２つのプロセッサに見せかける方法（らしい）。この機能を備えたCPUのパソコンで当プラグインを使うときにはプラグイン設定「高度な設定」タブで「安定化モードにする」をチェックすることが必要。

「メールボックス」［一般］

  電子メールを保存しておく所。受信者の立場から見たとき、電子メールは

（Ａ）発信者の手元→（Ｂ）受信者のプロバイダーのコンピュータ(一般に「サーバ」という)→（Ｃ）受信者自身のコンピュータ

の流れで届く。一般的にＢの場所にはユーザ毎のメールボックス領域が確保されており、ユーザは定期的にこの領域にメールが届いているかどうかを確認しに行くという方式になっている（実際に確認してくれるのはメールソフトがやってくれるわけだが．．．）。メールが届いている場合、そのメールを受信者自身のコンピュータであるＣのメールソフトに持って来て閲覧するのが標準的な電子メール受信方法である（2003年現在）。
  このように見ると、受信者が見に行くまで保存されているプロバイダー（Ｂ）のメールデータ領域も、その後メールを取り込んだ自分のパソコン（Ｃ）のメールデータ領域も「メールボックス」であると言うことができ、実際に両者とも「メールボックス」と呼ぶことが多い。使う際にはどちらであるか意識しておくことが大事。
  なおＣの場合でも、同じメールソフトで複数のメールアカウント（メールアドレス）を管理していると更に少しややこしくなる。複数のアカウントごとにメールデータの保存領域が分かれている場合、それぞれを個別のメールボックスと見なすことがあるが、その一方でそれらのメールボックスが集まった、某氏のメールデータが入っている全て一体のものを一つのメールボックスと考える場合があるからだ。
  Becky!一般の場合、それをインストールするとユーザ某のメールデータを入れるフォルダ（ユーザが任意に名前をつける）が確保されるわけだが、普通はついついこの領域をユーザ別のメールボックスと言ってしまう。ところが、その下に作ったアカウント別のフォルダもBecky!ではやはりメールボックスという用語を使うようで、というのもそれらのフォルダには「．ｍｂ」という拡張子がついており、これは「MailBox」の略だと考えられるからだ。
  いずれにせよ、「メールボックス」の言葉が使われたときに、どこのことを指しているのか意識しておくのが大切。

「メールアカウント」［一般］

  メール送受信に関してユーザに与えられた権利（？）の一つ分（？）のこと。「メールアカウントを貰った」「複数のメールアカウントを持っている」などというように使う。
  「メールアドレス」と呼び替える方が理解しやすく、またそれとほとんど同義で使うことも多いが「メールアカウント」と呼ぶと「メールアドレスを使う為の権利」のような感じがある。その結果、「君のメールアドレスを教えて」とは言っても「君のメールアカウントを教えて」とは（多分）言わない。

「プラグイン」［一般］

  「プラグイン(Plug-In)」とは母体のソフト（当プラグインではBecky!InternetMail）に新たな機能を追加したり、動作を変更したりすることができるようにするための追加ソフトのこと。ソフトというと独立したイメージがあるが、プラグインの場合には母体のソフトの存在があって初めて機能するものであることから「追加モジュール」「追加プログラム」「追加部品」などと呼ぶのが適当かもしれない。

「マウスジェスチャー」［一般］

  通常のマウスの機能に加えて、クリック（一回マウスのボタンを押す）やドラッグ（選択してボタンを抑えながら移動する）に特別な意味（命令）を与えるようにすること。参考資料「マウスジェスチャーについて」を参照のこと。

「β版」（べーたばん）［一般］

  ソフトウェア、アプリケーションなどが正式公開前に配布し、テストユーザに利用して貰い、その中で不具合（バグ）などを調整する版のこと。さらに実験段階の版として「α版（あるふぁばん）」というのが作られることもある。
  当プラグインでは2003年５月17日からβ版が開始され、正式版は８月より配布された。

「完全削除」［独自］

  ソフトウェアをアンインストール（パソコンからの除去）をする際に、出来る限りそのソフトに関係する全てのデータを削除すること。
  当プラグインでは「完全削除と原因究明」を参照のこと。


個人情報取扱指針・目的

個人情報取扱指針・当プラグインの目的

  当開発チームはこのツールを利用されるユーザの方々からの各種情報（ユーザの個人情報等を含む）を以下の方針に基づいて利用させて頂くこととします。

  • ［当プラグインの目的］
      当プラグインの目的は、電子メールユーザの「一方的迷惑広告メール（スパム・spam）」被害を少しでも回避・軽減し、同時にスパム問題の根本的解決を目指すことにあります。
  • ［当プラグイン取得情報の利用指針］
      当プラグインにより集める各種情報は、上記目的を前提とするプラグイン性能向上の為に利用されます。当プラグイン以外のスパム問題解決の為に利用されることもあります。この可能性の中には第三者への情報提供も含まれますが、その場合には後述の「プライバシー保護」の観点を重視いたします。
      上記入手情報が「当プラグインの目的」を逸脱する、私的な利益獲得の為に使われることはありません。
      なお、司法関係機関からの正式な要請があった場合には「当プラグインの目的」に沿うか否かに拘わらず、それらの司法関係機関に情報を提供する可能性もあります。しかし「当プラグインの目的」以外の為に、当チーム全体もしくはそのメンバーが積極的に司法関係機関への情報提供を行うことはありません。
  • ［皆様の想定範囲内での利用（目的外利用の忌避）］
          皆様から頂く情報は、提供者の方々の想定する範囲以外の目的で使わないように致します。「提供者の方々の想定する範囲」とは社会的常識を土台として考えます。
      スパム発信者の行動の問題の一つには、インターネット上で公開されている個人情報（メールアドレス）の想定外・目的外利用にあります。当プラグインはスパム問題の解決を目指すツールとして、この点の問題性に特に配慮することと致します。
  • ［プライバシー保護］
          頂いた情報はプライバシー保護の観点からも注意深く取り扱います。すなわち、提供された情報を開発チームおよびそのメンバーが「当プラグインの目的」の為、第三者に提供することが必要になった場合でも、それらの情報はあくまで匿名者の情報として提供されます。
      また、第三者への情報提供の影響が大きいと考えられる場合で、元の提供者の方（ユーザ）の連絡先（メールアドレスなど）を当チームが知っている時には、提供者の方に事前の御連絡をさせて頂くように心がけます。
  • ［情報の守秘］
      上記個人情報は当サイトにおいて当チームおよびメンバーのみが閲覧可能にし、極力第三者が閲覧できないような措置を取ります。
      ただし提供して頂く際には基本的に暗号化をせずに送ることがほとんどです。暗号化をしないでネット上に情報を流すリスクに関しては他の資料を参考にして下さい。

  なお、開発チームがサイト上で提供しているサイトでも、各々、個人情報取扱指針などを定めている場合がありますので「関連サイトリンク」を参照して下さい。


開発チームについて

当プラグインのチームのメンバーは2003年05月現在、下記の３者で構成されています。

  • BNR32
  • 松永香澄
  • 高崎真哉


関連サイトリンク

BkASPil for Becky!2 総合案内
  http://b2antispam.s33.xrea.com/

RedWing's HomePage
  BkASPil プラグイン制作者の BNR32 のサイトです。

IP Cache DB for BkASPil Plug-In
  プラグインが利用するブラックリストを管理している松永香澄のサイトです。ブラックリスト管理の仕組みについての情報や、ブラックリストの検索はこちらから。

BkASPil プラグイン私的解説
   BkASPil の紹介などがある高崎のページです。以前にここにあった「spam処置以来支援機能」の解説は、当プラグイン解説書（ヘルプ）に吸収されました。


当プラグインの歴史/雑誌紹介など

「道徳においては進歩なるものを仮定することは不可能である。 なぜなら道徳はあまりに密接に人格と結びついているから」　－　L.v.ランケ[1795-1886](独:歴史学者)『世界史概観』

  リンク掲載、雑誌紹介など(★)をして下さった方々には深く感謝いたします。

2005年５月
  ★『ネットランナー６月号』にて紹介。
  ★『PCfan』にて紹介。

2005年２月
  日本語メールもベイジアンフィルタ方式に正式対応。なお、本家Becky!のフィルタリングマネージャに関しても重要な変更がされています。（参考→「ユーザ独自のフィルタリング条件を追加出来るようにしてほしいのですが。」）

200５年１月
  ★『フリーウェア年鑑2005』にて紹介。

2004年10月
  ★『Yahoo!BBマガジン12月号』にて紹介。

2004年９月
  ★『ネットランナー９月号』にて紹介。
  ・『アスキーダッシュ』にて紹介？

2004年８月
  ベイジアンフィルタ方式を用いた正式バージョンVer.2.00を提供開始（ただしベイジアンフィルタ方式部分は英語のみ）。それに伴いヘルプ全面改定。

2003年１月
  フィルタリング機能にベイジアンフィルタも併用した試験版（α版）を提供開始。

2003年12月
  ★『日経Windowsプロ』（日経BP社）に掲載。
  ★『DiGi/USER』２月号（宝島社）に掲載とのこと（未確認）。その後、継続の模様。
  ★『ラジオライフ』2004年1月号（三才ブックス）に掲載とのこと（未確認）。
  ★『WindowsStart 2月号』（毎日コミュニケーションズ）に掲載とのこと（未確認）。
  ★窓の杜「2003年 窓の杜大賞」候補としてノミネート。

2003年11月
  ★窓の杜ソフトライブラリ2003年11月版に掲載。ライブラリページに掲載。その後、継続の模様。
  サポート掲示板設置。

2003年９月
  事情により当プラグインＭＬを廃止。御協力有り難うございました。

2003年８月下旬
  フィルタリングにDNSBLを使ったリニューアルバージョンBkASPilを正式提供開始。解説書（ヘルプ）提供。

2003年５月
  BNR32の頁、処置依頼総支援機能解説など、分散しがちだった当プラグインの解説頁に関し、共同管理可能なサイトを確保し、総合案内頁を設置。フィルタリング機能を一新したリニューアル版のβ版の提供を開始。

2003年３月
  具体的なフィルタリング改善意見が出される中で、沢渡みかげ氏の友人である松永香澄氏が当プラグインＭＬに参加、フィルタリング部分における開発等の協力を申し出る。その内容上、BNR32氏の単独による開発が困難になったことから、正式にチームにより開発を進めることを決定。

2003年２月
  当月後半までに高崎の満足するspam処置依頼支援機能がほぼ装備。高崎はspam処置依頼支援機能部分の解説頁を提供。
  月末、沢渡みかげ氏が当プラグインＭＬに参加し、フィルタリング機能を充実させる提案・要望が出される（みかげ氏以外にも類似意見・希望は出されていたが．．．）。

2003年1月
  高崎がユーザとして当プラグインＭＬに参加。高崎がspam処置依頼支援機能の一層の拡大を希望、BNR32がその数々の要望を受け入れながら、その機能の面の充実が図られる。

2002年12月
  BNR32によって開発・提供がanispam-jにて公表、開始。12日、当プラグイン用のメーリングリスト「B2antispamプラグイン情報メーリングリスト」（以下、当プラグインMLと略）がBNR32氏により設立、BNR32による情報提供、ユーザ同士の情報交換が開始。26日「スパム反対運動ML」にてBNR32氏が当プラグインを公表、告知。
  当初、antispamプラグインは、ユーザ間でspamに関する情報を共有しフィルタリングに使う、という点を主な目玉にして提供が開始されたが「スパム反対運動ML」上の意見交換にてBNR32氏はspam処置依頼支援機能の充実を検討し始め、対スパムツール集との連携を開始。


 ▲Becky2 BkASPil プラグイン 総合ページへ

BkASPil解説書（ヘルプ）　[　]の日付は最終改訂日

■質問集(FAQ) [2005/08/01]

■はじめに－BkASPilの概略 [2004/08/06]
■特徴・機能と動作環境、著作権 [2005/08/01]
■重要告知と新機能・修正点 [2005/08/01]
■この解説書(ヘルプ)についての情報 [2005/08/01]

■基本事項
  プラグインのインストール　[2004/01/19]
  プラグインの削除 [2005/08/01]
  導入した際に不具合が発生したら（１）　一時停止 [2005/08/01]
  導入した際に不具合が発生したら（２）　完全削除と原因究明 [2005/08/01]

■フィルタリング機能のしくみ（予定：現段階ではこちらを参照して下さい）
  基本的な仕組み
  ブラックリスト参照フィルタの解説
  ベイジアンフィルタの解説

■フィルタリング機能を使う
  スパムフィルタの概要 [2005/08/01]
  フィルタリング機能の基本設定（重要）
  振り分けされなかったメールをspam登録・学習する [2004/08/06]
   誤ったspam判定を訂正する [2004/08/06]
  ホワイトリストに登録する [2005/08/01]
   ●その他の機能
      既に受信したメールを改めて振り分ける [2004/01/21]
      spam登録されているかを確認する
      フィルタリング機能の停止

■処置依頼支援機能を使う
    そもそも処置依頼とは
    当システムの構造
    ユーザ登録について
    基本設定
    ●abuse窓口に送る
        メールヘッダを解析する
        abuse窓口メールアドレスを探す
        テンプレートの選択
        メール内容の確認
    ●関係官庁に送る
        官庁への連絡・報告について
        メールの作成と確認
    ●サイト関係ネット業者に送る
        URLの解析を行う
        abuse窓口メールアドレスを探す
        メールの作成と確認
    ●SpamCopに送る
        SpamCopとは
        準備（SpamCopへの登録と当プラグインへの登録）
        SpamCopにspamを転送する
        返信メールのリンク先を参照する

■画面解説
    プラグイン設定画面の表示方法
    プラグインの設定「設定」タブ
    プラグインの設定「高度な設定」タブ
       1_SpamFilter関係の設定 [2005/08/01]
      2-1_Bayesianの設定１ [2005/08/01]
       2-2_Bayesianの設定２ [2005/08/01]
      3_拒否TLDの設定 [2005/08/01]
      4_プロキシサーバの設定 [2005/08/01]
      5_処置依頼関連の設定 [2005/08/01]
       6_その他の設定 [2005/08/01]
    プラグインの設定「SpamCop登録状況」タブ
    プラグインの設定「ホワイトリスト」タブ [2005/08/01]
    プラグインの設定「Report」タブ
    プラグインの設定「about」タブ
    メイン画面での各部名称
    ツリービューでの右クリック
    リストビューでの右クリック [2004/08/06]
    メッセージビューでの右クリック [2004/08/06]

■参考資料
    spam処置依頼の正当性
    ドメインとIPアドレスの関係
    メールボックスとPlugInフォルダの位置 [2004/01/21]
    マウスジェスチャーについて
    GeekToolsWhois日本語版の使い方
    spamの宣伝サイトの閲覧とソース
    フィルタリングマネージャのルール別「タイミング」設定 [2005/08/01]

■質問集(FAQ) [2005/08/01]

■用語解説 [2005/08/01]

■その他
    個人情報取扱指針・目的
    開発チームについて
    関連サイトリンク
    当プラグインの歴史